Navigation screen black! Help!!!! - Page 5 - ClubLexus - Lexus Forum Discussion


IS - 2nd Gen (2006-2013) Discussion about the 2006+ model IS models

Navigation screen black! Help!!!!

Reply
 
 
 
Thread Tools Search this Thread
Old 11-01-17, 03:07 PM   #61
Bigham
Driver School Candidate
 
Join Date: Oct 2017
Location: Texas
Posts: 7
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pdpdavid View Post
I've read this thread up and down for the last few weeks. I've been on aliexpress several times and like sergeblr, asking a few of the sellers on there don't have them in supply when i ask them specifically for the IS. Or has anyone bought a board for the (1/2) or (2/2) and gotten it to work?

Anyone think they can help with leads?
I ordered a PCB display board from Aliexpress and MY NAVIGATION IS FULLY WORKING AGAIN!!!!

Best advice is to open your navigation system up and to take a picture of your original PCB display board thing so you can match it up with the ones on aliexpress.
Bigham is offline   Reply With Quote
Old 11-02-17, 11:44 PM   #62
pdpdavid
Driver School Candidate
iTrader: (1)
 
Join Date: Dec 2009
Location: CA: 323/626/818
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Bigham View Post
I ordered a PCB display board from Aliexpress and MY NAVIGATION IS FULLY WORKING AGAIN!!!!

Best advice is to open your navigation system up and to take a picture of your original PCB display board thing so you can match it up with the ones on aliexpress.
Mine's an '08. I've taken the center console out and looked in the back, and since there's only one blue connector, I assume it would exactly be like the pictures that whitebeast posted earlier.

Which seller did you purchase from? got a link?
pdpdavid is offline   Reply With Quote
Old 11-03-17, 06:40 AM   #63
See5
Pole Position
 
Join Date: Nov 2012
Location: NY
Posts: 267
Thanked 2 Times in 1 Post
Default

Guys my PCB board is out as well.

Can you please share links on where to buy the correct one for 07 2IS with Nav + ML DVD system (full option) ?

Many thanks
See5 is offline   Reply With Quote
Old 11-04-17, 12:17 AM   #64
1quickf4i
Driver School Candidate
 
Join Date: Jul 2017
Location: WA
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by whitebeast View Post
Well, the problem you have is not the same. We are talking about the whole top unit went black, No A/C control or none of the buttons light up at night.
The problem you have is MAP ECU failure, This should be easy case and less money to fix it. You could also buy the NAVIGATION PLAYER to replaced your failure one.
Yeah since then none of hvac or a/c navi is off sounds like i need new pcb board read all the posts now, i have 2006 is there a specific one i should order
would this one work for my year, thanks
https://opuradio.com/products-detail.php?ProId=771
1quickf4i is offline   Reply With Quote
Old 11-05-17, 12:14 AM   #65
whitebeast
Lexus Champion
iTrader: (5)
 
whitebeast's Avatar
 
Join Date: May 2011
Location: CA
Posts: 2,579
Thanks: 0
Thanked 35 Times in 35 Posts
Default

It’s good one. Buy it and you are good to go!!!
whitebeast is offline   Reply With Quote
Old 11-05-17, 01:28 AM   #66
1quickf4i
Driver School Candidate
 
Join Date: Jul 2017
Location: WA
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by whitebeast View Post
It’s good one. Buy it and you are good to go!!!
Should i apply better paste like silver to it?
ok thank you

Last edited by 1quickf4i; 11-05-17 at 01:42 AM.
1quickf4i is offline   Reply With Quote
Old 11-06-17, 06:54 AM   #67
whitebeast
Lexus Champion
iTrader: (5)
 
whitebeast's Avatar
 
Join Date: May 2011
Location: CA
Posts: 2,579
Thanks: 0
Thanked 35 Times in 35 Posts
Default

That is what I did. Clean the fan, remove all the old paste, and apply new paste
whitebeast is offline   Reply With Quote
Old 11-07-17, 05:54 PM   #68
5nX37
Driver
 
Join Date: Sep 2014
Location: California
Posts: 135
Thanks: 0
Thanked 1 Time in 1 Post
Default

Same here. Black screen no Nav, HVAC, or reverse camera. Mine has been sporadic but lately has been occurring more often. Got an 06 IS350 non-ML. Are they all the same PCB or is it model specific? Pls help with source on how to find the part for this. Need it bad this is my daily and “winter is coming!”
5nX37 is offline   Reply With Quote
Old 11-08-17, 05:15 PM   #69
whitebeast
Lexus Champion
iTrader: (5)
 
whitebeast's Avatar
 
Join Date: May 2011
Location: CA
Posts: 2,579
Thanks: 0
Thanked 35 Times in 35 Posts
Default

PM me for more info. I could help you out on finding part for your car
whitebeast is offline   Reply With Quote
Old 11-11-17, 10:02 PM   #70
pdpdavid
Driver School Candidate
iTrader: (1)
 
Join Date: Dec 2009
Location: CA: 323/626/818
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 1quickf4i View Post
Yeah since then none of hvac or a/c navi is off sounds like i need new pcb board read all the posts now, i have 2006 is there a specific one i should order
would this one work for my year, thanks
https://opuradio.com/products-detail.php?ProId=771
did you get confirmation of a board? i sent them a message via alibaba, since they (same email and skype usernames) sell the same product on alibaba as well https://www.aliexpress.com/store/pro...712231137.html and they told me no stock. please let me know. thanks.
pdpdavid is offline   Reply With Quote
Old 11-12-17, 09:29 AM   #71
1quickf4i
Driver School Candidate
 
Join Date: Jul 2017
Location: WA
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pdpdavid View Post
did you get confirmation of a board? i sent them a message via alibaba, since they (same email and skype usernames) sell the same product on alibaba as well https://www.aliexpress.com/store/pro...712231137.html and they told me no stock. please let me know. thanks.
Ended up paying little more but i got it shipped pretty quick installed and boom everything works again, applied the silver instead of that tooth rubbery paste. You guys been a big help thank you.
P.s. i've noticed the gold back plate was missing on this one didn't come with like the original or the picture showed.
1quickf4i is offline   Reply With Quote
Old 11-12-17, 12:03 PM   #72
pdpdavid
Driver School Candidate
iTrader: (1)
 
Join Date: Dec 2009
Location: CA: 323/626/818
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 1quickf4i View Post
Ended up paying little more but i got it shipped pretty quick installed and boom everything works again, applied the silver instead of that tooth rubbery paste. You guys been a big help thank you.
P.s. i've noticed the gold back plate was missing on this one didn't come with like the original or the picture showed.
Thanks for the quick response that their board works, which in turn you get yours working again!
pdpdavid is offline   Reply With Quote
Old 11-13-17, 02:46 PM   #73
5nX37
Driver
 
Join Date: Sep 2014
Location: California
Posts: 135
Thanks: 0
Thanked 1 Time in 1 Post
Default silver??

Quote:
Originally Posted by 1quickf4i View Post
Ended up paying little more but i got it shipped pretty quick installed and boom everything works again, applied the silver instead of that tooth rubbery paste. You guys been a big help thank you.
P.s. i've noticed the gold back plate was missing on this one didn't come with like the original or the picture showed.
What do u guys mean by this?
5nX37 is offline   Reply With Quote
Old 11-13-17, 10:11 PM   #74
whitebeast
Lexus Champion
iTrader: (5)
 
whitebeast's Avatar
 
Join Date: May 2011
Location: CA
Posts: 2,579
Thanks: 0
Thanked 35 Times in 35 Posts
Default

Nothing to worry about it. Lot of members here got it and confirmed it working great unless you want to pay little extra for local service with warranty
whitebeast is offline   Reply With Quote
Old 11-14-17, 09:36 PM   #75
pdpdavid
Driver School Candidate
iTrader: (1)
 
Join Date: Dec 2009
Location: CA: 323/626/818
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by whitebeast View Post
Nothing to worry about it. Lot of members here got it and confirmed it working great unless you want to pay little extra for local service with warranty
whitebeast, just double checking, this one here should work, right? https://www.aliexpress.com/store/pro...712231137.html

with alibaba/aliexpress having several days of sales, i can save a little and put it towards better/faster shipping. thanks.
pdpdavid is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2006 GS Nav Screen jmcafee GS - 3rd Gen (2006-2011) 3 10-24-17 10:54 AM
Navigation screen black...🤔 Lhduran IS - 3rd Gen (2014-present) 1 07-22-17 06:55 PM
Radio cuts out when applying brakes. akafixture GS - 2nd Gen (1998-2005) 7 11-08-16 06:58 PM
My ES300h - 2015 Navigation screen keeps rebooting vbhade ES - 6th Gen (2013-present) 5 06-10-16 12:32 PM
Car died while driving (alternator, again?) 92 SC400 IS - 2nd Gen (2006-2013) 9 05-25-16 01:49 PM


Tags
06 , 350 , black , controls , fuse , heat , heater , is250 , is350 , lexus , navigation , radio , rx , screen , white

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 08:10 PM.


Copyright © 2000-2017 Internet Brands, Inc. All Rights Reserved We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: