Go Back  ClubLexus - Lexus Forum Discussion > Lexus Model Forums > IS Models > IS - 3rd Gen (2014-present)
Invidia axle back + midpipe set up, does this effect O2 sensors? >

Invidia axle back + midpipe set up, does this effect O2 sensors?

Notices
IS - 3rd Gen (2014-present) Discussion about the 2014+ model IS models

Invidia axle back + midpipe set up, does this effect O2 sensors?

 
Old 04-13-19, 11:07 PM
  #1  
swaangin
Pole Position
Thread Starter
 
Join Date: Sep 2017
Location: cali
Posts: 205
Received 7 Likes on 7 Posts
Default Invidia axle back + midpipe set up, does this effect O2 sensors?

Fast forward to 1:58 to hear it
Amazon Amazon
Amazon Amazon

$1200 for this exhaust + install cost.. just a question though, I know the axleback is after the O2 sensors so that's not the issue but the mid pipe says it deletes the cats.. how does this effect the car? Can a check engine light come of this?

Sounds amazing IMO with midpipe
swaangin is offline  
Old 04-14-19, 01:09 AM
  #2  
ChineseKFC
Rookie
 
Join Date: Aug 2015
Location: British Columbia
Posts: 52
Received 2 Likes on 2 Posts
Default

i have the full exhaust, no lights no issues.
ChineseKFC is offline  
Old 04-14-19, 02:31 AM
  #3  
ex00
Driver
 
Join Date: Mar 2018
Location: HI
Posts: 173
Received 11 Likes on 11 Posts
Default

You shouldn't have any O2 issues unless downpipe but that is resolved based on what you get.
ex00 is offline  
Old 05-15-19, 12:59 PM
  #4  
babiibryan
Rookie
 
Join Date: Nov 2017
Location: CA
Posts: 58
Received 0 Likes on 0 Posts
Default

I just changed the midpipe and the axle back (the same parts from Invidia that was from the video) to my IS250. Driving for 130 miles and I have the check engine light turns on. The code diagnostic is P013C which related to the slow response of the O2 sensor. Not sure what to do now
babiibryan is offline  
Old 05-15-19, 01:21 PM
  #5  
AtomicAWD
Lead Lap
 
Join Date: Dec 2018
Location: BC
Posts: 601
Received 57 Likes on 47 Posts
Default

Originally Posted by babiibryan View Post
I just changed the midpipe and the axle back (the same parts from Invidia that was from the video) to my IS250. Driving for 130 miles and I have the check engine light turns on. The code diagnostic is P013C which related to the slow response of the O2 sensor. Not sure what to do now
Wait and see if the light goes off, or clear it if you want and see if it returns. Mine came on and went off about 3 times with a similar code, but has not come back for about 3 weeks now.
AtomicAWD is offline  
Old 05-15-19, 01:43 PM
  #6  
babiibryan
Rookie
 
Join Date: Nov 2017
Location: CA
Posts: 58
Received 0 Likes on 0 Posts
Default

Originally Posted by AtomicAWD View Post
Wait and see if the light goes off, or clear it if you want and see if it returns. Mine came on and went off about 3 times with a similar code, but has not come back for about 3 weeks now.
It already went off after staying on for 3 hours, but I still diagnose a code P013C by the OBDii. I really want to see if the Invidia midpipe and axle back cause the problem or the O2 sensor itself is bad and cause the problem or the installation causes the leaking problem.
Look like we share the same problem. It might be from the Invidia parts.
babiibryan is offline  
Old 05-15-19, 02:13 PM
  #7  
AtomicAWD
Lead Lap
 
Join Date: Dec 2018
Location: BC
Posts: 601
Received 57 Likes on 47 Posts
Default

Originally Posted by babiibryan View Post
It already went off after staying on for 3 hours, but I still diagnose a code P013C by the OBDii. I really want to see if the Invidia midpipe and axle back cause the problem or the O2 sensor itself is bad and cause the problem or the installation causes the leaking problem.
Look like we share the same problem. It might be from the Invidia parts.
Apparently it's not uncommon, at least for the Tsudo, the usual fix being OEM gaskets. I bought them only to find the light hasn't come back on. If it does I'll install them.
AtomicAWD is offline  
Old 05-15-19, 02:41 PM
  #8  
ChineseKFC
Rookie
 
Join Date: Aug 2015
Location: British Columbia
Posts: 52
Received 2 Likes on 2 Posts
Default

Originally Posted by babiibryan View Post
It already went off after staying on for 3 hours, but I still diagnose a code P013C by the OBDii. I really want to see if the Invidia midpipe and axle back cause the problem or the O2 sensor itself is bad and cause the problem or the installation causes the leaking problem.
Look like we share the same problem. It might be from the Invidia parts.
Most likely Iíll pin it on the gaskets, however I believe the RR racing tune can code it out.
ChineseKFC is offline  
Old 05-15-19, 02:51 PM
  #9  
babiibryan
Rookie
 
Join Date: Nov 2017
Location: CA
Posts: 58
Received 0 Likes on 0 Posts
Default

Originally Posted by AtomicAWD View Post
Apparently it's not uncommon, at least for the Tsudo, the usual fix being OEM gaskets. I bought them only to find the light hasn't come back on. If it does I'll install them.
Oh you have Tsudo, not Invidia but you also get the code P013C too. Do you have the part number for the OEM gasket?
babiibryan is offline  
Old 05-15-19, 02:51 PM
  #10  
babiibryan
Rookie
 
Join Date: Nov 2017
Location: CA
Posts: 58
Received 0 Likes on 0 Posts
Default

Originally Posted by ChineseKFC View Post
Most likely Iíll pin it on the gaskets, however I believe the RR racing tune can code it out.
I am sorry I am noob. Do you mind to explain what is RR racing tune?
babiibryan is offline  
Old 05-15-19, 03:29 PM
  #11  
AtomicAWD
Lead Lap
 
Join Date: Dec 2018
Location: BC
Posts: 601
Received 57 Likes on 47 Posts
Default

Originally Posted by babiibryan View Post
Oh you have Tsudo, not Invidia but you also get the code P013C too. Do you have the part number for the OEM gasket?
Yes, but the Tsudo and Invidia are very similar. Don't have the part number off-hand, just asked the parts guy to look it up and order. I think I actually got a couple different codes, from both sides.
AtomicAWD is offline  
Old 05-17-19, 11:23 AM
  #12  
Pittsy
Lead Lap
 
Pittsy's Avatar
 
Join Date: Aug 2018
Location: Arizona
Posts: 647
Received 51 Likes on 47 Posts
Default

Originally Posted by babiibryan View Post
I am sorry I am noob. Do you mind to explain what is RR racing tune?
RRRacing ing is the main tuner for our engines. It adds power, increases torque and power all the way to the top end, and it also removes the CEL for exhaust related OBDII codes. Rafi can comment more on here. It's an amazing product.
Pittsy is offline  
 


Thread Tools
Search this Thread
Quick Reply: Invidia axle back + midpipe set up, does this effect O2 sensors?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: