Do you have a noisy fuel pump?? - ClubLexus - Lexus Enthusiast Forums


Do you have a noisy fuel pump??

Reply
 
 
 
Thread Tools Search this Thread
Old 01-19-12, 01:25 PM   #1
gtsfire
Lead Lap
Thread Starter
iTrader: (4)
 
gtsfire's Avatar
 
Join Date: Nov 2009
Location: DFW Tx
Posts: 464
Thanks: 0
Thanked 0 Times in 0 Posts
Default Do you have a noisy fuel pump??

Bought my buddy's 92 SC400:



He owned it for a couple of years. He replaced the fuel pump twice. This last pump has been annoying loud ever since he installed it. I don't mean a loud whine, but terrible cavitating noises.

So I'm at my friends shop this morning swapping out the driveshaft and I just happen to look up and see this:



What...the...F---? It had to be pry'd off with a large screwdriver and who knows how long it's been there. Neither me nor my bud put it there.

It's amazing how much better the car starts and runs and how delightfully quiet the fuel pump is.

So if you have a noisy fuel pump, check for a pair of vice grips on the return line!
gtsfire is offline   Reply With Quote
Old 01-19-12, 01:32 PM   #2
Tabaka
Lexus Champion
iTrader: (8)
 
Join Date: Mar 2010
Location: Dale City, VA
Posts: 3,811
Thanks: 0
Thanked 0 Times in 0 Posts
Default

LOL, can't say I've ever seen that. Who knows how long that's been starving the car.
Tabaka is offline   Reply With Quote
Old 01-19-12, 01:35 PM   #3
97-SC300
Lexus Fanatic
iTrader: (17)
 
97-SC300's Avatar
 
Join Date: Jun 2006
Location: Illinois
Posts: 8,447
Thanked 45 Times in 38 Posts
Default

what the hell?
97-SC300 is offline   Reply With Quote
Old 01-19-12, 01:45 PM   #4
afro88
Driver School Candidate
 
afro88's Avatar
 
Join Date: Nov 2011
Location: CO
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

LOL he replaced his fuel pump that many times and never thought to check the lines? haha
afro88 is offline   Reply With Quote
Old 01-19-12, 02:18 PM   #5
vinh
Lexus Champion
iTrader: (8)
 
Join Date: Dec 2003
Location: California
Posts: 2,602
Thanks: 0
Thanked 0 Times in 0 Posts
Default

what on earth hahaha
vinh is offline   Reply With Quote
Old 01-19-12, 03:35 PM   #6
stockhatch
Lexus Champion
iTrader: (12)
 
stockhatch's Avatar
 
Join Date: May 2009
Location: Southport NC
Posts: 2,541
Thanks: 0
Thanked 1 Time in 1 Post
Default

Somebody replaced the fuel filter i guess? LOL That's awesome!
stockhatch is offline   Reply With Quote
Old 01-19-12, 03:38 PM   #7
gtsfire
Lead Lap
Thread Starter
iTrader: (4)
 
gtsfire's Avatar
 
Join Date: Nov 2009
Location: DFW Tx
Posts: 464
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by afro88 View Post
LOL he replaced his fuel pump that many times and never thought to check the lines? haha
No because both pumps we tested and bad. If you'd heard the noise the current one WAS making you'd understand. It was stressed!
gtsfire is offline   Reply With Quote
Old 01-19-12, 04:03 PM   #8
1JZPWRD
1JZ Single SC400
iTrader: (59)
 
1JZPWRD's Avatar
 
Join Date: Jan 2009
Location: Alabama, Roll Tide!
Posts: 8,512
Thanks: 0
Thanked 1 Time in 1 Post
Default

Dont worry you have another one on the way, compliments of ME !!
1JZPWRD is offline   Reply With Quote
Old 01-19-12, 07:06 PM   #9
gtsfire
Lead Lap
Thread Starter
iTrader: (4)
 
gtsfire's Avatar
 
Join Date: Nov 2009
Location: DFW Tx
Posts: 464
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 1992Lexus View Post
Dont worry you have another one on the way, compliments of ME !!
It'll be good to have a spare! I anticipate early failure of this one, lol.
gtsfire is offline   Reply With Quote
Old 01-20-12, 05:26 AM   #10
99SC42
gte & na-t
iTrader: (44)
 
99SC42's Avatar
 
Join Date: Jan 2007
Location: Maryland /Germantown
Posts: 5,113
Thanks: 0
Thanked 1 Time in 1 Post
Default

That's the retun line , That's why it's cavitating.
99SC42 is offline   Reply With Quote
Old 01-21-16, 12:36 PM   #11
718murdoc
Lead Lap
 
718murdoc's Avatar
 
Join Date: Jan 2010
Location: NewYork
Posts: 446
Thanked 0 Times in 0 Posts
Default

Sorry to bump an old thread but i hope someone can help me with a problem i have with my 92 SC400. I just got a fuel pump replaced at the mechanic shop because the old unit died. I got home and i heard a loud humming from the rear where the pump is located. The old pump never made this noise, is this normal because the pump is new? I did not notice the noise until i got home. Im going back to the shop tomorrow, but if someone could chime in on this, i would appreciate it.
718murdoc is offline   Reply With Quote
Old 01-23-16, 06:08 PM   #12
SC400slide
In Recovery Mode
iTrader: (11)
 
SC400slide's Avatar
 
Join Date: Apr 2012
Location: NM/AZ
Posts: 3,806
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Maybe you have some pliers on your return line?

SC400slide is offline   Reply With Quote
Old 01-25-16, 07:15 PM   #13
bigwhite
Lead Lap
 
bigwhite's Avatar
 
Join Date: Sep 2013
Location: In
Posts: 442
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I replaced my fuel pump a while back, and its been a little noisy ever since. My rear seats are removed so I can hear it more. Its weird because sometimes it makes a swirling loud gurgle and the next time it dosent. It dosent seem to matter how much gas is in the tank. I think I used an Airtex, made in Japan, instead of a Denso.
bigwhite is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My 1997 SC400 gtsfire Build Threads 26 04-12-17 09:01 PM
Sunroof rattle FIXED with pics rkspec IS - 2nd Gen (2006-2013) 12 04-27-16 07:58 PM
Help on my NA-T Setup Tamotoji Performance 18 02-12-16 12:58 AM
Need help with walbro 255 getting stuck. sayayin Performance & Maintenance 4 05-03-11 07:56 PM
ND FS: 01 GGP Lexus IS300 - ND Instigator Lexus Vehicles Classifieds 6 12-14-09 06:58 PM


Tags
250, fuel, fuelpump, hot, is300, lexus, loud, making, noise, noisy, pump, sc, sc300, sc400, tsx

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 01:43 AM.


Copyright © 2000-2017 Internet Brands, Inc. All Rights Reserved
 
  • Ask a Question
    Get answers from community experts
What's your question?
Send