Gs300 with ls400 brakes, new pads and rotors keeps SQUEAKING! - ClubLexus - Lexus Forum Discussion

Go Back  ClubLexus - Lexus Forum Discussion > Lexus Special Interest Forums > The Tire Rack's Tires, Wheels & Brakes Forum
Gs300 with ls400 brakes, new pads and rotors keeps SQUEAKING! >

Gs300 with ls400 brakes, new pads and rotors keeps SQUEAKING!

The Tire Rack's Tires, Wheels & Brakes Forum Where else do you go for wheel, tire and brake information?
Sponsored by:
Sponsored by:

Gs300 with ls400 brakes, new pads and rotors keeps SQUEAKING!

 
Old 02-08-19, 08:36 PM
  #1  
Sc3Hunnaa
Driver School Candidate
Thread Starter
 
Sc3Hunnaa's Avatar
 
Join Date: Oct 2014
Location: Missouri
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Gs300 with ls400 brakes, new pads and rotors keeps SQUEAKING!

I have a gs300 with a ls400 brake set up the previous owner replaced with (he says) ceramic pads and drilled and slotted rotors (I checked they look brand new) I've put quite a bit of miles on it since so I dont think they still need bedded lol.
Okay, the answers probably very simple I know but I want to hear how you all fixed your issues to see the different things I should run through. Basically the front brakes squeak when stopping slow, if I brake moderately hard then they do not, when I let out slowly they'll squeak. If I stop moderately slow and hear them squeak I can let out a bit and reapply and they will stop. I dont think they're squeaking because they ceramic that's what the precious owner said because it sounds very unnatural and annoying lol
Sc3Hunnaa is offline  
Old 02-09-19, 10:10 AM
  #2  
kos
Driver
 
Join Date: May 2006
Location: Arizona
Posts: 158
Thanked 10 Times in 10 Posts
Default

Ever think of going to a normal, blank rotor?
kos is offline  
Old 02-11-19, 03:49 AM
  #3  
Sc3Hunnaa
Driver School Candidate
Thread Starter
 
Sc3Hunnaa's Avatar
 
Join Date: Oct 2014
Location: Missouri
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have. They were on the car when I bought it. I was looking to see if some people had the issue and fixed it with things like a shim kit or hardware kit.
Sc3Hunnaa is offline  
Old 02-11-19, 06:09 AM
  #4  
kos
Driver
 
Join Date: May 2006
Location: Arizona
Posts: 158
Thanked 10 Times in 10 Posts
Default

Your original post said that the car has drilled /slotted rotors on it, my recommendation was based off of that. If it has blank rotors on it now and the issue is still persisting, there's a few different ways you can go.
kos is offline  

Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: