what toyota radios will work in sc300 - ClubLexus - Lexus Forum Discussion

Notices
SC- 1st Gen (1992-2000)

what toyota radios will work in sc300

Old 09-29-18, 05:31 PM
  #1  
Deathbarel
Rookie
Thread Starter
 
Join Date: Dec 2015
Location: sc
Posts: 76
Thanked 3 Times in 3 Posts
Default what toyota radios will work in sc300

my radio is shot, i dont like aftermarket ones. so what im really looking for is a toyota double din radio the will work with the existing amplifier. i dont mind making an adapter harness. the 95-99 camry radio looks great and has a cd player and a tape player. does anyone know of any radios that will work. thank you
Deathbarel is offline  
Old 10-01-18, 02:58 AM
  #2  
joe diego
Lexus Test Driver
iTrader: (2)
 
Join Date: Jun 2007
Location: CA
Posts: 807
Thanked 3 Times in 3 Posts
Default

Good question... My oem radio doesn’t power on at all, and I rather have the oem look instead of aftermarket myself.
joe diego is offline  
Old 10-07-18, 06:58 PM
  #3  
Deathbarel
Rookie
Thread Starter
 
Join Date: Dec 2015
Location: sc
Posts: 76
Thanked 3 Times in 3 Posts
Default

i used A56815. i bypassed the factory amp in the trunk. but after a couple minutes the radio shuts off and the back of the radio is hot enough to burn you. i know nothing about audio systems, does anyone know what is going on. the radio says it needs 4 ohm speakers. i verified that 4 ohm speakers are installed. the sc300 has a common ground system but the new radio does not.
Deathbarel is offline  
Old 10-10-18, 01:42 PM
  #4  
zazzn
Lead Lap
 
zazzn's Avatar
 
Join Date: Jun 2004
Location: SF, CA/Canada
Posts: 734
Thanked 7 Times in 6 Posts
Default

So, none will fit because of the design of the bezel. If you get a double din mounting kit and a double din kit you can find the older JBL models may work. but really they have a different wiring harness since Lexus...

You can easily make an adapter harness if you want, but your best bet is to buy another SC radio if you want stock. The JBL which is not amplified is what I have for my supra, I don't know what year, but we hacked it to have an AUX port when it plays a blank CD. Most tundra's and what not have just standard double din radios
zazzn is offline  
Old 10-12-18, 08:44 PM
  #5  
Deathbarel
Rookie
Thread Starter
 
Join Date: Dec 2015
Location: sc
Posts: 76
Thanked 3 Times in 3 Posts
Default

i got the radio in and working. because the lexus system is a common ground from the radio the speakers get their individual ground through the amplifier. this means that any head unit with an internal amplifier will need at least new grounds ran to the head unit. the radio is not as tall as the oem sc radio and leaves a nice place for pods. its nice to have cds again. and now the car is capable of having any toyota radio put in. the jbl radios have a different plug in the back of the radio but the harness that goes to the jbl amplifier is very short and then the amps outputs are the standard toyota plug.
Deathbarel is offline  
Old 10-13-18, 07:17 PM
  #6  
CELSI0R
Lead Lap
 
CELSI0R's Avatar
 
Join Date: Nov 2015
Location: NJ
Posts: 599
Thanked 55 Times in 48 Posts
Default

Wow! That looks fantastic, and it fits in there very well. Can you provide any more details on the process of hooking it up to the system?

I'm definitely going to bookmark this thread. This is much nicer than the factory CD changer setup.
CELSI0R is offline  
Old 10-13-18, 08:40 PM
  #7  
Deathbarel
Rookie
Thread Starter
 
Join Date: Dec 2015
Location: sc
Posts: 76
Thanked 3 Times in 3 Posts
Default

i can give you all the details you want. i had a rule for myself. no modifying of the factory harness is allowed. i had to find male versions of the connectors to connect into the female connectors that usually plug into the amp and thing like that. the hardest one was the 14 pin to hijack the amp signal connector. i ended up finding it in the rear of ~96 camry on the left side in the trunk, its blue. the 10 pin is also hard to find. i ordered them. pn 90980-10800. lexus used a different plug that goes into the radio untill they switched to the current two piece plug. using metra 71-8112 or maybe 70-8112. this will adapt the lexus radio to bare wires then you need a toyota repair radio harness and solder these to together and that will adapt the lexus to current toyota. this is the radio patch harness i refer to. the new radio requires individual grounds. soooooooooooooooo you have to run new ones. you can run all new positive and negative to each speaker from the radio. or get some speedwire. and run that one cable to the rear where the speaker 10 pin connector usually plugs into the amp. and just get a male 10 pin connector to plug into the speaker connector. thinking back now the easiest is to just forget about the 14 pin and run speed wire to the 10 pin speaker plug where the amp is in the rear, that 10 pin has individual speaker positives and negatives

.
Deathbarel is offline  
The Following User Says Thank You to Deathbarel For This Useful Post:
CELSI0R (10-14-18)
Old 10-13-18, 08:47 PM
  #8  
Deathbarel
Rookie
Thread Starter
 
Join Date: Dec 2015
Location: sc
Posts: 76
Thanked 3 Times in 3 Posts
Default

if you look at the blue 14 connector there are only 4 wires coming from it. those are the 4 positive wire signals, from the radio. knowing what i know now. i would just use speedwire. and run that one cable to the connector on the bottom left cause that one has all grounds and positive signals for each speaker, call it done.
Deathbarel is offline  
The Following User Says Thank You to Deathbarel For This Useful Post:
CELSI0R (10-14-18)
Old 10-14-18, 11:56 AM
  #9  
nnnickkk
Lexus Test Driver
iTrader: (2)
 
nnnickkk's Avatar
 
Join Date: Mar 2004
Location: California
Posts: 942
Thanked 3 Times in 3 Posts
Default

Deathbarel what year is your car? is it factory pioneer or nakamichi?
nnnickkk is offline  
Old 10-14-18, 01:02 PM
  #10  
Deathbarel
Rookie
Thread Starter
 
Join Date: Dec 2015
Location: sc
Posts: 76
Thanked 3 Times in 3 Posts
Default

i have a 92 with the pioneer. i have plugged a naka unit into the system and only the front left speaker works. not sure if thats valuable information or not.
Deathbarel is offline  
Old 10-16-18, 08:20 PM
  #11  
joe diego
Lexus Test Driver
iTrader: (2)
 
Join Date: Jun 2007
Location: CA
Posts: 807
Thanked 3 Times in 3 Posts
Default

Originally Posted by Deathbarel View Post
i have a 92 with the pioneer. i have plugged a naka unit into the system and only the front left speaker works. not sure if thats valuable information or not.
You had the P1606 prior to installing Naka unit?
joe diego is offline  
Old 10-16-18, 08:34 PM
  #12  
Deathbarel
Rookie
Thread Starter
 
Join Date: Dec 2015
Location: sc
Posts: 76
Thanked 3 Times in 3 Posts
Default

heres what i have, i do not see a similar part number
Deathbarel is offline  


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: