SC400 radio problems - ClubLexus - Lexus Forum Discussion

Notices
SC- 1st Gen (1992-2000)

SC400 radio problems

Old 07-04-18, 10:15 PM
  #1  
Vince31501
Driver School Candidate
Thread Starter
 
Join Date: Feb 2018
Location: New Jersey
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default SC400 radio problems

Hi everyone, I own a 1994 sc400 it's my first car i am currently 17 and have been driving it for about four months what an amazing car feels like a 2014 and its a 94 lol. but I've had really crazy issues with my stereo system, it worked perfectly for about two and a half months and then it wouldn't allow me to power the radio on a cold start. then it decided that it wasn't going to turn on unless it felt like 1000 degrees in my car, recently within the last three weeks it has just stopped turning on completely. anyway, two questions: Does anyone have any idea whats going on? and if I get an aftermarket radio how do I make it work with the power antenna? thank you guys so much for all the help, these forums are the best thing and the community is just completely amazing.
Vince31501 is offline  


Thread Tools
Search this Thread
Quick Reply: SC400 radio problems


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: