Help! Tuner NAV Water Damage, 2001 LS430, ML Audio - Club Lexus Forums


Help! Tuner NAV Water Damage, 2001 LS430, ML Audio

Reply
 
 
 
Thread Tools Search this Thread
Old 07-30-10, 07:11 PM   #1
magnithead
Driver School Candidate
Thread Starter
 
Join Date: Jul 2010
Location: IL
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help! Tuner NAV Water Damage, 2001 LS430, ML Audio

So, water got into the trunk and these two boxes were reeaally wet (both nav and radio stopped functioning). However, the tape mode and cd mode 'play' and sound fine. I purchased another "tuner" box off ebay, plugged in the two (2) connections and there is no am/fm, static...zero! OK, so the 'used' tuner may be non-functional as well, maybe? But, strangely, can it be the AMP?

When I disconnect the 'tuner' connections, no sound plays from the cd...weird?! Plug them back in (even on a defunct tuner) and the sound works from the cd?! There must be a ground that needs to be "plugged in" to the tuner to hear sound, even from another mode? Idk.

Also, the Nav unit has four (4) total connectors/wire harness openings (3 larger ones at bottom and 1 smaller in right, top corner (see pic), BUT there are only 3 total connections in the trunk...should 1 of the lowers not be connected to anything? Fyi - Everything all worked prior to the rain/water damage.

Do I need new connections for the tuner? Possible corrosion at the tips? Would the entire wire be 'shot' all the way to the front (or to the Amp) if gotten wet? Also, there is a single black thicker needle-type wire that was connected to the metal handle-thing off the back of the tuner box (see pic)? Is that the Antenna? I broke the blue, rectangular clip-thing when I pulled it out, but that shouldn't keep the whole radio from not turning on, right? I would at least get static? Does the 'tuner' box need to be bolted down to work, possible ground reasoning? Can just part of the Amp be broken, that which has something to only do w/ the radio? A fuse someplace?

Any help my way would be appreciated...thanks everyone (sorry for rambling).
Attached Thumbnails
Help! Tuner NAV Water Damage, 2001 LS430, ML Audio-cimg0034.jpg   Help! Tuner NAV Water Damage, 2001 LS430, ML Audio-cimg0035.jpg   Help! Tuner NAV Water Damage, 2001 LS430, ML Audio-cimg0037.jpg   Help! Tuner NAV Water Damage, 2001 LS430, ML Audio-cimg0003.jpg  
magnithead is offline   Reply With Quote
Old 07-22-14, 07:54 AM   #2
wrcapps
Driver School Candidate
 
Join Date: Jul 2014
Location: NC
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help! Tuner NAV Water Damage, 2001 LS430, ML Audio

Did you ever find the solution to the radio repair?
wrcapps is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HOW-TO: SC300/SC400 Install Aftermarket Head Unit, OEM Speakers and Sub Working! raine Lexus Audio, Video, Security & Electronics 573 10-19-16 04:17 PM
How to? Add XM Radio to 2005 GX 470? orion7mm GX - 1st Gen (2004-2009) 6 05-16-16 04:28 PM
CA WTB: Sirius XM radio kit aznKewlguy 2Gen IS250 / IS350 / IS-F Classifieds (06-13) 0 11-20-15 06:02 PM
Is my factory Head Unit Dead? (01 w/ Nav and Mark Levinson) illspeed LS - 3rd Gen (2001-2006) 9 07-25-15 09:41 AM
Plug & Play with touch screen XM radio on GS430 with Nav. VVT-i Lexus Audio, Video, Security & Electronics 30 03-25-14 03:27 PM


Tags
2001, 2001ls430, 430, amplifier, conenectors, damage, damaged, lexus, location, ls, ls430, radio, slight, tuner, water, wiring

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 02:59 AM.


Copyright © 2000-2017 Internet Brands, Inc. All Rights Reserved
 
  • Ask a Question
    Get answers from community experts
What's your question?
Send