electrical issues - ClubLexus - Lexus Forum Discussion


IS - 3rd Gen (2014-present) Discussion about the 2014+ model IS models

electrical issues

Reply
 
 
 
Thread Tools Search this Thread
Old 06-23-14, 01:35 PM   #1
lelexlexus
Driver School Candidate
Thread Starter
 
Join Date: May 2014
Location: ontario
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default electrical issues

Hi. I just wanna know has anybody else had problems with the electrical unit on their 3is? A while back it had sudden black outs or freezing with the screen. When that happens my entire multi media does not work including gps. Recently it keeps telling I have a system update but when it finishes loading the same cycle of it updating keeps appearing. Just wanted to know if its just my car or its a recall. Thanks.
lelexlexus is offline   Reply With Quote
Old 06-23-14, 01:52 PM   #2
dojoman
Lexus Champion
iTrader: (5)
 
Join Date: Sep 2007
Location: California
Posts: 2,780
Thanked 4 Times in 4 Posts
Default

Nav freezing is not electrical problem, it's simply software issue. Lexus recently updated Enform app suite and that's why you keep getting update screen. If you let the update go through you should not see it again.
dojoman is offline   Reply With Quote
Old 06-23-14, 02:30 PM   #3
lelexlexus
Driver School Candidate
Thread Starter
 
Join Date: May 2014
Location: ontario
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dojoman View Post
Nav freezing is not electrical problem, it's simply software issue. Lexus recently updated Enform app suite and that's why you keep getting update screen. If you let the update go through you should not see it again.
Ohh but the problem is I cant hear music or anything. Ive allowed the system to update but it keeps repeating itself I cant get access of anything that has to with the pad and screen. Also one my friends she also had the same problem they had to order and install the whole unit again and she said that took 5 months to order......weird.
lelexlexus is offline   Reply With Quote
Old 06-23-14, 02:59 PM   #4
dojoman
Lexus Champion
iTrader: (5)
 
Join Date: Sep 2007
Location: California
Posts: 2,780
Thanked 4 Times in 4 Posts
Default

Did you try to unplug the car's battery and wait 10 min? It sounds like you may have bad unit.
Mine sometimes reboot pre updating the firmware but it's more stable now. But yours sounds like it's bad unit.
dojoman is offline   Reply With Quote
Old 06-24-14, 09:33 AM   #5
cFoo
Driver
 
Join Date: Jul 2008
Location: Canada
Posts: 165
Thanked 0 Times in 0 Posts
Default

Mine freezes and locked up if someone is calling while the phone is syncing at startup. It's a very rare use case. Restarting the car will make it all better.
cFoo is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
"Intermittent electrical issue causing misfire" OneSC Performance & Maintenance 10 10-31-16 04:10 AM
Weird problems socal3 IS - 2nd Gen (2006-2013) 3 09-24-16 05:46 PM
2010 LS460's Reliability? ibidu1 LS - 4th Gen (2007-2017) 12 10-20-13 05:29 PM
Repeat Electrical Issue :( TheAzn SC- 1st Gen (1992-2000) 17 08-26-13 06:53 PM
Issues with radio and Nav opmredwing GS - 2nd Gen (1998-2005) 3 11-01-05 05:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 04:16 PM.


Copyright © 2000-2017 Internet Brands, Inc. All Rights Reserved
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: