Notices
GS - 2nd Gen (1998-2005) Discussion about the second generation GS300, GS400 and GS430 (1998 - 2005)

Alternatives for brake master and booster

 
Old 03-14-19, 11:34 PM
  #1  
Kstyle55
Pole Position
Thread Starter
 
Join Date: Sep 2004
Location: Florida
Posts: 218
Likes: 0
Received 1 Like on 1 Post
Default Alternatives for brake master and booster

Posted this in bakes and suspension but have yet to get any replies so im trying here. I have already replaced my abs brake master and booster unit that us as gs owners have been cursed with once already and now a few years later my abs light is coming on every once in awhile which i feel like its on its way out again and i refuse to buy another used one and not know how long before its gonna go out again plus its expensive. So i was wonder if anyone knew of any master cylinder and brake booster i can use like the ones out of the sc300 or ls400 or even the supra so i dont have to get another used factory one. Dont really care about abs thats what my right foot is for. Any input would be appreciated. Thanks in advance
Kstyle55 is offline  
Old 03-15-19, 05:15 AM
  #2  
sbagdon
Pole Position
 
Join Date: Mar 2016
Location: MI
Posts: 369
Likes: 0
Received 16 Likes on 15 Posts
Default

Just curious... so the only reason you're doing the repair is to get the light to go out?
sbagdon is offline  
Old 03-15-19, 05:35 AM
  #3  
TrueGS300
Pole Position
 
Join Date: Nov 2018
Location: CA
Posts: 342
Received 35 Likes on 32 Posts
Default

The entire assembly can be had for $250 from JDM importers on ebay. I did mine that way and the install is quite easy. 4 nuts and two lines, and all the electrical connectors. I don't consider that expensive, but maybe you do. I'd just try another and hope for better luck. Mine has been great so far, but only been in for 6 months now.
TrueGS300 is offline  
The following users liked this post:
tiguy99 (04-04-19)
Old 03-15-19, 05:39 AM
  #4  
sbagdon
Pole Position
 
Join Date: Mar 2016
Location: MI
Posts: 369
Likes: 0
Received 16 Likes on 15 Posts
Default

Originally Posted by TrueGS300 View Post
The entire assembly can be had for $250 from JDM importers on ebay. I did mine that way and the install is quite easy. 4 nuts and two lines, and all the electrical connectors. I don't consider that expensive, but maybe you do. I'd just try another and hope for better luck. Mine has been great so far, but only been in for 6 months now.
Is this the fix for "ABS engages last few feet, and it drives me crazy" issue...?
sbagdon is offline  
Old 03-15-19, 05:50 AM
  #5  
TrueGS300
Pole Position
 
Join Date: Nov 2018
Location: CA
Posts: 342
Received 35 Likes on 32 Posts
Default

Originally Posted by sbagdon View Post
Is this the fix for "ABS engages last few feet, and it drives me crazy" issue...?
Since its everything in one unit, I'm sure its probably the fix for everything abs related. I didn't have physically low peddle or hydraulic issues, or abs activating at any odd times. I simply had lights going off and the accumulator motor running every time I hit the brakes. I bet a replacement unit and a proper bleed will make the brake system work great.
TrueGS300 is offline  
The following users liked this post:
tiguy99 (04-04-19)
Old 03-15-19, 05:54 AM
  #6  
sbagdon
Pole Position
 
Join Date: Mar 2016
Location: MI
Posts: 369
Likes: 0
Received 16 Likes on 15 Posts
Default

Originally Posted by TrueGS300 View Post
Since its everything in one unit, I'm sure its probably the fix for everything abs related. I didn't have physically low peddle or hydraulic issues, or abs activating at any odd times. I simply had lights going off and the accumulator motor running every time I hit the brakes. I bet a replacement unit and a proper bleed will make the brake system work great.
That's where I'm at... when the ABS is working, every time we're at a stop, the ABS would activate. Will investigate a new/used/replacement test unit, thx!
sbagdon is offline  
Old 03-15-19, 06:17 AM
  #7  
TrueGS300
Pole Position
 
Join Date: Nov 2018
Location: CA
Posts: 342
Received 35 Likes on 32 Posts
Default

Ya, feeling JDM "AF" with my Aristo booster haha
TrueGS300 is offline  
Old 03-16-19, 07:16 PM
  #8  
MikeUD
Driver School Candidate
 
Join Date: Aug 2013
Location: DE
Posts: 33
Likes: 0
Received 4 Likes on 3 Posts
Default

It could just be a wheel sensor causing the light to come on, y'know.
MikeUD is online now  
Old 03-17-19, 07:36 AM
  #9  
Kstyle55
Pole Position
Thread Starter
 
Join Date: Sep 2004
Location: Florida
Posts: 218
Likes: 0
Received 1 Like on 1 Post
Default

Originally Posted by sbagdon View Post
Just curious... so the only reason you're doing the repair is to get the light to go out?
no it is not the only reason if it was i would just remove the bulb. Come on fellas
Kstyle55 is offline  
Old 03-17-19, 07:53 AM
  #10  
Kstyle55
Pole Position
Thread Starter
 
Join Date: Sep 2004
Location: Florida
Posts: 218
Likes: 0
Received 1 Like on 1 Post
Default

Originally Posted by TrueGS300 View Post
The entire assembly can be had for $250 from JDM importers on ebay. I did mine that way and the install is quite easy. 4 nuts and two lines, and all the electrical connectors. I don't consider that expensive, but maybe you do. I'd just try another and hope for better luck. Mine has been great so far, but only been in for 6 months now.
well lets see i already changed it once and i just find it really annoying that this thing could be going out again when i can replace with a brand new master and booster for less than what a used one for the gs cost and not have to worry about it again. Im not so worried about the price but the annoyance of the same part going out over and over again i can find many other things i would rather spend my money on like my 3 kids ijs.
Kstyle55 is offline  
Old 03-17-19, 08:03 AM
  #11  
j3rf
Driver School Candidate
 
Join Date: Jan 2019
Location: OH
Posts: 11
Received 0 Likes on 0 Posts
Default

What is the code causing the ABS light to illuminate? Should probably check that first before you assume the master cylinder assembly is bad.
j3rf is offline  
Old 03-17-19, 08:18 AM
  #12  
Kstyle55
Pole Position
Thread Starter
 
Join Date: Sep 2004
Location: Florida
Posts: 218
Likes: 0
Received 1 Like on 1 Post
Default


Here is my bay if anybody was wondering. I dont have money to throw away to keep buying that stupid unit over and over again there are many other things i would like to buy instead. Plus abs imho are for people who dont know how to drive and who dont have any brake control. Plus i was thinking of going manual 6 speed with either v160, cd009 or t56 and switching to a regular booster and master would look way better in the bay than that bulky unit and it would give me alot more room for the clutch slave cylinder but that will be in the future just want to plan ahead
Kstyle55 is offline  
The following users liked this post:
Arussto (04-17-19)
Old 03-17-19, 08:20 AM
  #13  
Kstyle55
Pole Position
Thread Starter
 
Join Date: Sep 2004
Location: Florida
Posts: 218
Likes: 0
Received 1 Like on 1 Post
Default

Originally Posted by TrueGS300 View Post
Ya, feeling JDM "AF" with my Aristo booster haha
Yeah i feel jdm af too with my swap lol
Kstyle55 is offline  
Old 03-17-19, 08:23 AM
  #14  
Kstyle55
Pole Position
Thread Starter
 
Join Date: Sep 2004
Location: Florida
Posts: 218
Likes: 0
Received 1 Like on 1 Post
Default

Originally Posted by j3rf View Post
What is the code causing the ABS light to illuminate? Should probably check that first before you assume the master cylinder assembly is bad.
im gonna be heading to my boys shop to run a scan to see what the problem is just been really busy this past week and havent had time to make it to the shop and as u all should know once u do the 2jzgte vvti swap u cant use a ob2 scanner any more just a heads up for who didnt know

Last edited by Kstyle55; 03-17-19 at 08:42 AM.
Kstyle55 is offline  
Old 03-19-19, 08:13 AM
  #15  
R3VO666
Driver School Candidate
 
Join Date: Mar 2019
Location: Florida
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by TrueGS300 View Post
Since its everything in one unit, I'm sure its probably the fix for everything abs related. I didn't have physically low peddle or hydraulic issues, or abs activating at any odd times. I simply had lights going off and the accumulator motor running every time I hit the brakes. I bet a replacement unit and a proper bleed will make the brake system work great.
I'm having that same issue of used MBC unit (2nd one) no lights and buzzing no more but very low pedal and accumulator goes off everytime I press the brakes.. I thought i was tripping. So bascially saything that not suppose to happen (accumulator part)? I honeslty was gunna bleed the brakes again to get pressure up and call it a day.
R3VO666 is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: