Notices
ES - 1st to 4th Gen (1990-2006) Forum for all 1990 - 2006 ES300 and ES330 models. ES250 topics go here as well.

New System Install

 
Old 01-28-19, 11:17 AM
  #61  
CBme
Driver School Candidate
 
Join Date: Jan 2019
Location: WA
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by crwys View Post
You need 2 of these or something like this product.

https://www.amazon.com/Isolator-BOSS...PYEZAA71HAE2EA
Yup, the isolators will help and are really the only other option to not have to bypass if you can't fix the core issue which is usually a grounding problem. Unfortunately, fixing the core problem doesn't seem possible with this specific model and an aftermarket radio as no one appears to have been successful in doing so. Problem with isolators they don't fully mask the issue with this specific factory amp (might with some receivers, but haven't with others) and *might* negatively affect audio quality (some with this car have reported it reduced the low end for some reason).
CBme is offline  

Thread Tools
Search this Thread
Quick Reply: New System Install


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: