Problem found! - Club Lexus Forums


Go Back   Club Lexus Forums > Lexus Model Forums > GS Models > GS - 2nd Gen (1998-2005) > Performance
Log In 

Problem found!

Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-20-14, 09:03 PM   #1
tn96dc
Pole Position
Trader Score: (7)
 
tn96dc's Avatar
 
Join Date: Apr 2011
Location: Bay Area
Posts: 291
Default Problem found!

After weeks of experiencing sluggish acceleration, poor idling, horrible fuel mileage and burning rich, I found the culprit that was causing everything. I decided to make a smoke machine to see if I had a leak anywhere in my intake after the mass air flow meter. Voila! I found a gaping hole in the box connected to the intake covered by a heat shield. If you're having any of these symptoms, check it out guys! I'm sure it's often missed!
Click the image to open in full size.
Click the image to open in full size.
__________________
2002 GS300
tn96dc is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY: Ambient Air Temperature Sensor Replacement alexly GS - 2nd Gen (1998-2005) 8 07-28-15 03:33 PM
MA FS: Volk Te laobo979 Wheels and Tires Classifieds 12 07-21-14 04:00 AM
SJGS. Slow LS430 Project Built W/ UAS Install SjGS Build Threads 30 05-08-14 07:26 PM
finally some pics of my gs300 AWD and a new member!! :P redb202 GS - 3rd Gen (2006-2011) 21 02-17-14 12:07 PM
CA Platinum Vip / Job Design GS350F part out. project328 4Gen GS450H / 350 Classifieds (13-) 13 12-02-13 11:28 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 04:39 AM.



Copyright © 2000-2015 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS