Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS430
Sign in using an external account
Register Forgot Password?

Help! Tuner NAV Water Damage, 2001 LS430, ML Audio

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-30-10, 07:11 PM   #1
magnithead
Driver School Candidate
Trader Score: (0)
 
Join Date: Jul 2010
Location: IL
Posts: 8
Default Help! Tuner NAV Water Damage, 2001 LS430, ML Audio

So, water got into the trunk and these two boxes were reeaally wet (both nav and radio stopped functioning). However, the tape mode and cd mode 'play' and sound fine. I purchased another "tuner" box off ebay, plugged in the two (2) connections and there is no am/fm, static...zero! OK, so the 'used' tuner may be non-functional as well, maybe? But, strangely, can it be the AMP?

When I disconnect the 'tuner' connections, no sound plays from the cd...weird?! Plug them back in (even on a defunct tuner) and the sound works from the cd?! There must be a ground that needs to be "plugged in" to the tuner to hear sound, even from another mode? Idk.

Also, the Nav unit has four (4) total connectors/wire harness openings (3 larger ones at bottom and 1 smaller in right, top corner (see pic), BUT there are only 3 total connections in the trunk...should 1 of the lowers not be connected to anything? Fyi - Everything all worked prior to the rain/water damage.

Do I need new connections for the tuner? Possible corrosion at the tips? Would the entire wire be 'shot' all the way to the front (or to the Amp) if gotten wet? Also, there is a single black thicker needle-type wire that was connected to the metal handle-thing off the back of the tuner box (see pic)? Is that the Antenna? I broke the blue, rectangular clip-thing when I pulled it out, but that shouldn't keep the whole radio from not turning on, right? I would at least get static? Does the 'tuner' box need to be bolted down to work, possible ground reasoning? Can just part of the Amp be broken, that which has something to only do w/ the radio? A fuse someplace?

Any help my way would be appreciated...thanks everyone (sorry for rambling).
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
Attached Images
    
magnithead is offline   Reply With Quote
Old 07-22-14, 07:54 AM   #2
wrcapps
Driver School Candidate
Trader Score: (0)
 
Join Date: Jul 2014
Location: NC
Posts: 1
Default Help! Tuner NAV Water Damage, 2001 LS430, ML Audio

Did you ever find the solution to the radio repair?
wrcapps is offline   Reply With Quote
Old 07-22-14, 07:54 AM
 
 
 
 
Reply

Tags
2001, 2001ls430, 430, amplifier, conenectors, damage, damaged, lexus, location, ls, ls430, radio, slight, tuner, water, wiring

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HOW-TO: SC300/SC400 Install Aftermarket Head Unit, OEM Speakers and Sub Working! raine Lexus Audio, Video, Security & Electronics 524 Today 12:28 PM
No Audio At Times - 01 Ls430 Ultra With Mark Levinson speedemon LS430 14 09-12-14 06:02 AM
92 SC400 audio input wiring?? aerokabn SC 400/300 0 02-04-14 11:54 PM
radio questions john339 Lexus Audio, Video, Security & Electronics 2 03-08-13 09:34 AM
CA FS: OEM XM Satellite Radio Tuner (Discontinued) sfxr 2Gen IS250 / IS350 / IS-F Classifieds (06-13) 3 01-01-13 10:04 PM

All times are GMT -7. The time now is 07:09 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info