Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS430
Sign in using an external account
Register Forgot Password?

02 touch screen not working

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 09-11-09, 02:26 PM   #1
lovelexus2
Rookie
Trader Score: (0)
 
Join Date: Sep 2009
Location: tx
Posts: 50
Smile 02 touch screen not working

Thanks in advance for anybody here who give your advise.

I just got a 02 LS430, the touch screen is not working, I can't touch the "I agree or anything " to get the GPS start. For everything else, AC,Audio or others, I can't control them by the touch screen as well. i am wondering if anybody had this problem before. Do I have to take to dealer? I bet it will be very expensive. Also I have heard that if the disc was missing which can cause this kind of problem? If the disc is missing,do i have to order fromt the dealer, and since I am the owner of the car, will they give me one for free??

Also the warning keep showing up: low engine oil level. However I have checked couple times, the engine oil looks pretty good, it still has 1000 more miles before next service. anybody know about this problem? could it be the sensor?



thanks
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!

Last edited by lovelexus2; 09-15-09 at 11:00 AM..
lovelexus2 is offline   Reply With Quote
Old 11-16-09, 07:07 PM   #2
joe422
Driver School Candidate
Trader Score: (0)
 
Join Date: Mar 2006
Location: CA
Posts: 10
Default

Did you get this fixed?

Anybody else have this problem? Our LS430 had intermittent touchscreen problems too, and now wont work. Mainly at startup, the "I agree" corner does not respond... heck the whole lower portion doesn't respond. If I press climate, some of the areas in the middle will respond to touch, but not the lower part of the screen.

Anyone ever fix this?

I updated the Navi disk a couple yrs ago. Bought it oem from dealer.
joe422 is offline   Reply With Quote
Old 11-17-09, 05:43 AM   #3
toantran99
Pole Position
Trader Score: (0)
 
Join Date: Jul 2009
Location: VA
Posts: 236
Default

Might have to replace the screen portion.
toantran99 is offline   Reply With Quote
Old 11-17-09, 03:59 PM   #4
ebolger
Rookie
Trader Score: (0)
 
Join Date: Apr 2009
Location: CA
Posts: 89
Default

Have you had the Lexus Link disconnected?

I had that problem when I bought my '01 7 months ago but had the same problem. Found out that the Lexus Link was not supported in the older 430's. Went to the dealer...$135 later everything worked fine.
ebolger is offline   Reply With Quote
Old 11-17-09, 04:58 PM   #5
Slvr surfr
Lexus Test Driver
Trader Score: (0)
 
Slvr surfr's Avatar
 
Join Date: Oct 2009
Location: dc
Posts: 1,028
Default

I have an 05 and had this happen on two occasion in on cold mornings. Couldn't hit the agree button but heard the music playin. After several screen presses, i get a notice about the nav disc malfunctioning. Got to my destination only after a couple of minutes a turned the car off. Next time i started it it was working fine. I think maybe it acts funny in colder weather or maybe the disc and/or nav laser is dirty. Will try to clean and see what happends.
Slvr surfr is offline   Reply With Quote
Old 01-13-10, 03:00 PM   #6
joe42276
Rookie
Trader Score: (0)
 
Join Date: Jan 2007
Location: CA
Posts: 53
Default

Anyone have touchscreen problems too?

We do have Lexus Link, and didnt remove it yet... ('01 LS430 UL)
Has anyone fixed this issue yet?
joe42276 is offline   Reply With Quote
Old 03-09-10, 02:10 PM   #7
lovelexus2
Rookie
Trader Score: (0)
 
Join Date: Sep 2009
Location: tx
Posts: 50
Default

Bought a used one from Ebay, replace it and everything works just fine.
lovelexus2 is offline   Reply With Quote
Old 06-04-10, 12:31 PM   #8
joe42276
Rookie
Trader Score: (0)
 
Join Date: Jan 2007
Location: CA
Posts: 53
Default

Thanks!

I did the same. Found a used one on ebay ($350)... crossed my fingers, and perfect! I did swap in my bezel and some of the buttons as mine were in better condition. The screen works perfect though.

Easy 10 min install.
joe42276 is offline   Reply With Quote
Old 06-04-10, 12:52 PM   #9
lovelexus2
Rookie
Trader Score: (0)
 
Join Date: Sep 2009
Location: tx
Posts: 50
Default

That is great, congratulations
lovelexus2 is offline   Reply With Quote
Old 06-04-10, 04:14 PM   #10
Bocatrip
Lexus Test Driver
Trader Score: (0)
 
Join Date: May 2006
Location: Fl
Posts: 1,044
Default

Quote:
Originally Posted by lovelexus2 View Post
Bought a used one from Ebay, replace it and everything works just fine.
Are you talking about buying an entire used nav system? Are these systems known to have problems? I am looking for a 2001-2003 LS430 and was considering staying away from those cars with Nav. Should I be concerned?
__________________
Currently Own:
2001 Lexus LS430 Millenium Silver/Nav/ML
2010 Jaguar XK Coupe Liquid Silver
2004 Infiniti G35 Coupe - purchased new. (sold)
Bocatrip is offline   Reply With Quote
Old 06-04-10, 04:20 PM   #11
joe42276
Rookie
Trader Score: (0)
 
Join Date: Jan 2007
Location: CA
Posts: 53
Default

The problem doesn't seem common.. being that it was so hard to find any good info or solutions for a while.


In my case, the upper 1/3 and lower 1/3 was numb to the touch. It would not respond. It started out as a sporadic problem... not consistent... and later, it was just stopped responding.


The Ebay part I bought included the actual screen... the bezel surrounding it and the button along the side of the screen, as well as the center vent outlet.

I only utilized the screen itself. It's fairly easy to replace.
joe42276 is offline   Reply With Quote
Old 06-04-10, 07:50 PM   #12
biga27110
Rookie
Trader Score: (1)
 
Join Date: Jul 2005
Location: ca
Posts: 83
Default

thanks for this great post guys
biga27110 is offline   Reply With Quote
Old 06-07-10, 09:55 AM   #13
joe42276
Rookie
Trader Score: (0)
 
Join Date: Jan 2007
Location: CA
Posts: 53
Default

Oh yea... the plastic bezel for the navi screen that goes up over the center vents, would squeak from time to time. Nothing could solve it.. not even the dealer (yrs ago).

Anyway, while I was replacing the nav screen, I also bought a roll of 1mm felt tape... and stuck it neatly onto the bezel (where it will touch the vinyl on the dash). Voila... perfect! No more squeaks! Just silence.
joe42276 is offline   Reply With Quote
Old 06-07-10, 05:10 PM   #14
randal
Pole Position
Trader Score: (0)
 
Join Date: Nov 2009
Location: IN
Posts: 336
Default

Joe, can you tell me how to remove the bezel? I also have the squeak occasionally and would like to do the felt treatment.
__________________
2002 LS430
1992 LS400
1992 ES300
randal is offline   Reply With Quote
Old 06-07-10, 05:36 PM   #15
joe42276
Rookie
Trader Score: (0)
 
Join Date: Jan 2007
Location: CA
Posts: 53
Default

You'll have to start from the bottom and disassemble / pull each segment out from the shfter center console on up.
joe42276 is offline   Reply With Quote
Old 06-07-10, 05:36 PM
 
 
 
 
Reply

Tags
250, 350, fix, gps, gs, gx470, is250, is300, issues, lexus, problems, screen, start, touch, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 11:15 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info