Help! Tuner NAV Water Damage, 2001 LS430, ML Audio - Club Lexus Forums


Help! Tuner NAV Water Damage, 2001 LS430, ML Audio

Reply
 
 
 
Thread Tools Search this Thread
Old 07-30-10, 08:11 PM   #1
magnithead
Driver School Candidate
Thread Starter
 
Join Date: Jul 2010
Location: IL
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help! Tuner NAV Water Damage, 2001 LS430, ML Audio

So, water got into the trunk and these two boxes were reeaally wet (both nav and radio stopped functioning). However, the tape mode and cd mode 'play' and sound fine. I purchased another "tuner" box off ebay, plugged in the two (2) connections and there is no am/fm, static...zero! OK, so the 'used' tuner may be non-functional as well, maybe? But, strangely, can it be the AMP?

When I disconnect the 'tuner' connections, no sound plays from the cd...weird?! Plug them back in (even on a defunct tuner) and the sound works from the cd?! There must be a ground that needs to be "plugged in" to the tuner to hear sound, even from another mode? Idk.

Also, the Nav unit has four (4) total connectors/wire harness openings (3 larger ones at bottom and 1 smaller in right, top corner (see pic), BUT there are only 3 total connections in the trunk...should 1 of the lowers not be connected to anything? Fyi - Everything all worked prior to the rain/water damage.

Do I need new connections for the tuner? Possible corrosion at the tips? Would the entire wire be 'shot' all the way to the front (or to the Amp) if gotten wet? Also, there is a single black thicker needle-type wire that was connected to the metal handle-thing off the back of the tuner box (see pic)? Is that the Antenna? I broke the blue, rectangular clip-thing when I pulled it out, but that shouldn't keep the whole radio from not turning on, right? I would at least get static? Does the 'tuner' box need to be bolted down to work, possible ground reasoning? Can just part of the Amp be broken, that which has something to only do w/ the radio? A fuse someplace?

Any help my way would be appreciated...thanks everyone (sorry for rambling).
Attached Thumbnails
Help! Tuner NAV Water Damage, 2001 LS430, ML Audio-cimg0034.jpg   Help! Tuner NAV Water Damage, 2001 LS430, ML Audio-cimg0035.jpg   Help! Tuner NAV Water Damage, 2001 LS430, ML Audio-cimg0037.jpg   Help! Tuner NAV Water Damage, 2001 LS430, ML Audio-cimg0003.jpg  
magnithead is offline   Reply With Quote
Old 07-22-14, 08:54 AM   #2
wrcapps
Driver School Candidate
 
Join Date: Jul 2014
Location: NC
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help! Tuner NAV Water Damage, 2001 LS430, ML Audio

Did you ever find the solution to the radio repair?
wrcapps is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
No Audio At Times - 01 Ls430 Ultra With Mark Levinson speedemon LS - 3rd Gen (2001-2006) 19 04-10-15 05:42 PM
RX 400h 2006 with xm tuner installed - play ipod? hirendesai Lexus Audio, Video, Security & Electronics 15 01-10-12 08:00 PM
CA Pioneer BT and XM/Nav Traffic rvalero Mobile Audio/Video Classifieds 2 02-04-11 11:39 AM
NY FS Alpine IVA-W205 (NYC) SnoopyBQ Mobile Audio/Video Classifieds 13 03-05-10 08:07 PM
New XM offering for Lexus! patrickcfi GX - 1st Gen (2004-2009) 3 10-29-05 04:21 PM


Tags
2001, 2001ls430, 430, amplifier, conenectors, damage, damaged, lexus, location, ls, ls430, radio, slight, tuner, water, wiring

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 11:22 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved