96 LS Radio Display Bad - Club Lexus Forums

Log In 

96 LS Radio Display Bad

Reply
 
 
 
Thread Tools Search this Thread
Old 03-20-04, 11:10 AM   #1
lexer
Driver School Candidate
Thread Starter
 
Join Date: Jan 2004
Location: California
Posts: 16
Unhappy 96 LS Radio Display Bad

I seldom listen radio/CD while driving. I probably turn it on less than 5 times a year. But, recently, when I turn it on, I found many (more than 5) LED segments are not working. The radio/CD work OK though. I just can't see what radio station or which CD song I am listening because the broken LED segments make the display not readable. I brought it to a local Lexus dealer and they said the entire radio unit need to be replaced, instead of just replacing the LED screen. It will cost close to $1,000.- I really believe the problem is just the LED display panel. Does anyone know is there a way to just replace the LED panel? The problem is not major, not very annoying.

Thanks in advance.
lexer is offline   Reply With Quote
Old 04-12-04, 09:11 AM   #2
roger53
Driver School Candidate
 
Join Date: Sep 2003
Location: California
Posts: 1
Smile Radio Display '96 LS

I too had the same malady that you decribe with my '96 LS and was shocked when I got the same estimate from the dealer, but decided that there must be a better altenative. I talked to the independent shop I go to, Okimoto's in Norwalk, CA and when the shop he recommended said that they couldn't work on Lexus radios, they asked for another shop that could and were told of a place in Garden Grove, CA.
I called the shop and talked to Freddie and he said they weren't very busy that day and the repair would take about two hours and run $150. So I beat feet over, watched while Freddie dismantled the dash and retrieve the radio. He took it in the back and did some secret things to it and viola' the radio was back in the car within an hour!

Freddie expplained to me that there are two different problems that occur with this radio, one the lights go out, like mine did, and the other is that the digital display goes out and you can't see the numbers of the station etc. and that repair cost $225 from this shop called Car Radio Center, at 11001 Westminister Ave @ Euclid in Garden Grove.
I'm sure that this shop won't be convienient for everybody but they do work on just the radio itself if you want to ship it to them, call them at 714-626-3333 or 4444 and no, I don't work for them.

Last edited by roger53; 04-12-04 at 09:12 AM.
roger53 is offline   Reply With Quote
Old 04-12-04, 02:35 PM   #3
SharpLS-96
Lexus Champion
 
SharpLS-96's Avatar
 
Join Date: Mar 2002
Location: California
Posts: 2,991
Default

Very uncommon in the 2nd generation LS for the display to go out unlike the 1st generation LS which is prone to that specific problem. Lexus supposedly had fixed the problem by slightly rearranging the heater control panel which was causing the head units to heat up too much causing the displays to go out.

I guess as the car ages it will eventually go.
Roger, good to know of those repair shops!

Last edited by SharpLS-96; 04-12-04 at 02:43 PM.
SharpLS-96 is offline   Reply With Quote
Old 04-13-04, 10:09 PM   #4
Rice
Pole Position
 
Join Date: Dec 2002
Location: NJ
Posts: 298
Default Re: 96 LS Radio Display Bad

Quote:
Originally posted by lexer
I seldom listen radio/CD while driving. I probably turn it on less than 5 times a year. But, recently, when I turn it on, I found many (more than 5) LED segments are not working. The radio/CD work OK though. I just can't see what radio station or which CD song I am listening because the broken LED segments make the display not readable. I brought it to a local Lexus dealer and they said the entire radio unit need to be replaced, instead of just replacing the LED screen. It will cost close to $1,000.- I really believe the problem is just the LED display panel. Does anyone know is there a way to just replace the LED panel? The problem is not major, not very annoying.

Thanks in advance.
PM lexusaudio on this forum.
He's in the business of fixing these things.
My 97 has the same problem. LCD works fine, but back lights are out.
I am expecting to reseive a fixed radio from him within a day or so.
I'll let you know more after it arives and I install it.
Rice is offline   Reply With Quote
Old 04-16-04, 09:20 AM   #5
CaVleX
Driver School Candidate
 
Join Date: Apr 2004
Location: New York
Posts: 9
Default 96 LS400 - Aftermarket Radio

Has anyone had an aftermarket stereo installed in there 96 LS400 - I am trying to get one installed and it seems like it is the only year that they didn't make harnesses or anything for? I am being told that I have to rewire the whole damn thing is this true? And if not how can I find the wiring harness. The radio is the pioneer head unit - not nakamachi and all the harness that I have been sold don't fit? I am lost!!!
CaVleX is offline   Reply With Quote
Old 04-16-04, 02:34 PM   #6
SharpLS-96
Lexus Champion
 
SharpLS-96's Avatar
 
Join Date: Mar 2002
Location: California
Posts: 2,991
Default Re: 96 LS400 - Aftermarket Radio

Quote:
Originally posted by CaVleX
Has anyone had an aftermarket stereo installed in there 96 LS400 - I am trying to get one installed and it seems like it is the only year that they didn't make harnesses or anything for? I am being told that I have to rewire the whole damn thing is this true? And if not how can I find the wiring harness. The radio is the pioneer head unit - not nakamachi and all the harness that I have been sold don't fit? I am lost!!!
Welcome to ClubLexus!!

Probably have to splice all the connectors if your keeping the amp.

Last edited by SharpLS-96; 04-16-04 at 03:55 PM.
SharpLS-96 is offline   Reply With Quote
Old 04-16-04, 04:11 PM   #7
RedAE102
Driver School Candidate
 
Join Date: Apr 2004
Location: California
Posts: 21
Default

I haven't had the centre stack of our LS400 opened up, but I'm 90% sure the radio uses the same wiring harnesses as my '96 4Runner (6-speaker Toyota premium system with external amp). The wiring from the head unit to the amp is the same for all Toyotas since the early '90s, and the wire harnesses from the amp to the body wiring is the same as systems without external amps like my Corolla, so any of the radio wiring harness kits will work.

That brings me to a question I have: Does anyone know if the outputs from the stereo itself to the amp are preouts or speaker level outputs? (I'm talking factory systems) Meaning, if I wanted to connect a non-amplified Toyota head unit to an aftermarket amplifier, would I use the preamp inputs or speaker level inputs?

And more on topic, the radio was replaced under warranty in our '96 LS400 when it was about 3 years old because half the LCD segments on the right side of the radio display worked only intermittently. The display has worked fine since, but the bulb behind the volume ****, behind the AM and FM1/2 buttons, and the one behind the TAPE and CD buttons have burned out one by one (in that order). Can be a bit of a nuisance at night, but not worth $150... yet. The delightfully intuitive radio controls keep it from being a problem.

Last edited by RedAE102; 04-16-04 at 04:18 PM.
RedAE102 is offline   Reply With Quote
Old 04-16-04, 11:07 PM   #8
CaVleX
Driver School Candidate
 
Join Date: Apr 2004
Location: New York
Posts: 9
Default Tried it all

See that's the problem I have tried all of the toyota harnesses, even the toyota amplifier integration harness. None of them work. Just wondering if anyone on the board actually found a harness.
CaVleX is offline   Reply With Quote
 
 
Reply


Tags
1996, bad, cant, cd, display, displays, es350, goes, led, lexus, ls, ls400, out, panel, radio, screen, segments

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 08:46 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved