Instrument cluster question (LOL) - Page 2 - ClubLexus - Lexus Forum Discussion

Notices
SC- 1st Gen (1992-2000)

Instrument cluster question (LOL)

Closed Thread

 
 
 
Old 12-10-11, 01:48 PM
  #16  
O. L. T.
Keeper of the light
Thread Starter
iTrader: (17)
 
O. L. T.'s Avatar
 
Join Date: Feb 2003
Location: My little world
Posts: 33,749
Thanked 7 Times in 6 Posts
Default

Originally Posted by Kalogerus View Post

and lol theres no such thing as KPH, theres a Km/H though
You sound like the one at the party no one wants to talk to because even when the point is really clear you'll go out of the way to make a pointless correction to whatever they are saying. Don't be that guy. It's a rough looooooooonely life.
O. L. T. is offline  
Old 12-10-11, 08:57 PM
  #17  
Kalogerus
Lexus Test Driver
iTrader: (3)
 
Kalogerus's Avatar
 
Join Date: Oct 2011
Location: VA
Posts: 1,064
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by O. L. T. View Post
You sound like the one at the party no one wants to talk to because even when the point is really clear you'll go out of the way to make a pointless correction to whatever they are saying. Don't be that guy. It's a rough looooooooonely life.
yet u chose to ignore the point of the post and focused on my corny correction. no offence intended.
Kalogerus is offline  
Old 12-10-11, 09:26 PM
  #18  
CrazySC300
Lexus Champion
iTrader: (16)
 
CrazySC300's Avatar
 
Join Date: Jan 2008
Location: Southern California
Posts: 3,280
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by O. L. T. View Post
The 95 guys are hiding
Except for me and TechGeek, We have '95 year models and we posted.
CrazySC300 is offline  
Old 12-11-11, 01:44 PM
  #19  
BigManne
Lexus Test Driver
iTrader: (3)
 
BigManne's Avatar
 
Join Date: Jan 2005
Location: Landmass
Posts: 1,221
Thanks: 0
Thanked 1 Time in 1 Post
Default

my 95 sc4 has taillight indicators
BigManne is offline  
Old 07-05-12, 01:51 AM
  #20  
Tommy2JZ
Pole Position
 
Tommy2JZ's Avatar
 
Join Date: Apr 2012
Location: CA
Posts: 387
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have a 95 i have the US one, and my budddy joel also has a 95 with the canadian with MPH
Tommy2JZ is offline  
Old 07-05-12, 02:20 AM
  #21  
uras300
Lead Lap
iTrader: (2)
 
uras300's Avatar
 
Join Date: Jul 2006
Location: HI
Posts: 722
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a California spec 95 with headlight indicator and speed is read in MPH.
uras300 is offline  
Old 07-05-12, 11:50 AM
  #22  
SEIDO
Lexus Test Driver
iTrader: (1)
 
SEIDO's Avatar
 
Join Date: Nov 2008
Location: NY
Posts: 1,033
Thanks: 0
Thanked 3 Times in 2 Posts
Default

Okay wait a minute...

So I have the style in the bottom pic, with the lil' lightbulb indicator; it's usually on, and glows green.
However, my headlights and taillights all work.
I just thought it meant that my lights are in use.

So you're saying that it means my lights aren't working?
Why's mine on then?
SEIDO is offline  

Thread Tools
Search this Thread
Quick Reply: Instrument cluster question (LOL)


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: