Idle control - ClubLexus - Lexus Forum Discussion

Notices
RX - 1st Gen (1999-2003) Discussion topics related to the 1999 -2003 RX300 models
Sponsored by:
Sponsored by:

Idle control

 
Old 03-01-19, 11:02 AM
  #1  
Simonbart
Driver School Candidate
Thread Starter
 
Join Date: Mar 2019
Location: Uk
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Idle control

Hi.

I'm new around here but have owned my rx since 2003.
I'm needing a little advice. 2000 rx300 150k miles. Over the last couple of years we've had to clean the idle control valve a few times to fix low cold idle and all has been good for 6 months each time. The last time the clean didn't work so we went on Ebay and bought a new idle control valve and fitted it. With the new valve to car idled at 2000 rpm ! So I thought faulty cheap part and ordered another one from a different seller.



Put original part on and it doesn't tick over when cold. 2nd new one arrives so we fit that one and idle is back upto 2000rpm. Cant find any air leaks.

Any suggestions ? Does anything need relearning when fitting this valve?



Thanks in advance for any help / advise

Simonbart is offline  
Old 03-01-19, 11:59 AM
  #2  
salimshah
Moderator
 
Join Date: Apr 2001
Location: Austin, TX
Posts: 12,136
Thanked 269 Times in 262 Posts
Default

Yes there is re-learning, you just let it idle and warm up.
I would only clean my old one or purchase a new one from authorized dealer.

Salim
salimshah is offline  

Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: