Heat Still Blowing Cold after Thermostat replacement - ClubLexus - Lexus Forum Discussion


Performance & Maintenance Engine, forced induction, intakes, exhausts, torque converters, transmissions, etc.

Heat Still Blowing Cold after Thermostat replacement

Reply
 
 
 
Thread Tools Search this Thread
Old 02-13-17, 01:26 PM   #1
streetnick
Driver School Candidate
Thread Starter
 
Join Date: Jan 2017
Location: New York
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Question Heat Still Blowing Cold after Thermostat replacement

Whats up guys, first post on here besides the introduction section. So I recently bought a 95 SC400, and one of the problems was that the car wouldn't warm up fully, and the heat was blowing cold.

So I thought it would be the thermostat to fix it all, and I was wrong. The car properly heats up now, but the heat still blows cold. I suspect its the heater core, but hope its not ;/

Any tips, suggestions, or pointing me towards the right thread would be appreciated.

Thanks again,
streetnick
streetnick is offline   Reply With Quote
Old 02-13-17, 03:36 PM   #2
salimshah
Moderator
 
Join Date: Apr 2001
Location: Austin, TX
Posts: 10,323
Thanked 43 Times in 42 Posts
Default

Heat is very sensitive to air in the coolant.

Salim
salimshah is offline   Reply With Quote
Old 02-13-17, 03:39 PM   #3
ttsport15
Driver
 
ttsport15's Avatar
 
Join Date: Feb 2017
Location: new york
Posts: 157
Thanked 10 Times in 10 Posts
Default

Could be a bad switch
ttsport15 is offline   Reply With Quote
Old 02-13-17, 03:39 PM   #4
streetnick
Driver School Candidate
Thread Starter
 
Join Date: Jan 2017
Location: New York
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Smile

Quote:
Originally Posted by salimshah View Post
Heat is very sensitive to air in the coolant.

Salim
Thank you. After searching the forum (like I should have first, sorry for wasting a post) Thats what I concluded. Im going to try tomorrow and I'll report back if I have any problems.
streetnick is offline   Reply With Quote
Old 02-25-17, 11:53 PM   #5
tzxlyd
Rookie
 
Join Date: Mar 2015
Location: tx
Posts: 88
Thanks: 0
Thanked 1 Time in 1 Post
Default

Streetnick,
I am curious about what you found as your problem -- I am having a similar problem.
tzxlyd is offline   Reply With Quote
Old 02-26-17, 01:40 AM   #6
Zerodrag
Driver
iTrader: (4)
 
Zerodrag's Avatar
 
Join Date: Sep 2009
Location: CA
Posts: 150
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Are you sure your heater control valve is functioning correctly? It's on the passenger side firewall, and it should move when you adjust the temp control ****. Mine was leaking and it would get stuck from the coolant residue.
Zerodrag is offline   Reply With Quote
Old 02-26-17, 05:08 PM   #7
tzxlyd
Rookie
 
Join Date: Mar 2015
Location: tx
Posts: 88
Thanks: 0
Thanked 1 Time in 1 Post
Default

I am not sure but I will check it when I get the car back -- I think I tried to do a by pass of it with a cheaper valve that goes on a ford. I believe there was a forum post about it that I tried to follow but I don't think that worked for me -- I may have to bite the bullet and by an OEM. My car is in the shop getting body work done so I cannot check it. When I get the car back I will check that -- I appreciate the reply. So I take it you either fixed the problem or replaced the valve?
tzxlyd is offline   Reply With Quote
Old 02-26-17, 08:16 PM   #8
Zerodrag
Driver
iTrader: (4)
 
Zerodrag's Avatar
 
Join Date: Sep 2009
Location: CA
Posts: 150
Thanks: 0
Thanked 2 Times in 2 Posts
Default

I bought a used one off eBay for around $40-50 and just swapped it in. No need to buy a new one when you should be able to find one used either online or at a junkyard. I think they were the same for the 300s and 400s, but not 100% positive.
Zerodrag is offline   Reply With Quote
Old 03-02-17, 07:43 PM   #9
tzxlyd
Rookie
 
Join Date: Mar 2015
Location: tx
Posts: 88
Thanks: 0
Thanked 1 Time in 1 Post
Default

Zerodrag,
Thanks I will look on eBay.
tzxlyd is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2008 Lexus IS250 AWD: Heater blowing cold air, please help. Lexus267 IS - 2nd Gen (2006-2013) 0 01-31-17 03:50 PM
Heated Seat Blows Cold Air SuperCoupe400 LS - 3rd Gen (2001-2006) 4 01-14-17 05:50 PM
Heater Blowing Only Cold baphomit Performance & Maintenance 3 04-13-16 08:25 AM
No heat on drivers side Donnbuk1 GS - 2nd Gen (1998-2005) 5 12-09-15 01:57 PM
Is your car's engine slow to warm up in the winter? mmarshall Car Chat 24 01-06-13 08:22 PM


Tags
heat, thermostat

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 03:29 AM.


Copyright © 2000-2017 Internet Brands, Inc. All Rights Reserved
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: