Go Back  ClubLexus - Lexus Forum Discussion > General Forums > Car Chat
Help! 2014 Rav4 radio HU won't boot/reboots after locking up >

Help! 2014 Rav4 radio HU won't boot/reboots after locking up

Car Chat General discussion about Lexus, other auto manufacturers and automotive news.

Help! 2014 Rav4 radio HU won't boot/reboots after locking up

 
Old 01-07-19, 12:01 PM
  #1  
2013FSport
Lexus Champion
Thread Starter
iTrader: (2)
 
2013FSport's Avatar
 
Join Date: Aug 2017
Location: OR
Posts: 2,110
Received 221 Likes on 209 Posts
Red face Help! 2014 Rav4 radio HU won't boot/reboots after locking up

Preface, it is not my car but with so many members on here, I thought someone might have encountered this before.

This is a base unit, no Navigation just bluetooth AM/FM CD and backup camera. Camera and display work fine.
Car has 55k miles and no other issues. Just a few days ago the unit locked up while playing FM radio and could not be turned off or changed in any way. No buttons would respond (not a touch screen model), so I pressed and held the on/off button upon ignition on and it rebooted. Now it is stuck repeating this boot loop but never making it to the end. Goes to 95% and stays there for as long as the ignition is on.

I've done a lot of looking and it seems there are no fixes for this problem other than replacement.

Anyone have any ideas? Pulling fuses and battery disconnects do nothing to help.

2014 Rav4 dead head unit
2013FSport is offline  
Old 01-07-19, 01:39 PM
  #2  
2013FSport
Lexus Champion
Thread Starter
iTrader: (2)
 
2013FSport's Avatar
 
Join Date: Aug 2017
Location: OR
Posts: 2,110
Received 221 Likes on 209 Posts
Default


Looks like so.... stuck!
It almost seems like software issue vs some mechanical. Fault. Holding the power button down and toggling the lights from off to on 3 times does not place it into diagnostic mode as it never posts to a functional state.

Apparently not uncommon in various Toyota's of this era and a few Lexus vehicle's.

#radio loop, #radio reboot, #toyota radio failure
2013FSport is offline  
Old 01-08-19, 12:56 PM
  #3  
2013FSport
Lexus Champion
Thread Starter
iTrader: (2)
 
2013FSport's Avatar
 
Join Date: Aug 2017
Location: OR
Posts: 2,110
Received 221 Likes on 209 Posts
Default

whitebeast
You ever seen something like this? Any clue what goes wrong? Some type of memory corruption?

Any input is welcome.
Thanks!
2013FSport is offline  
Old 01-15-19, 06:13 PM
  #4  
whitebeast
Lexus Champion
iTrader: (5)
 
whitebeast's Avatar
 
Join Date: May 2011
Location: CA
Posts: 2,758
Likes: 0
Received 49 Likes on 49 Posts
Default

yes, it's hard drive failure. 1 out of 5 is just simple update firmware is needed
whitebeast is offline  
Old 01-15-19, 06:54 PM
  #5  
Nad1370
Lexus Test Driver
 
Nad1370's Avatar
 
Join Date: Apr 2008
Location: Illinois
Posts: 821
Received 61 Likes on 59 Posts
Default

Looks like a dead unit.
Need the screen to navigate to update the firmware.
If its stuck in this loop, i dont think it will take the update.
Nad1370 is offline  
Old 01-16-19, 05:48 AM
  #6  
2013FSport
Lexus Champion
Thread Starter
iTrader: (2)
 
2013FSport's Avatar
 
Join Date: Aug 2017
Location: OR
Posts: 2,110
Received 221 Likes on 209 Posts
Default

So even the most basic units without NAV that only transfers your phone contacts use a hard drive?
Is that fair to say? When listening close it sounds like a mechanical drive seeking.

Sure would be nice to reload the OEM data on a new drive and not drop fortune on it when everything else is fine.


I'm guessing a sector by sector exact copy from a known good drive to replacement would not be possible outside of HU as its all proprietary. Sadness.
2013FSport is offline  
Old 01-16-19, 06:21 AM
  #7  
2013FSport
Lexus Champion
Thread Starter
iTrader: (2)
 
2013FSport's Avatar
 
Join Date: Aug 2017
Location: OR
Posts: 2,110
Received 221 Likes on 209 Posts
Default

Adding to the above; unit was not in for any firmware updates and I do not know what firmware version it was running at.

Are you saying a firmware update would have lessened the chances of hardware corruption? Just an observation but it ran from late 2013 to beginning of 2019. If I were a betting person I'd say the drive failed and corrupted itself.

I mentioned proprietary above, anyone ever looked and/or know what OS it runs on? It has to be some stripped down version of something OR Toyota proprietary.

Thanks! Any and All information is welcome!
2013FSport is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: