RX300: Terrible MPG average related to faulty transmission? - Page 2 - Club Lexus Forums


RX300: Terrible MPG average related to faulty transmission?

Reply
 
 
 
Thread Tools Search this Thread
Old 05-12-14, 06:59 AM   #16
hypervish
Lexus Fanatic
 
hypervish's Avatar
 
Join Date: Aug 2009
Location: NJ
Posts: 5,416
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by freedannyv View Post
Not as such no. I rely on the computer. The check light has just come back on and I've noticed that when I push the O/D button, it does not come up on the display. I guess this is what the mechanic saying the gears are not correctly working is about. A little concerning. Things just go from bad to worse with this vehicle.
You need to calculate by hand, the computer can often times be inaccurate. Till then, we don't know what mpg you are truly getting.
hypervish is offline   Reply With Quote
Old 05-12-14, 08:34 AM   #17
fastnoypi
Lexus Test Driver
 
Join Date: Nov 2009
Location: NJ
Posts: 1,230
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hypervish View Post
You need to calculate by hand, the computer can often times be inaccurate. Till then, we don't know what mpg you are truly getting.
agreed. Reset your odometer when you fill up completely. Your full tank is 17.2 gallons.

Drive till your 1/2 way mark and note your mileage and divide by 8.6 to get your mpg.
fastnoypi is offline   Reply With Quote
Old 05-15-14, 10:30 AM   #18
AnthonyMtz
Pole Position
 
Join Date: Apr 2014
Location: texas
Posts: 368
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I noticed that when i ran 87 octane (Unleaded fuel) my rx got terrible gas mileage so what i did i change my spark plugs with some ol' ngk irdum ones (old ones looked like they just about had it verry crusty and rusty and brown) cleaned my maf sensor (was extreamly dirty) changed my air filter (that thing looked like crap) then ran a can of sea foam through my engine, changed my oil got a filter and gasket for my transmission (trans oil was black smelled a tad burnt) went to the gas station to fill up on some good 93 octane (premium fuel) got 14 - 19.4 in the city and 24.5 on the freeway also noticed my transmission shifted smooth as silk and didn't drag anymore and on my rx300 i have about 175,000 on her clock
AnthonyMtz is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1999 rx 300 JannaG RX - 1st Gen (1999-2003) 1 10-17-16 01:32 PM
O2 Sensor and Fuel Mileage Live4brew LS - 1st and 2nd Gen (1990-2000) 17 10-23-12 01:24 AM
Poor Gas Milage PFB ES - 1st to 4th Gen (1990-2006) 5 08-09-10 08:13 PM
Getting Only 15MPG on IS350 ?!? micio IS - 2nd Gen (2006-2013) 45 09-13-08 03:11 PM
MPG problem slammedgs GS - 2nd Gen (1998-2005) 11 07-30-01 02:34 PM


Tags
14, 95, calculator, faulty, mpg, rx 300, rx300, transmission, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 12:40 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved