Go Back   Club Lexus Forums > Lexus Model Forums > GS Models > GS - Second Generation > Performance
Sign in using an external account
Register Forgot Password?

help! CEL, VSC, VSC OFF lights on! no acceleration...

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-26-07, 03:01 PM   #1
GQD_GS4
Lexus Test Driver
Trader Score: (0)
 
Join Date: May 2005
Location: IL
Posts: 1,478
Default help! CEL, VSC, VSC OFF lights on! no acceleration...

help guys!

something is wrong with my car... my CEL, VSC, and VSC OFF lights all turned on, and my gas pedal doesnt work unless i press it *all the way down.* am i in limp mode? i unplugged the 2 sensors next to the throttle body to try and get rid of the lights but it didnt work. then i disconnected the battery for 15 minutes to reset the ECU and that didnt work either.

i've been searching on CL and i think i need either a TPS or an accelerator position sensor. which one do i need and how much do each of these cost?

and can i buy these from carson or sewell (contact info?)?

thanks in advance guys
vince
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
GQD_GS4 is offline   Reply With Quote
Old 01-26-07, 04:50 PM   #2
Spyder78
Lexus Champion
Trader Score: (6)
 
Spyder78's Avatar
 
Join Date: Dec 2004
Location: NY
Posts: 3,364
Send a message via AIM to Spyder78
Default

you need to plug in the obd 2 scanner and see what codes you are throwing. Usually the vsc lights are associated with suspension components. Go to autozone and they can pull the code for you for free.
Spyder78 is offline   Reply With Quote
Old 01-26-07, 05:21 PM   #3
w_star_001
Driver
Trader Score: (0)
 
Join Date: Jan 2003
Location: California
Posts: 110
Default

yeah go to Autozone and pull the code. the scanner will give u a little info about the code. keep us posted...
w_star_001 is offline   Reply With Quote
Old 01-26-07, 06:04 PM   #4
LEXUS_KID
Lexus Fanatic
Trader Score: (4)
 
LEXUS_KID's Avatar
 
Join Date: Dec 2004
Location: IN THE POKER ROOM!!!!
Posts: 10,793
Send a message via AIM to LEXUS_KID Send a message via Yahoo to LEXUS_KID
Default

It also could be your (TPS) Throtle Position Sensor
__________________
http://www.clublexus.com/gallery/data//500/lexus_kidsigx.jpg


~WEALTH IS WHAT YOU ACCUMULATE, NOT WHAT YOU SPEND~
LEXUS_KID is offline   Reply With Quote
Old 01-26-07, 06:52 PM   #5
blackgs415
Driver School Candidate
Trader Score: (0)
 
Join Date: Dec 2006
Location: CA
Posts: 7
Default

Pull the codes.

I had the same prob.
Codes I got was P1120 and P1121

Looked up the the codes and it was the Accelerator Pedal Position Sensor

Bought the part 2206046010-LEVER ASSY, THROTTLE from Lexus
Installed it the same night it arrived.

No more problemo!
blackgs415 is offline   Reply With Quote
Old 01-26-07, 06:55 PM   #6
blackgs415
Driver School Candidate
Trader Score: (0)
 
Join Date: Dec 2006
Location: CA
Posts: 7
Default

BTW: The information I found on this site was priceless. I am a new Lexus owner and it turns out the this is a common problem with the GS.
blackgs415 is offline   Reply With Quote
Old 01-26-07, 07:04 PM   #7
DSM2GS400
Driver
Trader Score: (0)
 
Join Date: Oct 2005
Location: Ontario
Posts: 167
Default

Had a similar problem today. Restarted the car and the problem went away. The night before I got a car wash and it was realy cold afterwards -17, I'm hoping that was part of the problem. Never happened before and I hope never again.
__________________
98 Lexus GS400
Sneaky fast...
白求恩

04 Cadillac XLR
Thunder Grey
#000075
DSM2GS400 is offline   Reply With Quote
Old 01-26-07, 08:48 PM   #8
GQD_GS4
Lexus Test Driver
Trader Score: (0)
 
Join Date: May 2005
Location: IL
Posts: 1,478
Default

Quote:
Originally Posted by blackgs415 View Post
Pull the codes.

I had the same prob.
Codes I got was P1120 and P1121

Looked up the the codes and it was the Accelerator Pedal Position Sensor

Bought the part 2206046010-LEVER ASSY, THROTTLE from Lexus
Installed it the same night it arrived.

No more problemo!
thanks for the input guys,

ok i went to autozone and i got one code: P1120. so i guess i'm in the same boat as blackgs415. how much does this Accelerator Pedal Position Sensor cost?

and BTW this also happend to me after i got my car washed! it wasnt that cold either, approximately 25 degrees out yesterday and 40 degrees today...
GQD_GS4 is offline   Reply With Quote
Old 01-26-07, 09:00 PM   #9
GQD_GS4
Lexus Test Driver
Trader Score: (0)
 
Join Date: May 2005
Location: IL
Posts: 1,478
Default

BTW whats what's carson lexus's contact info and who do i talk to there?
GQD_GS4 is offline   Reply With Quote
Old 01-27-07, 02:27 AM   #10
GILLEXUS
Lexus Champion
Trader Score: (14)
 
Join Date: Dec 2002
Location: Colorado
Posts: 1,776
Default

Found the part for $221 at Park place Lexus, Check Carason Toyota 1-800-908-6968 or 310-522-2300 and Try Sewell Lexus

http://www.trademotion.com/partlocat...&siteid=213808

Before I buy anything I would try re-setting the ECU who knows it may fix the problem?
__________________
2001-GS430-Gold Met.-L-Tuned Shocks/ECU,Eibach,JP rear spoiler,Tint,I forged-Classic,Borla SS,LMW-Remote start,WIN billet grill,Win billet grill

Last edited by GILLEXUS; 04-06-07 at 04:44 PM..
GILLEXUS is offline   Reply With Quote
Old 01-27-07, 05:45 AM   #11
aliti19
Lexus Test Driver
Trader Score: (0)
 
aliti19's Avatar
 
Join Date: Mar 2005
Location: Chicago, IL
Posts: 1,483
Send a message via AIM to aliti19
Default

Quote:
Originally Posted by LEXUS_KID View Post
It also could be your (TPS) Throtle Position Sensor
I saw TPS & had a mental picture of Office Space. LOL
Click the image to open in full size.
__________________
2012 VW GTI
~2002 GS430: sold!
~1999 ES300:Sis ~2004 LS430: Dad
aliti19 is offline   Reply With Quote
Old 01-27-07, 08:32 AM   #12
@lpher
Lead Lap
Trader Score: (0)
 
@lpher's Avatar
 
Join Date: Jan 2006
Location: Norway
Posts: 536
Send a message via MSN to @lpher
Default

Quote:
Originally Posted by blackgs415 View Post
Pull the codes.

I had the same prob.
Codes I got was P1120 and P1121

Looked up the the codes and it was the Accelerator Pedal Position Sensor

Bought the part 2206046010-LEVER ASSY, THROTTLE from Lexus
Installed it the same night it arrived.

No more problemo!

Is it an easy DIY?
__________________
2010 Toyota Avensis
1999 Lexus GS300 (sold)
1994 Toyota Supra TwinTurbo (sold)
1991 Toyota Celica 2.0 GTi (Sold)
@lpher is offline   Reply With Quote
Old 01-27-07, 09:20 AM   #13
w_star_001
Driver
Trader Score: (0)
 
Join Date: Jan 2003
Location: California
Posts: 110
Default

i also got the same lights on(CEL, VSC , VSC OFF) and the code i got is P0505( Idle control system malfunction). what parts do i need to replace? the thing is my car runs just fine.
w_star_001 is offline   Reply With Quote
Old 01-27-07, 04:11 PM   #14
GQD_GS4
Lexus Test Driver
Trader Score: (0)
 
Join Date: May 2005
Location: IL
Posts: 1,478
Default

Quote:
Originally Posted by GILLEXUS View Post
Found the part for $221 at Park place Lexus, Check Carason Toyota 1-800-908-6968 or 310-522-2300 and Try Sewell Lexus

http://www.trademotion.com/partlocat...&siteid=213808

Before I buy anything I would try re-seting the ECU who knows it may fix the problem?


thanks for going the extra mile for me! i said earlier though that i already tried resetting the ECU and it didnt work.


BTW so i started my car this morning and strangely enough all the check lights didnt show up this time and my car ran perfectly fine. i dont know whats up with my car, but i thinking i should get that part anyway to ensure that this doesnt happen again...
GQD_GS4 is offline   Reply With Quote
Old 01-27-07, 07:49 PM   #15
GQD_GS4
Lexus Test Driver
Trader Score: (0)
 
Join Date: May 2005
Location: IL
Posts: 1,478
Default spoke too soon @#%@$

i guess i spoke too soon guys. so i was on my way out tonight and i turn on my car and bamm, on come all the CEL lights again...


arrgh
GQD_GS4 is offline   Reply With Quote
Old 01-27-07, 07:49 PM
 
 
 
 
Reply

Tags
400, 98, 99, acceleration, acelerator, code, gs, gs400, lexus, light, lx470, p1120, p1121, picture, position, rx330, sensor, vsc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VSC OFF, VSC TRAC, CEL but no SKID Light Kermee GX - First Generation 7 03-11-13 12:33 PM
cel,vsc,vsc off, and abs light on????? rylee Maintenance 1 11-25-11 03:39 PM
Help with CEL, VSC, VSC OFF lights, CEL P1120 and 1121 treimche GS - Second Generation 13 02-04-11 04:23 PM
CEL Code: P0018 Blk04GS430 GS - Second Generation 0 10-04-10 11:55 PM
CEL then VSC OFF/CHECK VSC problems audphile1 LS430 1 04-09-09 09:10 PM

All times are GMT -7. The time now is 11:04 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info