Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 400/300 > Performance & Maintenance
Sign in using an external account
Register Forgot Password?

O/D light flashing on 93 SC300

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 06-18-14, 10:37 AM   #1
JoeBazz
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2008
Location: ny
Posts: 6
Default O/D light flashing on 93 SC300

I no this has been covered many times.but I cant get that O/D light to stop coming back.The car has 134k on it.October 2013 I changed all 3 shift solenoids, filter and Royal Purple fluid.Drove the car for 15-20 miles in the local streets and hwy for about 1/2 hour or so.Away the car went with no light.I don't drive the car in the winter it stays covered under a car port till May.I start the car every two weeks and drive it around the block.When it was time to take it out The first day on the road that annoying light came back.I checked the code it was 42 bad #1 speed sensor.I put a new one in while the negative cable was off.Drove it in the local streets for 10 min no light.Once I hit 60 mph on the hwy light back on.Does anyone have any other suggestions.Local mechanics are puzzled also One thinks bad ground in ecu or bad ecu.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
JoeBazz is offline   Reply With Quote
Old 07-11-14, 04:40 PM   #2
JoeBazz
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2008
Location: ny
Posts: 6
Default

Had ECM rebuilt.Fixed all my problems.I used roadrunner4444 on ebay.Shipped it to him on Saturday had it back Thursday.Car good as new.
JoeBazz is offline   Reply With Quote
Old 07-13-14, 09:50 AM   #3
SC400slide
Lexus Champion
Trader Score: (7)
 
SC400slide's Avatar
 
Join Date: Apr 2012
Location: In Recovery mode
Posts: 3,050
Jonathan Hoppman SC400slide
Send a message via Skype™ to SC400slide
Default

Daryl does a great job with rebuilding the Lexus ECU's.
__________________
1992 SC400 152k Italian leather, RX8 Shinkas, Megan LP's, 1995 SC400 190k, 1999 GS300 210k, 2001 Toyota Sequoia 235k, 2003 Chevy Suburban 175k Fuel Throttle rims, Nitto/grabber terrains, 1999 NB Miata 165k Tokicos, 2000 Miata SE 6 Spd 110k, Exedy, DRB Drags
Lebo Boh tak miloval svet...
TLN #49 BURNT BROWNIE
SC400slide is offline   Reply With Quote
Old 07-13-14, 09:50 AM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
PA FS: '97 SC300 (Onyx) CityKnight Lexus Vehicles Classifieds 5 07-31-13 09:43 PM
RX300 Transmission Hesitant to Downshift mike96sc2 RX - First Generation 0 07-24-13 01:52 PM
overdrive issue xmssc300 Performance & Maintenance 8 02-06-13 03:09 PM
getting 10 mpg and some problems with my car ryosuke SC 400/300 12 07-26-11 05:36 PM
Is Royal Purple 5w30 any good? UberNoob Maintenance 50 07-22-07 08:51 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 06:46 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info