Go Back   Club Lexus Forums > Lexus Model Forums > GS Models > GS - Second Generation
Sign in using an external account
Register Forgot Password?

Radio Display

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 03-18-15, 06:19 PM   #1
lex442
Driver School Candidate
Trader Score: (0)
 
lex442's Avatar
 
Join Date: May 2014
Location: Tx
Posts: 4
Default Radio Display

I have a 99 GS300 which I purchased new in 99. The car has about 95k on it. i have not driven it a lot. The problem I am having with it. is the radio display wont show any dialogue, very little. So I cant tell which stations its on. The radio works great other than the display. I took it back to the dealer about 6 months after I had bought it for the same thing. So I think they replaced it. Does anyone have any idea is there something that I might be able to adjust to get the display back?

Thanks in advance
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
lex442 is offline   Reply With Quote
Old 03-18-15, 06:24 PM   #2
Mr Jokster
Lexus Fanatic
Trader Score: (8)
 
Mr Jokster's Avatar
 
Join Date: Aug 2008
Location: California
Posts: 5,167
https://www.facebook.com/nathaniel.alaniz.58
Send a message via Yahoo to Mr Jokster
Default

Maybe a problem with your dimmer, how are your gauges and climate control lighting, do they seem dim?

First post in a year... welcome
__________________


Drag car:
~650WHP 2003 Grand Prix (yes, its front wheel drive can you dig!?)
http://www.fullthrottlev6.com/forums...ad.php?t=36212
http://www.youtube.com/watch?v=y3E7xkQqpKs

Quote:
Originally Posted by gs400rpg View Post
Mr Jokster : Perfect example of 22's done right IMO
Mr Jokster is offline   Reply With Quote
Old 03-23-15, 06:18 AM   #3
lex442
Driver School Candidate
Trader Score: (0)
 
lex442's Avatar
 
Join Date: May 2014
Location: Tx
Posts: 4
Default

Quote:
Originally Posted by Mr Jokster View Post
Maybe a problem with your dimmer, how are your gauges and climate control lighting, do they seem dim?

First post in a year... welcome
Thanks!. The dimmers work fine, other gauge lighting is good also. I believe its something gone wrong inside the radio itself. I think I am going to pull it out and take to an electronic radio repair shop, Other than not being able to see what station I have it on its working really good.
lex442 is offline   Reply With Quote
Old 03-23-15, 09:03 AM   #4
UDel
Lexus Champion
Trader Score: (0)
 
Join Date: Feb 2005
Location: ------
Posts: 4,458
Default

Quote:
Originally Posted by lex442 View Post
I have a 99 GS300 which I purchased new in 99. The car has about 95k on it. i have not driven it a lot. The problem I am having with it. is the radio display wont show any dialogue, very little. So I cant tell which stations its on. The radio works great other than the display. I took it back to the dealer about 6 months after I had bought it for the same thing. So I think they replaced it. Does anyone have any idea is there something that I might be able to adjust to get the display back?

Thanks in advance
My radio has randomly displayed all kinds of different numbers, letters, symbols on the screen like it is going haywire for years but it will also display the radio station, CD. It has always worked fine though except the face volume/power button stopped working, steering wheel controls work fine. I have thought about seeing about getting it fixed but it will probably be some ridiculous cost, I can live with what it does as it still works and I mainly use the Sirius tuner to listen to Sirius.

Have you tried unhooking the battery and resetting it? May be worth a shop.
__________________
-----------------------------------------------------------------------------------------------
UDel is offline   Reply With Quote
Old 03-23-15, 10:41 AM   #5
TaninAuto
Sponsor
Trader Score: (0)
 
TaninAuto's Avatar
 
Join Date: May 2012
Location: WI
Posts: 422
TaninAutoElectronix TaninElectronix
Default

Common problem. You have to order a new LCD display from Pioneer. They are around $200 if I remember right.
__________________
--
Jason Tanin - Owner
Tanin Auto Electronix
Racine, WI
Office - 262-456-4147
www.TaninAutoElectronix.com

http://www.facebook.com/TaninAutoElectronix
TaninAuto is offline   Reply With Quote
Old 03-23-15, 12:02 PM   #6
KTGS300
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2006
Location: CA
Posts: 35
Default

Same thing happened to mine. It would display random garbage and return to normal for a while until one day it totally craps out on you. Everything else works fine, just can't see what I am listening to. So I finally caved and going to put in an aftermarket stereo instead.
KTGS300 is offline   Reply With Quote
Old 03-23-15, 01:09 PM   #7
illtww
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2012
Location: SC
Posts: 12
Default

Is it the actual LCD that goes bad or the Lights behind the LCD panel on the radio? or a combo of both?
illtww is offline   Reply With Quote
Old 03-23-15, 03:47 PM   #8
lex442
Driver School Candidate
Trader Score: (0)
 
lex442's Avatar
 
Join Date: May 2014
Location: Tx
Posts: 4
Default

Quote:
Originally Posted by illtww View Post
Is it the actual LCD that goes bad or the Lights behind the LCD panel on the radio? or a combo of both?
Its the LCD that is not displaying the information. The lights on it is ok. I think I am going to pull it off and see if I can get it fixed. Just cant see what station I am listing to.
lex442 is offline   Reply With Quote
Old 03-23-15, 05:02 PM   #9
lex442
Driver School Candidate
Trader Score: (0)
 
lex442's Avatar
 
Join Date: May 2014
Location: Tx
Posts: 4
Default

Quote:
Originally Posted by TaninAuto View Post
Common problem. You have to order a new LCD display from Pioneer. They are around $200 if I remember right.
Thanks very much
lex442 is offline   Reply With Quote
Old 03-23-15, 06:29 PM   #10
Shorty SMC
Driver School Candidate
Trader Score: (0)
 
Shorty SMC's Avatar
 
Join Date: Jan 2009
Location: MN
Posts: 48
Default

My bulbs are out... anyone know what voltage they are?

I think I read somewhere that they were 8v? But I can't find that post now, that may have been other lights.
My backlight bulbs are out... I've got time tomorrow to hit radioshack and see what they have for bulbs / LED's I could swap in
__________________
2001 GS300 "SYRUP"
Shorty SMC is offline   Reply With Quote
Old 03-23-15, 06:29 PM
 
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 08:55 PM.

Join ClubLexus

Copyright © 2000-2015 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info