P0130, P0133, P0150, P0153 codes - Club Lexus Forums

Log In 

P0130, P0133, P0150, P0153 codes

Reply
 
 
 
Thread Tools Search this Thread
Old 06-21-16, 01:22 PM   #1
karolgt
Rookie
Thread Starter
 
karolgt's Avatar
 
Join Date: Nov 2013
Location: Poland
Posts: 65
Default P0130, P0133, P0150, P0153 codes

Hi

I have a problem with above codes and I have no idea how to fix it.

It started from the code suggested that Oxygen Sensor Bank 2 Sensor 1 is broken, so I replaced it with new Denso DX0109 (my frien has LS430 and he used the same model and it is working fine).

Then, P0150, so ok...I bought another one Denso DX0109 and replaced Oxygen Sensor Bank 2 Sensor 2.
After about 10 km, Check Engine disappeared, but after about 50 km I got:

P0130, P0133, P0150, P0153 codes

I cleared the CE light, but after 50 km, CE back.

The next problem is that I feel smelt from the exhaust.

Any idea?

Thanks
karolgt is offline   Reply With Quote
Old 06-21-16, 01:36 PM   #2
Mcon
Lexus Test Driver
 
Mcon's Avatar
 
Join Date: Jan 2014
Location: North America
Posts: 991
Default

You have a leak in your exhaust system. Maybe a gasket that is dad (broken) and this causes the leak. Also maybe, one of your exhaust pipe have a hollow or is cracked and so you smell what you smell.

Go to any muffler shop let the guy what you smell and he can let you know if you have a crake on you system or you need a new gasket. 99% of the time is, that you need to install a new exhaust gasket.
Them clean the cel and see what happen. Good luck.
Mcon is offline   Reply With Quote
Old 06-22-16, 04:41 AM   #3
karolgt
Rookie
Thread Starter
 
karolgt's Avatar
 
Join Date: Nov 2013
Location: Poland
Posts: 65
Default

Hi

I checked exhaust system 3 times, and there is no leak.

Do you know where can I find information about Oxygen Sensors voltage? I have Techstream so I can check how all Oxygen Sensors are working.

Thanks.
karolgt is offline   Reply With Quote
Old 06-22-16, 10:58 AM   #4
Mcon
Lexus Test Driver
 
Mcon's Avatar
 
Join Date: Jan 2014
Location: North America
Posts: 991
Default

I send you a pm
Mcon is offline   Reply With Quote
Old 06-24-16, 07:40 AM   #5
karolgt
Rookie
Thread Starter
 
karolgt's Avatar
 
Join Date: Nov 2013
Location: Poland
Posts: 65
Default

Thanks Mcom

Today I disconnected battery for about 2 hours, I will wait for next CE light and check codes.

But I'm thinking, maybe just new O2 sensor is not as fast as should be, so I will try to replace it once again.
karolgt is offline   Reply With Quote
Old 06-24-16, 07:58 AM   #6
Mcon
Lexus Test Driver
 
Mcon's Avatar
 
Join Date: Jan 2014
Location: North America
Posts: 991
Default

Very happy to help you.
Mcon is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New Owner! Rides Like A Dream! Organized Garage Status ES - 1st to 4th Gen (1990-2006) 13 07-27-16 05:01 PM
'95 ES 300 check engine light and codes JCC511 ES - 1st to 4th Gen (1990-2006) 5 11-20-15 05:37 PM
A lot of engine error codes danielmew LS - 3rd Gen (2001-2006) 1 08-03-15 01:23 AM
P0130, P0133, P0150, P0153, P0171 After TB Change vsop4me GS - 2nd Gen (1998-2005) 2 09-02-14 11:54 AM
P0174 P0171 and P0325 Bumbobee ES - 1st to 4th Gen (1990-2006) 2 05-25-14 11:31 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 02:14 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved