hks evc-s issues - Club Lexus Forums


hks evc-s issues

Reply
 
 
 
Thread Tools Search this Thread
Old 07-20-13, 12:26 PM   #1
Nixspeed
Lead Lap
Thread Starter
 
Join Date: Jan 2012
Location: CO
Posts: 511
Default hks evc-s issues

Anyone have one of these? I put one on my Aristo swap and it will not hit a steady boost turned on. In off mode it goes right to WG pressure and holds steady. Otherwise it'll hit 15 then stop to 8 then back to 12. I've tried adjusting all the settings with no change at all. Once in a while it'll hold one boost level then next time I get on it it'll be all over again. All my other turbo cars I run Greddy profec and never had a problem like this.
Nixspeed is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
VA FS: HKS EVC VI Boost Controller and Boost-by-Gear Software 99 GS3 SC400 / 300 Classifieds 3 07-13-15 09:08 PM
Blower speed LEX_GS4 GS - 2nd Gen (1998-2005) 2 09-19-14 02:48 PM
Mines ECU Sag Performance & Maintenance 7 11-06-13 12:01 PM
Hks evc-s s set up Rande Performance 4 03-24-12 02:43 AM
Are my mods safe for my 1jz twins? StuntKing Performance & Maintenance 4 03-09-11 11:10 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 11:40 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved