Techstream & Cable Problem and solutions - ClubLexus - Lexus Forum Discussion

Notices
SC430 - 2nd Gen (2001-2010)

Techstream & Cable Problem and solutions

Reply

 
 
 
Old 07-13-18, 11:50 PM
  #1  
GmanSC
Lead Lap
Thread Starter
 
Join Date: Oct 2015
Location: CA
Posts: 640
Thanked 34 Times in 32 Posts
Default Techstream & Cable Problem and solutions

I'd like to share my experience with techstream cable and software problem, in case of new member of this forum has the same problem, you would know what to do.
Last year, I bought the Techstream cable version 10.10.18, firmware ver 1.4.5. Installed in my XP laptop, with no problem. But when I tried to connect to my SC, it failed with error message "Unable connect to VIM". Searched the net and Youtube and finally found the solution and fixed the problem.
Basically, I did not know that I had a Xhorse cable, and to fix the problem, you must run MVCI file, independently with Techstream file and reconfigure Techstream to Europe.
So here what to do:
1. When you get the cable, it came with a mini disk, you will have 3 files: Techstream, MiniVCi, and TSI key.
2. Install techstream software to a XP computer.
3. Unrav TSI key and run file.
4. Unrav Mini VCI file run file. Do not run Techstream before you run MVCI.
5. Now run Techstream.
6. You will get the message say "you need Java file". Do not ignore this message, download the Java file to your laptop.
7. Close Techsteam and run it again.
8. Reconfigure Techstream and choose Europe (if you have Xhorse Cable).
9. Connect cable to your OBD2 port of your SC
10. Insert key and turn it to ON
11. Click connect to vehicle, choose "auto select"
Techstream should connect to your vehicle, pay attention to the LED on the cable, it should flashing when techstream is reading infos from your car computer.
If "unable connect to VIM" message appear, you might have to reinstall the software. Good luck.

Ref:
https://www.slideshare.net/careucar1...connect-to-vim
This site to get Java file for your laptop.
https://priuschat.com/threads/help-t...to-vim.166358/
GmanSC is offline  
Reply With Quote
Old 07-14-18, 02:16 AM
  #2  
jdanielca
Rookie
 
jdanielca's Avatar
 
Join Date: Jun 2018
Location: Lviv, Ukraine
Posts: 96
Thanked 4 Times in 4 Posts
Default

thanks for the info but what cables should we be buying? is it your brand of cable that was the problem or is xhorse a type? I have a US spec car so just want to make sure I am buying the right thing.
jdanielca is offline  
Reply With Quote
Old 07-14-18, 06:41 AM
  #3  
iolmaster
Lexus Test Driver
iTrader: (1)
 
Join Date: Aug 2008
Location: Virginia
Posts: 868
Thanks: 0
Thanked 29 Times in 25 Posts
Default

Most of this is correct . However, there are a couple problems here. First, the firmware version is for the cable not Techstream and the 1.4.5 is not the most current version. Version 2.0.4 is current. Many of us were unable to connect with version 1.4 and were then able to connect with version 2. I would recommend getting the version 2 not 1 of the cable. Although I have read that you can run this on a 64 bit computer I have not been able to configure the drivers for the cable following the directions I have read. I do IT work and am very familiar with the Widows OS. If someone else has been successful they are better than me. I have had no problem installing both the drivers for the cable and the software on a Windows 7 32 bit system. If you are unable to connect it is unlikely that it is the Techstream software. The most likely problem is with the drivers for the cable. You should be able to go into Device Manager in Windows and check to see if the drivers loaded properly. There should be no "unknown devices" under USB. Also, if you choose Europe as your location you will have to change the units of measure from metric to English. Not a big deal.
Here is an Amazon post for the version 2 cable. Many ads do specify the firmware version. I have no idea why they all aren't version 2 at this point.

Amazon Amazon
iolmaster is offline  
Reply With Quote
Old 07-14-18, 07:43 AM
  #4  
GmanSC
Lead Lap
Thread Starter
 
Join Date: Oct 2015
Location: CA
Posts: 640
Thanked 34 Times in 32 Posts
Default

Iím speaking from my past experience, thisís happened in 2017. At that time, I believe it was the latest firmware version .
When I bought the cable, I did not know what Xhorse was . I had no idea until I tan into the problem, then found out from the internet. Guess we all have to learn.

Last edited by GmanSC; 07-14-18 at 07:54 AM.
GmanSC is offline  
Reply With Quote
Old 07-14-18, 08:41 AM
  #5  
iolmaster
Lexus Test Driver
iTrader: (1)
 
Join Date: Aug 2008
Location: Virginia
Posts: 868
Thanks: 0
Thanked 29 Times in 25 Posts
Default

Originally Posted by GmanSC View Post
Iím speaking from my past experience, thisís happened in 2017. At that time, I believe it was the latest firmware version .
When I bought the cable, I did not know what Xhorse was . I had no idea until I tan into the problem, then found out from the internet. Guess we all have to learn.
Actually no, I bought 2.0.4 in 2015 and I know it had been around for a while even then.
iolmaster is offline  
Reply With Quote
Old 07-14-18, 09:51 AM
  #6  
GmanSC
Lead Lap
Thread Starter
 
Join Date: Oct 2015
Location: CA
Posts: 640
Thanked 34 Times in 32 Posts
Default

Originally Posted by iolmaster View Post
Actually no, I bought 2.0.4 in 2015 and I know it had been around for a while even then.
Darn! That meant I got dupped from the vendor. Thanks.
GmanSC is offline  
Reply With Quote
Old 07-14-18, 12:00 PM
  #7  
Bgw70
Lexus Champion
 
Bgw70's Avatar
 
Join Date: Dec 2014
Location: Fl
Posts: 4,275
Thanked 206 Times in 171 Posts
Default

I have both cables firmware versions but my v1.4.1 will only work on my 2002 and 2007 SC430s. V2.0.4 will not communicate with the SC430s but will communicate with my relatives 2010 Camry. Must be something wrong with the newer cable.
My TechStream is running on USA, not Europe.
anyway, I took some pictures of the firmware versions and some TechStream screen shots for anyone interested in making the purchase. Techstream and the cable can be purchased for $25 on eBay.




This was using v2.0.4 on my 2007 SC430







Last edited by Bgw70; 07-14-18 at 12:03 PM.
Bgw70 is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: