Notices
RX - 2nd Gen (2004-2009) Discussion topics related to the 2004 -2009 RX330, RX350 and RX400H models
Sponsored by:
Sponsored by:

07 RX350 Transmission Shudder

 
Old 04-20-19, 12:24 AM
  #31  
stanleybg
Driver School Candidate
 
Join Date: Feb 2016
Location: Bulgaria
Posts: 40
Received 0 Likes on 0 Posts
Default

I beleive that the MAF sensor could be the problem. On Idle and hot engine it shows 2.8g/s . As i know it should show 3.5g/s. ANd may be this is why when i drive with 30mph and tranny shift to 5th gear and keeps 1000rpms. How are your cars ? When driving city with 30mph and crusie control or gas pedal static is your transmission shifting to overdrive at 1000rpms ? I think this is very low rpms.
stanleybg is offline  
Old 04-21-19, 08:07 AM
  #32  
stanleybg
Driver School Candidate
 
Join Date: Feb 2016
Location: Bulgaria
Posts: 40
Received 0 Likes on 0 Posts
Default

A little update. Its not torque converter shuddering. Its 5th gear at low RPM.Torque converter its not locking below 70km/h at all. And because of the bump that occurs at most times from 4th to 5th gear the culprit is there. Today i changed the oil with valvoline and its the same.Next week i will remove the valvebody and will clean all solenoids. Open them clean the bushing and install everything.The MAF i still think its not okey on hot engine idle to show 2.8g/s. It should be 3.5g/s. Anyone checked his values ?
stanleybg is offline  
Old 04-22-19, 10:45 AM
  #33  
stanleybg
Driver School Candidate
 
Join Date: Feb 2016
Location: Bulgaria
Posts: 40
Received 0 Likes on 0 Posts
Default

I have got the instructions how to test MAF sensor. Tommorow will check it. Today i ordered OEM Gasket kit for full transmission rebuild. And weekend will remove the valvebody and change all gaskets. Will open solenoids full clean them and valvebody. If that does not help then there in some clutches or pistons inside is a problem and will open and change all needed. I hope with the valvebody will fix it because there is no sense on fift gear and full trothle not to slip , but only on low rpms. Its possible the oil pump to have cloged or somethink and in low RMP to be low pressure. But logic is if on low rpm the oil pressure is low it also will not shift okey. When i changed the filter also there was little debris in oil pan. There are several parts that are changed in design inside the transmission and one of them is the oil pump , some pistons and one clutch pack.

About MAF i checked it with TPS sensor and it reacts perfect linear between TPS and MAF are perfect. Also fuel trims are perfect less that 5-6% and evet on idle 0-2% difference.
stanleybg is offline  
Old 04-22-19, 07:26 PM
  #34  
tomr51
Driver
 
Join Date: Jul 2017
Location: NSW
Posts: 176
Received 16 Likes on 14 Posts
Default

Hi Stanley, I have only drained the pan and refilled.it a couple of times on the RX350. On my SC400 (soarer) i used to disconnect the transmission line from the radiator and do a full flush.

How do you do the full flush on the RX 350?
tomr51 is offline  
Old 04-23-19, 12:15 AM
  #35  
stanleybg
Driver School Candidate
 
Join Date: Feb 2016
Location: Bulgaria
Posts: 40
Received 0 Likes on 0 Posts
Default

I disconect the cooler line. And pass like 10 liters of oil with putting fresh in the pan. But i did two time this and result is that on 4th gear no more shudder. In 5th gear the same. Now i will put another lubegard platinum. From lubegard they responded to me very fast and friendly. They told me to use the platinum as it is the strongerst one. If under stress the 5th gear is okey and not slipping i beleive the clutches are okey. May be the valvebody solenoid or dirt is the problem. After i clean the all valvebody and replace the gaskets and filters i hope will fix the shudder. Its possible the piston that activates 5th gear to be bad ,bit i will see.
stanleybg is offline  
Old 04-27-19, 05:43 AM
  #36  
stanleybg
Driver School Candidate
 
Join Date: Feb 2016
Location: Bulgaria
Posts: 40
Received 0 Likes on 0 Posts
Default

Today i cleaned valvebody with fully open it and clean all mechanic valves inside. Also i opened solenoids to clean them from metal grey debris.After test drive it was shuddering again the same , but the test drive was also for fluid level check.After i added enough fluid shudder occurs only on 4th gear. Then i added lubeguard platinum and it fixed this shudder. But i hope it will fix it for long not shord period. If it continues next step is to open the gearbox and change pistons and clutches.

Last edited by stanleybg; 04-28-19 at 01:06 AM.
stanleybg is offline  
Old 04-27-19, 08:23 PM
  #37  
tomr51
Driver
 
Join Date: Jul 2017
Location: NSW
Posts: 176
Received 16 Likes on 14 Posts
Default

hope you have it fixed. 10 out of 10 for persistence Keep us up to date on how it progress.
tomr51 is offline  
Old 04-30-19, 11:05 AM
  #38  
stanleybg
Driver School Candidate
 
Join Date: Feb 2016
Location: Bulgaria
Posts: 40
Received 0 Likes on 0 Posts
Default

Today i drove the car 3 hour mostly on highway ,but also in city and no shudder at all. I am not sure it is cured , but when passing city there was no shudder even at 1000rpm. Next 5-6 days will show. Actually i also ordered :
BARDAHL HYDRAULIC VALVE LIFTERS ,
BARDAHL ATF CONDITIONER 300ML
VALVOLINE COOLING SYSTEM CLEANER
Bardahl 2 Oil Treatment 300ML
BARDAHL ATF FLUSH 300ML
If it continues , i will drive like 5000-10000km. Will make atf flush and refill with fresh fluid. If this did not help will add bardahl conditioner. If today it worked may be the new fluid cleaned a little clutches.
I also added extra magnets to the pan , from old computer hard drive. I beleive that the clutches are okey. My old rx300 2001 year broke hard. Fron planetary was very loose , and sun gear of rear planetary was totaly disconected from the drum. "destroyed". And the car was with badly noise and shifts only first gear. After i opened to repair it all clutches was in perfect condition. Theyr marks on the clutch matterial was reading perfectly. This is why i beleive that clutches are okey here also. I will continuine with the oil additives and flushes and if after this there is no improovement , i will surender and open it up with changing all clutches and pistons inside. And also upgrade the planetary with special solder that i did on the old tranny also. I buyed brand new front planetary and solder the weakest parts. It became perfect and works like a charm.
stanleybg is offline  
Old 05-24-19, 12:19 PM
  #39  
stanleybg
Driver School Candidate
 
Join Date: Feb 2016
Location: Bulgaria
Posts: 40
Received 0 Likes on 0 Posts
Default

Shudder is there , but in much harder environment. Now i am driving it and i will wait something to brake then full rebuild.
stanleybg is offline  

Thread Tools
Search this Thread
Quick Reply: 07 RX350 Transmission Shudder


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: