sc400 battery problem help?? - ClubLexus - Lexus Forum Discussion


Performance & Maintenance Engine, forced induction, intakes, exhausts, torque converters, transmissions, etc.

sc400 battery problem help??

Reply
 
 
 
Thread Tools Search this Thread
Old 11-27-11, 11:30 AM   #1
unknown159
Pole Position
Thread Starter
 
unknown159's Avatar
 
Join Date: Oct 2010
Location: fl
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
Default sc400 battery problem help??

went to start my car and the battery was dead so i took it to autozone and got a brand new replacement when i took the battery home put it in the car still wont start... the lights come on, the dashboard , go to start it, and nothing happens. All the lights and dashboard icons turn off
and then i wiggled it a bit went to start it again and saw a huge spark fly from the battery and then everything went completely dead no dashboard lights nothing im kind of confused really dont feel like spending anymore money on this dam car just want to find out the problem and sell it...any help would be great thanks...
unknown159 is offline   Reply With Quote
Old 11-27-11, 12:29 PM   #2
6SOARER
Lexus Test Driver
iTrader: (20)
 
Join Date: Jan 2009
Location: SoCal
Posts: 1,234
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So your not getting any power at all? If thats the case check all the fuses in the fusebox located under the hood. I would also check the battery terminals to see if they have good connection.

I changed out my terminals a while back, did not have any power. I was chasing my tail for a few hours and it turned out that the NEW terminals did not have any connection
6SOARER is offline   Reply With Quote
Old 11-29-11, 12:48 AM   #3
GS4_Fiend
Lexus Fanatic
iTrader: (22)
 
GS4_Fiend's Avatar
 
Join Date: Aug 2008
Location: CA
Posts: 6,665
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Make sure connections are tight.
GS4_Fiend is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help ! All the lights are on. JiggsHall LS - 4th Gen (2007-2017) 4 02-10-16 10:05 AM
2002 gs300 won't stop cranking ledfootdee GS - 2nd Gen (1998-2005) 8 02-26-15 01:23 PM


Tags
400 , 92 , battery , car , dead , hod , lexus , move , problem , problems , replacement , sc , sc400 , size , terminal

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 03:18 PM.


Copyright © 2000-2017 Internet Brands, Inc. All Rights Reserved We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: