1995 Lexus Sc300 Coupe - ClubLexus - Lexus Forum Discussion


Performance & Maintenance Engine, forced induction, intakes, exhausts, torque converters, transmissions, etc.

1995 Lexus Sc300 Coupe

Reply
 
 
 
Thread Tools Search this Thread
Old 03-19-11, 05:57 PM   #1
1995lexus
Driver School Candidate
Thread Starter
 
Join Date: Mar 2011
Location: Wa
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation 1995 Lexus Sc300 Coupe

I seem to be having some kind of heater issue.

Without warning....it started having issues 2 days ago. I got in my car, let it warm up as usual, but the heat was blasting out cold air. I waited and waited...After almost an hour it began to slowly warm up.

However...yesterday the heat didn't get warm at all. To make matters worse when I switched from outside air to inside air...it made a funny zinging noise everytime I switched it to outside air.

I ended up having to take a family member to the ER yesterday which is about 1/2 an hour from my house and the heater didnt blow hot air even at max heating temperature on the way there or back.

When we got home I turned off the car and got my family member situated and got ready to go down to our local grocery store. I went out and started up my car and it began making weird noises...(heater) The zinging noise when I started her up was there from the heater. Also, the middle of the display unit for the heater/ac began turning dark in the center of the strip.

Then when I hit my break to switch into gear, the brake clicked and the overhead lights flickered when I did that.

Still no heat!

Today I went out to start the car again, after checking all the fuses beneath the hood...which looked fine. The display no longer had the black in the middle, but there was still no heat and it still made zinging noises when I switched it into outside air supply....

I cant figure out what is wrong...... No emergency lights are coming on. All liquids that are visible are full. My phone charging unit works fine. The A/C works fine. The radio works fine. The power windows work fine. There was no warning of any kind. It doesnt seem to be leaking anything. I am at a loss...

Can anyone help?
1995lexus is offline   Reply With Quote
Old 03-19-11, 09:17 PM   #2
MrBrock
Driver
 
Join Date: May 2010
Location: Iowa
Posts: 188
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You'll probably need to bypass the heater control valve under the hood. There's a how-to on here if you search. Replacement of that valve would be ideal, but it's expensive. I bypassed mine for the winter.
MrBrock is offline   Reply With Quote
Old 03-20-11, 11:20 AM   #3
1995lexus
Driver School Candidate
Thread Starter
 
Join Date: Mar 2011
Location: Wa
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well...I'd rather not go the cheap way out. I know that in the long run I'll just have to pay that much more.

I've been researching and the nearest place to my home is Schucks O'reilly auto parts or Napa auto parts...but neither seems to carry the replacement part.
1995lexus is offline   Reply With Quote
Old 03-09-16, 04:36 PM   #4
Quadan1
Driver School Candidate
 
Join Date: Mar 2016
Location: Arkansas
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default 1995 lexus sc300

Quote:
Originally Posted by MrBrock View Post
You'll probably need to bypass the heater control valve under the hood. There's a how-to on here if you search. Replacement of that valve would be ideal, but it's expensive. I bypassed mine for the winter.
I have a Lexus sc300, it cranks over fine. The timing marks are accurate, getting spark and fuel pump is working what could be the issue for not starting? Possibly crank position sensor?
Quadan1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2004 LS 430 UL Heater Function Question cad55ken LS - 3rd Gen (2001-2006) 3 11-01-17 06:51 PM
LS400 1st gen: heater not working OMAHA LS - 1st and 2nd Gen (1990-2000) 18 10-31-17 10:53 AM
No heat on left , no a/c on right silverb5 RX - 1st Gen (1999-2003) 1 10-01-17 11:21 AM
Strange door creaking sound when using heater? jameshan IS - 3rd Gen (2014-present) 2 09-13-17 09:58 PM
Heater and defroster not working Cruisin101 LS - 1st and 2nd Gen (1990-2000) 3 07-24-17 08:08 PM


Tags
1995 , 300 , 95 , acheat , air , blowing , club , coupe , heat , heater , lexus , perofrmance , phone , sc300 , warm

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 08:38 PM.


Copyright © 2000-2017 Internet Brands, Inc. All Rights Reserved We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: