mark levinson amp lx470 - ClubLexus - Lexus Forum Discussion


LX - 1st and 2nd Gen (1997-2007) Post here for topics related to the LX470 or LX450

mark levinson amp lx470

Reply
 
 
 
Thread Tools Search this Thread
Old 09-24-13, 11:22 PM   #1
James77192
Driver School Candidate
Thread Starter
 
Join Date: Sep 2013
Location: NC
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default mark levinson amp lx470

the power transistor blew out of my friends amp under the seat ..blew the fuse then he put another and kept blowing ..i pull the amp and open it ..two badly blow transistors ..looks like a water leak from the roof earlier ..i am offering to solder the new trans ..but cant figure out the part numbers on three of them ..there is a power side with four of them ..any help would be greatly appriciated ..
James77192 is offline   Reply With Quote
Old 10-25-13, 03:32 PM   #2
rueym
Driver
 
Join Date: Apr 2008
Location: CA
Posts: 158
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by James77192 View Post
the power transistor blew out of my friends amp under the seat ..blew the fuse then he put another and kept blowing ..i pull the amp and open it ..two badly blow transistors ..looks like a water leak from the roof earlier ..i am offering to solder the new trans ..but cant figure out the part numbers on three of them ..there is a power side with four of them ..any help would be greatly appriciated ..
I have a spare amp if you need that I purchased thinking the problem was the amp but turned out to be head unit email me at [email protected] if you need a new amp I'll let it go for $200 shipped.
rueym is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fixed my Dead Nakamichi Amp kurbs62 Lexus Audio, Video, Security & Electronics 19 09-18-17 08:19 PM
MINI Low Profile 15 Amp Question Mrcoach LS - 4th Gen (2007-2017) 2 04-09-17 06:38 PM
Blower Motor Stopped Working 1991 LS400 Guywithcar LS - 1st and 2nd Gen (1990-2000) 8 02-02-16 03:51 PM
24k Miles and Tire blew on Tein H techs KingBryan IS - 3rd Gen (2014-present) 7 09-02-15 08:19 PM
Console 12V Outlet is blowing 15 Amp Fuses, nothing plugged in oldglo IS - 2nd Gen (2006-2013) 3 08-16-15 11:21 PM


Tags
2001lexus , 470 , adjusting , amp , amplifier , broken , levinson , lexus , lx , lx470 , mark , marklevinson , percy , percydynaudio

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 05:39 AM.


Copyright © 2000-2017 Internet Brands, Inc. All Rights Reserved We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: