Fixing dead head unit IS - 2nd Gen (2006-2013) - ClubLexus - Lexus Forum Discussion

Notices
Lexus Audio, Video, Security & Electronics
Sponsored by:

Fixing dead head unit IS - 2nd Gen (2006-2013)

 
Old 01-03-19, 05:43 PM
  #1  
Kendrick07
Rookie
Thread Starter
 
Kendrick07's Avatar
 
Join Date: Jul 2007
Location: California
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default "Check the connection to the air conditioner" IS - 2nd Gen (2006-2013)

SOLVED

2006 Lexus IS250

Hi all, I had the dreaded dead head unit issue. I know there are many variations of this issue, but mine was where the screen does not turn on and all the surrounding hard buttons don't work (no climate control, navigation, backup camera, stereo works without any control). I had checked all related fuses in all four fuse boxes (2 boxes under hood and 2 at kicker panels) and they were all good. I bought the board 86111-53040 and did the swap. Put everything back and now everything works again except the climate control. When I hit the hard climate button, the screen says "check the connection to the air conditioner". I took everything back out, backtracked literally everything and redid every connection, but I can't find anything wrong. Put it all back again and I'm still getting this when trying to use climate. I checked all the fuses again too. Anyone have any wisdom on this? Thank you!

SOLVED: All I needed to do was start the actual engine and it was good to go lol.


Last edited by Kendrick07; 01-04-19 at 05:24 PM.
Kendrick07 is offline  

Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: