TT SC400 1UZ 126MPH in the 1/4 - ClubLexus - Lexus Forum Discussion


Build Threads Details on Club Lexus SC owner vehicles

TT SC400 1UZ 126MPH in the 1/4

Reply
 
 
 
Thread Tools Search this Thread
Old 06-04-14, 10:55 AM   #1
rdm20fan
Lead Lap
Thread Starter
 
Join Date: Nov 2004
Location: Illinois
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Default TT SC400 1UZ 126MPH in the 1/4

Hi Guys,
I had a few updates that I thought I would share.

I took my 93 SC400 to the track yesterday (6-3-14)
I did about 6 runs
ET range from a 13.0 - 12.5 (Street tires and a lot of wheel hop)
and my MPH ranged from 119 - 126 mph
the 119-122 mph was at 18 psi
and the 126 was at 20 psi

I still have to upload the videos to youtube, but here is one my buddy took.

https://www.youtube.com/watch?v=L9Q3...ature=youtu.be

According to Great Lakes Dragaway's HP Calculator I put in 3800lbs with me as driver and trap speed of 126.6 and it's giving me a net HP of 601 :-)
That made me pretty happy.
http://www.greatlakesdragaway.com/in...page=analyzers

I'll try and post photos of the time slips, and videos

Car has 1st gen 1UZ, Stock heads & Cams. Upgraded springs.
Ross Pistons W/Pauter rods.
ARP head studs.
Stock ECU and additional injector controller 16 fuel injectors.
CM Racing twin turbo kit.
Getrag 6-speed
rdm20fan is offline   Reply With Quote
Old 06-04-14, 11:22 AM   #2
jadu
live.love.laugh.lexus
iTrader: (42)
 
jadu's Avatar
 
Join Date: Oct 2008
Location: CALI
Posts: 11,104
Thanked 37 Times in 32 Posts
Default

Nice runs! V8 ft 6 speed must be damn nice
jadu is offline   Reply With Quote
Old 06-04-14, 04:14 PM   #3
dasleepa
Driver School Candidate
 
Join Date: Dec 2013
Location: NY
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

vid not existing?
dasleepa is offline   Reply With Quote
Old 06-04-14, 07:45 PM   #4
rdm20fan
Lead Lap
Thread Starter
 
Join Date: Nov 2004
Location: Illinois
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I might just be me, but that is one sexy sounding SC
...................................................................................





Twin Turbo Lexus SC400 19 psi
12.59 @ 123.42 mph
Neon SRT4
13.45 @ 113.13
rdm20fan is offline   Reply With Quote
Old 06-04-14, 10:19 PM   #5
HiPSI
Lexus Test Driver
iTrader: (2)
 
HiPSI's Avatar
 
Join Date: May 2008
Location: VA
Posts: 933
Thanks: 0
Thanked 0 Times in 0 Posts
Default

126mph is moving with how heavy these cars are! pump gas?
HiPSI is offline   Reply With Quote
Old 06-05-14, 09:19 AM   #6
rdm20fan
Lead Lap
Thread Starter
 
Join Date: Nov 2004
Location: Illinois
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by HiPSI View Post
126mph is moving with how heavy these cars are! pump gas?
Thanks Hi PSI.
I was really pretty excited about the MPH. My ET's need some work.
I was hoping for a 120mph trap speed, and the first run of the day the car run a 119.9

As far a fuel, I have a unique set up.
I have 2 fuel systems.
I'm still running the stock fuel system, and stock ECU. (Running 93 octane) This takes care of the drive-abilty start up
I have a second fuel system (Tank, pump, lines, rails, and injectors) this system comes on at boost, and adds fuel. I'm running 800cc injectors on this set up with E85.
The motor really seems to love the E86. Drops the water temp, and she responds well.
rdm20fan is offline   Reply With Quote
Old 07-22-14, 10:23 AM   #7
rdm20fan
Lead Lap
Thread Starter
 
Join Date: Nov 2004
Location: Illinois
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Took the SC400 back to the track last Wednesday 7-16-14 I had a set of Mickey Thompson ET's on the back. Although my ET did go down, it went down just a little.

I had a pretty hard time getting the car to launch. Still a lot of wheel spin, and wheel hop.

I just purchased used Supra springs n struts in the hopes of getting the car to squat a little better then the stuff I have on the car now.

My MPH did take a pretty good jump.

The car ran a 12.20 @ 132 MPH and I had to lift for a second in 4th.

I did this at 23 psi. Think I needed to let a little bit of air out of the tires, as i was running them at 20 psi

I had a hard time keeping the car on the track.

I did up the boost to 25 psi, but I couldn't stay in the gas. The car was all over the track, and I was having to list 2 to 3 times in the 2 runs I did at the higher PSI.



I was on Dragtimes.com, and I currently have the highest MPH, but still chasing an 11 sec ET
rdm20fan is offline   Reply With Quote
Old 07-22-14, 11:12 AM   #8
KC95SC400
Lexus Test Driver
iTrader: (3)
 
KC95SC400's Avatar
 
Join Date: May 2007
Location: NC
Posts: 1,270
Thanks: 0
Thanked 2 Times in 2 Posts
Default

That's me with the lowest ET on dragtimes.com.

Your car is definitely capable of smacking me down, haven't run with the new blower yet though.

KC
KC95SC400 is offline   Reply With Quote
Old 07-22-14, 08:43 PM   #9
1JZPWRD
1JZ Single SC400
iTrader: (59)
 
1JZPWRD's Avatar
 
Join Date: Jan 2009
Location: Alabama, Roll Tide!
Posts: 8,512
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Dang fine numbers there. I would be impressed with those all day long.
1JZPWRD is offline   Reply With Quote
Old 07-23-14, 06:47 AM   #10
rdm20fan
Lead Lap
Thread Starter
 
Join Date: Nov 2004
Location: Illinois
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks guys, the car was starting to get hard to handle. Especially in 4th and 5th gear.

KC, what are you running for suspension?
Are you still running the factory trans?

Bob
rdm20fan is offline   Reply With Quote
Old 07-23-14, 06:56 AM   #11
rdm20fan
Lead Lap
Thread Starter
 
Join Date: Nov 2004
Location: Illinois
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have to work on that 60 foot, and my ET

rdm20fan is offline   Reply With Quote
Old 07-23-14, 08:47 AM   #12
KC95SC400
Lexus Test Driver
iTrader: (3)
 
KC95SC400's Avatar
 
Join Date: May 2007
Location: NC
Posts: 1,270
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by rdm20fan View Post
Thanks guys, the car was starting to get hard to handle. Especially in 4th and 5th gear.

KC, what are you running for suspension?
Are you still running the factory trans?

Bob
I have Supra Tokico Illumina shocks and Swift lowering springs. Solid diff ear mounts, the rear diff cushions are stock but have replaced with new. Every single suspension bushing on the car is poly. I also have some spacers on the front of the rear subframe which pretty much make it solid but I don't think I ever ran the car with these. Mickey Thompson DR's. Not sure of the size at the moment but they are not huge.

I have been in the 1.6's for 60ft's.

Transmission is auto and has been rebuilt with raybestos blue plate clutches and an upgraded second gear sprag. IPT did the valve body. I have a Suprastick transmission controller.

I set the rear shocks to the softest setting when at the drags, leave the front in the middle. Usually launch somewhere around 2800 rpm.

Suggestions for you- Remove the front sway bar. Just for the track. I have never tried this but it is supposed to allow allot more weight transfer to the rear when launching. Don't try to launch harder than the track / car will let you. Yes if you can launch harder and stick you will run faster but if it won't stick it will just slow you down. Try a different track. Maybe the prep at the track you've been going to sucks. This is often true if they are doing a test and tune and it is a slow night. Play with the air pressure in the tires. Try different burnouts. Try short. Try long. Try into second gear. I don't know if you are spinning in 4th and 5th or if it is just getting unstable but too little air pressure or bias ply (non radial) tires can cause it to feel unstable at high speeds.
KC95SC400 is offline   Reply With Quote
Old 07-23-14, 11:49 AM   #13
KC95SC400
Lexus Test Driver
iTrader: (3)
 
KC95SC400's Avatar
 
Join Date: May 2007
Location: NC
Posts: 1,270
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Forgot to mention the Supra LSD Torsen diff.

If you have an open differential, it could be your whole problem.
KC95SC400 is offline   Reply With Quote
Old 07-24-14, 06:12 AM   #14
rdm20fan
Lead Lap
Thread Starter
 
Join Date: Nov 2004
Location: Illinois
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks KC. I have the supra TT auto diff. I did replace the front diff mounts. I was running 20 psi in the slicks. After a little research I guess this is a little high. 18-15 is probably where the tires like it.
I am spinning in 4th at the higher psi. Don't know about 5th, I can't stay in the gas at 25psi.
I purchased a used set of supra shocks/springs. I'm gonna see if this helps at all.
I'm currently running intraks supra lowering springs. ( the car is low. I think it's a 3" drop) and agx shocks.
I know a few of the guys at sound performance and they have suggested stock supra stuff.

Baby steps right?
Thanks for the tips.
Bob
rdm20fan is offline   Reply With Quote
Old 07-24-14, 09:22 AM   #15
turbodremz
Lexus Champion
iTrader: (18)
 
turbodremz's Avatar
 
Join Date: Jan 2008
Location: TX
Posts: 4,870
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Very nice runs. I also found that 20psi is too much for DR's, even the ET's. I run my DR's at 18psi now with my LSx setup and hook just fine.

I have to say, after seeing these vids and your e.t.'s, I have a new respect for the 1UZ. And racing at 3800lbs and low 12's is pretty impressive. Any incar vids by chance?
turbodremz is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
DIY Shock Revalve: PARTS 1-3 kene GS - 1st Gen (1993-1997) 66 08-11-17 04:48 PM
My GS300 Turbo VS 12 second Mach 1 adamgamz Performance 28 05-20-17 03:30 PM
Twin Turbo 1UZ street/strip car! BLK40T Drag Strip 7 10-30-16 03:50 PM
Mercedes-AMG GLC43 Hoovey2411 Car Chat 6 03-19-16 06:24 AM
402hp stock everything. just about weeters SC- 1st Gen (1992-2000) 23 01-09-16 05:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 12:37 AM.


Copyright © 2000-2017 Internet Brands, Inc. All Rights Reserved We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: