issues installing coilovers. please help! - Club Lexus Forums

Log In 

issues installing coilovers. please help!

Reply
 
 
 
Thread Tools Search this Thread
Old 03-12-14, 09:14 AM   #1
blkcherry2
Driver School Candidate
Thread Starter
 
Join Date: Mar 2014
Location: colorado
Posts: 2
Default issues installing coilovers. please help!

So my function/form type 2 came in and I immediately installed them. Both rears went smoothly, the fronts did too upon disassembling the bolts, installed the coil over and when I went to reconnect the sway bar it wouldn't reach. I was told it would be fine to leave it disconnected. Now its been 2 days of driving and the car still has an uncontrollable bounce to the point where Im nervous to be driving it. I haven't messed with the spring prelude at all and some thing feels really wrong. Any help asap would be greatly appreciated!

Kevin
blkcherry2 is offline   Reply With Quote
Old 03-12-14, 09:41 AM   #2
Revive
Lead Lap
iTrader: (1)
 
Revive's Avatar
 
Join Date: Nov 2010
Location: Florida
Posts: 609
Default

Get both wheels off the ground and unbolt the bushing bracket...
Revive is online now   Reply With Quote
Old 03-12-14, 10:19 AM   #3
blkcherry2
Driver School Candidate
Thread Starter
 
Join Date: Mar 2014
Location: colorado
Posts: 2
Default

Quote:
Originally Posted by Revive View Post
Get both wheels off the ground and unbolt the bushing bracket...
The bracket that connects to the sway bar?
blkcherry2 is offline   Reply With Quote
Old 04-09-14, 07:12 AM   #4
perrychad1
Driver
 
Join Date: Oct 2013
Location: nc
Posts: 150
Default

no the endlinks
perrychad1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Battery Charging Problems... PLEASE HELP apdanger IS - 1st Gen (2001-2005) 4 07-30-16 09:08 AM
Help With Amp Bypass kennyel88 ES - 1st to 4th Gen (1990-2006) 0 09-16-14 01:29 PM
Air ride help!!!! baggedgs4 Suspension and Brakes 21 08-20-13 06:12 AM
My headlight went out in my 04' dag8882 SC430 - 2nd Gen (2001-2010) 3 03-22-11 03:24 PM
battery light is not going away need help lex786 GS - 2nd Gen (1998-2005) 5 01-17-10 12:06 PM


Tags
coilovers, installing, issues

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 01:58 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved