issues installing coilovers. please help! - Club Lexus Forums

Log In 

issues installing coilovers. please help!

Reply
 
 
 
Thread Tools Search this Thread
Old 03-12-14, 09:14 AM   #1
blkcherry2
Driver School Candidate
Thread Starter
 
Join Date: Mar 2014
Location: colorado
Posts: 2
Default issues installing coilovers. please help!

So my function/form type 2 came in and I immediately installed them. Both rears went smoothly, the fronts did too upon disassembling the bolts, installed the coil over and when I went to reconnect the sway bar it wouldn't reach. I was told it would be fine to leave it disconnected. Now its been 2 days of driving and the car still has an uncontrollable bounce to the point where Im nervous to be driving it. I haven't messed with the spring prelude at all and some thing feels really wrong. Any help asap would be greatly appreciated!

Kevin
blkcherry2 is offline   Reply With Quote
Old 03-12-14, 09:41 AM   #2
Revive
Lead Lap
iTrader: (1)
 
Revive's Avatar
 
Join Date: Nov 2010
Location: Michigan
Posts: 609
Default

Get both wheels off the ground and unbolt the bushing bracket...
Revive is offline   Reply With Quote
Old 03-12-14, 10:19 AM   #3
blkcherry2
Driver School Candidate
Thread Starter
 
Join Date: Mar 2014
Location: colorado
Posts: 2
Default

Quote:
Originally Posted by Revive View Post
Get both wheels off the ground and unbolt the bushing bracket...
The bracket that connects to the sway bar?
blkcherry2 is offline   Reply With Quote
Old 04-09-14, 07:12 AM   #4
perrychad1
Driver
 
Join Date: Oct 2013
Location: nc
Posts: 150
Default

no the endlinks
perrychad1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Swift Spring install, fronts only or all four? F1nALMSfan RC F (2015-present) 4 08-27-15 11:09 AM
Startup / Display off Images KBalgopal RX - 3rd Gen (2010-2015) 2 04-11-15 07:15 PM
01 RX 300 Air fuel sensor code p1135, p1155 2ks RX - 1st Gen (1999-2003) 72 12-23-14 08:08 AM
IS300 from Holland, with some issues GeenIdee Build Threads 2 11-17-14 02:32 AM
**Project "Black Pearl" 1 of 120 97 5speed** geauxsimon Build Threads 177 08-01-14 05:57 PM


Tags
coilovers, installing, issues

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 11:49 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved