Air ride question - Club Lexus Forums


Go Back   Club Lexus Forums > Lexus Model Forums > GS Models > GS - 2nd Gen (1998-2005) > Suspension and Brakes
Log In 

Air ride question

Reply
 
 
 
 
Thread Tools Search this Thread
Old 01-19-14, 03:12 PM   #1
baggedgs4
Driver School Candidate
Trader Score: (0)
 
Join Date: Apr 2012
Location: nj
Posts: 44
Default Air ride question

Ok I've searched and haven't found any info on this ok the problem I'm having is my compressor isn't shutting off it just keeps going and going until I unhook the wire connected to pressure switch on tank would that mean that switch is bad?
baggedgs4 is offline   Reply With Quote
Old 01-19-14, 04:58 PM   #2
seivonecsu
Lead Lap
Trader Score: (7)
 
Join Date: Sep 2011
Location: ny
Posts: 436
NYCAuto addicts
Default

Most likely the pressure switch went bad
seivonecsu is offline   Reply With Quote
Old 01-19-14, 06:06 PM   #3
baggedgs4
Driver School Candidate
Trader Score: (0)
 
Join Date: Apr 2012
Location: nj
Posts: 44
Default

Quote:
Originally Posted by seivonecsu View Post
Most likely the pressure switch went bad
Thanks man now I have peace of mind it was driving me nuts lol
baggedgs4 is offline   Reply With Quote
Old 01-19-14, 10:02 PM   #4
tdciv
Driver
Trader Score: (0)
 
tdciv's Avatar
 
Join Date: Jan 2014
Location: canada
Posts: 113
Default

pressure switch is bad they always go bad after time
tdciv is offline   Reply With Quote
Old 01-20-14, 01:35 PM   #5
baggedgs4
Driver School Candidate
Trader Score: (0)
 
Join Date: Apr 2012
Location: nj
Posts: 44
Default

Quote:
Originally Posted by tdciv View Post
pressure switch is bad they always go bad after time
Sucks it was the compressor now I installed a viair 480c compressor a shop called ams autowerks in linden nj guy there has experience he knew right away compressor was fried he had it brand new in stock he did recommend that I do two compressors instead of one
baggedgs4 is offline   Reply With Quote
Old 01-20-14, 02:04 PM   #6
tdciv
Driver
Trader Score: (0)
 
tdciv's Avatar
 
Join Date: Jan 2014
Location: canada
Posts: 113
Default

Quote:
Originally Posted by baggedgs4 View Post
Sucks it was the compressor now I installed a viair 480c compressor a shop called ams autowerks in linden nj guy there has experience he knew right away compressor was fried he had it brand new in stock he did recommend that I do two compressors instead of one
2 is always best lets the pump work less 2 480s on a 10 gallon tank at 200psi will only make the pumps run at 40% each
tdciv is offline   Reply With Quote
Old 01-20-14, 02:14 PM   #7
carbongs
Lexus Champion
Trader Score: (13)
 
carbongs's Avatar
 
Join Date: Sep 2005
Location: ga
Posts: 4,153
Default

Yes two is better than one. I run 2 - 3 gallon tank with 2 compressors. Glad you found out that it was the pressure switch. Check the tank for water too. It's good to drain them out every now and then even if you have water traps. That moisture can end up damaging the sensors.
__________________
CarbonGS
carbongs is offline   Reply With Quote
Old 01-20-14, 02:41 PM   #8
Sevenevez
Lexus Test Driver
Trader Score: (2)
 
Sevenevez's Avatar
 
Join Date: Dec 2012
Location: Arizona
Posts: 1,501
Default

i have gone through 3 pressure switches on my '50.
__________________

2000 GS400 - Build Thread
1950 Ford Shoebox - Build Thread
Sevenevez is offline   Reply With Quote
Old 02-27-14, 02:30 AM   #9
djlowlife
Driver School Candidate
Trader Score: (0)
 
djlowlife's Avatar
 
Join Date: Feb 2014
Location: indiana
Posts: 1
Default

what kind of pressure switches you are using???? when I had bags on my grand Cherokee I ended getting a square-D pressure switch no more pressure problems after that..but I also wired up an on and off switch for the compressors in case of a leak I could shut them off...
djlowlife is offline   Reply With Quote
Old 02-27-14, 02:30 AM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
can you bypass/jump power window switch? Starrk SC- 1st Gen (1992-2000) 5 09-18-14 04:24 PM
moonroof/sunroof switch bad? LS400BOY LS - 1st and 2nd Gen (1990-2000) 4 09-17-12 11:54 AM
Electrical issue?? ayooaaron SC- 1st Gen (1992-2000) 5 09-11-12 08:42 PM
power window problem BlaineyB SC- 1st Gen (1992-2000) 30 08-30-12 01:04 AM
Power windows (all except driver side) don't work lindong LX - 1st and 2nd Gen (1997-2007) 7 07-12-04 05:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 09:32 PM.

Copyright © 2000-2015 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info