sc300 feels squirmy at high speeds - Club Lexus Forums


sc300 feels squirmy at high speeds

Reply
 
 
 
Thread Tools Search this Thread
Old 04-11-12, 08:32 PM   #1
robsidewz
Driver School Candidate
Thread Starter
 
Join Date: Oct 2011
Location: ca
Posts: 19
Default sc300 feels squirmy at high speeds

my sc300 feels squirmy at high speeds idk what to do about this i am low and have traction bars and toe arms alignment is good 0'd out the toe in the rear and pulled out the camber as much as i could ... just finished my 1j swap in my car and wanted to do some high speed runs but whenever i get on the freeway and hit cracks in the road and hit any un-evan pavement or sometimes even going fast just in a straight line feels weird idk .....
robsidewz is offline   Reply With Quote
Old 04-13-12, 10:12 AM   #2
sj408
Lexus Test Driver
iTrader: (6)
 
Join Date: Apr 2009
Location: ca
Posts: 931
Default

It seems we are having similar issues and ive gone over EVERYTHING as well and am starting to think that my LCA bushings are shot. In fact im almost positive thats it.

Have you been able to inspect your lca bushings??? they are a pain to look at but im 90% sure thats my problem.
sj408 is offline   Reply With Quote
Old 04-13-12, 10:15 AM   #3
KingPhilip
Lexus Champion
iTrader: (10)
 
KingPhilip's Avatar
 
Join Date: Apr 2011
Location: CA
Posts: 3,076
Default

Change all bushings all around if you haven't done it. SC's will never feel right until you swap out all the bushings and mounts.
KingPhilip is offline   Reply With Quote
Old 04-13-12, 10:57 AM   #4
sj408
Lexus Test Driver
iTrader: (6)
 
Join Date: Apr 2009
Location: ca
Posts: 931
Default

Quote:
Originally Posted by KingPhilip View Post
Change all bushings all around if you haven't done it. SC's will never feel right until you swap out all the bushings and mounts.
so next time i need spark plugs i should do a head job??? or a rebuild???
sj408 is offline   Reply With Quote
Old 04-13-12, 11:15 AM   #5
AnonymousG
Pole Position
iTrader: (2)
 
Join Date: Jan 2011
Location: Bay Area, CA
Posts: 319
Default

My SC feels the same, but I think its how my front coilovers are preloaded, one side has more preload then the others.

haha its wierd how all of us who posted is from CA too.
AnonymousG is offline   Reply With Quote
Old 04-13-12, 11:21 AM   #6
sj408
Lexus Test Driver
iTrader: (6)
 
Join Date: Apr 2009
Location: ca
Posts: 931
Default

Quote:
Originally Posted by AnonymousG View Post
My SC feels the same, but I think its how my front coilovers are preloaded, one side has more preload then the others.

haha its wierd how all of us who posted is from CA too.
Well my sc felt great for 3-4 years and then just recently i started to notice it being all over the place at high speeds. I really think its either the lca bushings or the rack bushings. so i guess ill be replacing both.

I used to be able to do 120+ with no fear if my car was gonna steer itself into a wall.... on a track of course
sj408 is offline   Reply With Quote
Old 04-13-12, 11:52 AM   #7
KingPhilip
Lexus Champion
iTrader: (10)
 
KingPhilip's Avatar
 
Join Date: Apr 2011
Location: CA
Posts: 3,076
Default

Quote:
Originally Posted by sj408 View Post
so next time i need spark plugs i should do a head job??? or a rebuild???
Real funny, but I wasn't talking to you.
KingPhilip is offline   Reply With Quote
Old 04-13-12, 12:25 PM   #8
Tabaka
Lexus Champion
iTrader: (8)
 
Join Date: Mar 2010
Location: Dale City, VA
Posts: 3,810
Default

Quote:
Originally Posted by sj408 View Post
I used to be able to do 120+ with no fear if my car was gonna steer itself into a wall.... on a track of course
I've never driven faster than 70 in my car. Car feels all over the place and the steering wheel has a funny shake to it. I've had a few different set wheels balanced and the alignment done three or four times on both aftermarket and stock wheels and nothing changes. It feels a little bit better with 55 wall stock tires, but I believe the larger sized tire absorbs some of the road vibration. When I install my 35 wall / 19" wheels....forget it. I usually take back roads to avoid driving at highway speeds. I'm sure all of my bushings are shot and I need to replace my shocks.
Tabaka is offline   Reply With Quote
Old 04-13-12, 01:10 PM   #9
sj408
Lexus Test Driver
iTrader: (6)
 
Join Date: Apr 2009
Location: ca
Posts: 931
Default

Quote:
Originally Posted by KingPhilip View Post
Real funny, but I wasn't talking to you.
We got a private messaging system... check it out some time.


Quote:
Originally Posted by Tabaka View Post
I've never driven faster than 70 in my car. Car feels all over the place and the steering wheel has a funny shake to it. I've had a few different set wheels balanced and the alignment done three or four times on both aftermarket and stock wheels and nothing changes. It feels a little bit better with 55 wall stock tires, but I believe the larger sized tire absorbs some of the road vibration. When I install my 35 wall / 19" wheels....forget it. I usually take back roads to avoid driving at highway speeds. I'm sure all of my bushings are shot and I need to replace my shocks.

Yeah definetly sounds like more issue than your tires or alignment themself. Betcha if you inspect everything close youll find more than a few bushings tore up
sj408 is offline   Reply With Quote
Old 04-13-12, 04:18 PM   #10
TechGreek
Lexus Test Driver
iTrader: (4)
 
Join Date: Sep 2010
Location: DE
Posts: 875
Default

I dealt with the same issues for a while.

Low = Suspension Geometry Wrong

You shouldn't be adding pre-load, only zeroing it out.

There are all sort of things that are at the wrong angle (like Sway Bar End Links, Control Arm Ball Joint Angle, etc).
TechGreek is offline   Reply With Quote
Old 04-14-12, 12:02 AM   #11
Bflatsharp
Driver
iTrader: (18)
 
Join Date: May 2010
Location: MO
Posts: 179
Default

The KING is right . 92 212,000 +, ALL bushings replaced, stance suspension and 19 inch tires 110 mph 2&4 lane
roads. WOW.
Bflatsharp is offline   Reply With Quote
Old 04-14-12, 11:02 AM   #12
scoobySC3
Driver
iTrader: (1)
 
scoobySC3's Avatar
 
Join Date: Feb 2012
Location: Utah
Posts: 178
Default

When was the last time the car was aligned on a rack? Also what do you mean by "camber pulled out"?

Couple things to check would be all the suspension bushings, ball joints, steering rack bushings, tie rod ends, wheel bearings, rear subframe bushings.
Also I once had a slightly bent sub frame which was impossible to see, but the alignment never felt right even after multiple times to the alignment shop. I literally replaced everything I mentioned above, and as a last hope I bought a new subframe, after I confirmed all the control arms were straight, the subframe ended up having a slight crease in it, put on a new one and everything was as good as new


Hope this helps and let us know how it goes.
Thanks,
Rick
scoobySC3 is offline   Reply With Quote
Old 04-14-12, 11:30 AM   #13
KingPhilip
Lexus Champion
iTrader: (10)
 
KingPhilip's Avatar
 
Join Date: Apr 2011
Location: CA
Posts: 3,076
Default

Oh yeah, another thing, SC's feel slightly squirmy with a -3 camber with wide tires, although -3 camber is still within specs, I guess the wide tires is what's making a difference..
KingPhilip is offline   Reply With Quote
Old 04-25-12, 06:08 PM   #14
KahnBB6
Moderator
iTrader: (5)
 
Join Date: Jun 2010
Location: California
Posts: 3,268
Default

I'm having this same problem now myself. I recently had an alignment and I do have to drive over some poorly maintained roads almost every other day but I don't think that's my problem. LCA's haven't been replaced yet but I am considering it. Steering rack bushings were replaced with Daizens a year ago. My tires may be nearing the end of their life but they aren't ready to go yet. I have 245mm front and 275mm rear. Does that contribute to squirminess at 70mph? I'm going down to 235/255 soon.
KahnBB6 is offline   Reply With Quote
Old 04-27-13, 08:35 AM   #15
SOLID300
Pole Position
iTrader: (6)
 
Join Date: Apr 2010
Location: Florida
Posts: 225
Default

I have vibration at high speeds. At around 100+ miles an hour my dash begins to shake. Most of my front suspension is new except for a bad inner tie rod on the drivers side.

Im thinking I may need to upgrade to Supra Motor Mounts but mine was replaced only about a year ago.
SOLID300 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Steering is "squirmy" under heavy braking Sameer89 IS F (2008-2014) 23 04-07-16 03:09 PM
Review -- Bridgestone Turanza Serenity Plus e-man The Tire Rack's Tires, Wheels & Brakes Forum 6 06-12-15 01:59 PM
Suspension Blues MA70KinG GS - 1st Gen (1993-1997) 9 02-26-15 05:05 PM
Conti Extreme Contact DWS - Wandering GSteve350 GS - 3rd Gen (2006-2011) 27 07-07-11 06:06 PM
Suspension Problems!!!! catano787 GS - 1st Gen (1993-1997) 21 03-26-09 01:58 AM


Tags
alignment, car, coilovers, feels, freeway, high, higher, issues, jittering, sc300, send, side, sits, speeds, squirmy, subframe, toe, tracking

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 01:22 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved