Go Back   Club Lexus Forums > Search Forums
Sign in using an external account
Register Forgot Password?

Showing results 1 to 16 of 16
Search took 0.05 seconds.
Search: Posts Made By: lexxpro
Forum: LS400 08-15-14, 08:27 AM
Replies: 6
Views: 266
Posted By lexxpro
I'm not sure how he would fail you for the Air...

I'm not sure how he would fail you for the Air Injection visual. The air pump is located where the starter is and there is nothing you can really even see. I would demand a retest and explanation of...
Forum: LS400 04-17-14, 04:26 PM
Replies: 40
Views: 1,152
Posted By lexxpro
I would get the temp sensor fixed first which is...

I would get the temp sensor fixed first which is cheap if you can do it yourself. How often are you adding coolant? The brown color could be just from mixing red with green coolant. How does the oil...
Forum: LS400 01-04-14, 09:32 PM
Replies: 10
Views: 795
Posted By lexxpro
I would check all grounds and inspect the ecu for...

I would check all grounds and inspect the ecu for leaking caps and damage. Also clean the throttle body and test the throttle position sensor to make sure its in spec.
Forum: LS400 12-17-13, 09:03 AM
Replies: 36
Views: 1,987
Posted By lexxpro
Check the fan bracket. Sounds similar to a...

Check the fan bracket. Sounds similar to a problem i had with mine when the bearing started to go out. The fan started to wobble around.
Forum: LS400 07-24-13, 08:30 PM
Replies: 25
Views: 1,316
Posted By lexxpro
You are missing all the covers to prevent things...

You are missing all the covers to prevent things like this from happening. It looks like your right hand cam sensor is completly riped out of the housing and the left side cam sensor has a damaged...
Forum: LS400 06-07-13, 11:57 PM
Replies: 63
Views: 19,723
Posted By lexxpro
First you need a set of Toyota valve tools like...

First you need a set of Toyota valve tools like theses-...
Forum: LS400 06-04-13, 06:12 PM
Replies: 4
Views: 277
Posted By lexxpro
Its the left side cam sensor plug. It needs to be...

Its the left side cam sensor plug. It needs to be repaired and tucked away from the belt.
Forum: LS400 06-03-13, 06:04 PM
Replies: 63
Views: 19,723
Posted By lexxpro
90-94 ls400 is recommened every 75k i believe. I...

90-94 ls400 is recommened every 75k i believe. I waited to do mine around 140k when i did the valve cover gaskets. I got use to the ticking but after a few new shims it was alot quieter.
Forum: LS400 04-02-13, 08:49 PM
Replies: 23
Views: 980
Posted By lexxpro
My 93 had the same problem. You need one or both...

My 93 had the same problem. You need one or both front o2 sensors. And make sure to use oem Denso ones. I got mine for about $55 each on amazon
Forum: LS400 03-27-13, 11:09 PM
Replies: 12
Views: 453
Posted By lexxpro
Hello and welcome, I have a 93 ls400 as well....

Hello and welcome, I have a 93 ls400 as well. First you will want to diagnose why the cel is on.
This is a great guide to help with that- http://www.lexls.com/tutorials/intro/codereading.html

I...
Forum: LS400 03-22-13, 06:45 PM
Replies: 12
Views: 803
Posted By lexxpro
No it doesnt. You will want to pick one of those...

No it doesnt. You will want to pick one of those up. Part # 90311-A0001
Usually only about $5 from a toyota dealer
Forum: LS400 03-21-13, 09:08 PM
Replies: 12
Views: 803
Posted By lexxpro
I would go with the Aisin TKT-021 kit. ...

I would go with the Aisin TKT-021 kit.

http://www.partsgeek.com/ss/?i=1&ssq=Aisin+TKT-021&x=16&y=10
Forum: LS400 03-21-13, 06:39 PM
Replies: 12
Views: 520
Posted By lexxpro
Keep taping on all three studs of the tower and...

Keep taping on all three studs of the tower and eventually it will break free. Careful you dont mess up the threads or use a brass hammer it you have one
Forum: LS400 03-21-13, 06:31 PM
Replies: 73
Views: 6,411
Posted By lexxpro
Any update on the issue? Sounds very similar to...

Any update on the issue? Sounds very similar to the problem with my 93 ls400. From about 2000-3800rpm it feels like it lacking power and pinging but only sometimes which is strange. Its been doing...
Forum: LS400 03-21-13, 06:15 PM
Replies: 12
Views: 803
Posted By lexxpro
The Aisin TKT-030 kit from parts geek is what i...

The Aisin TKT-030 kit from parts geek is what i used and its all OEM parts. $206 with free shipping.
http://www.partsgeek.com/ss/?i=1&ssq=Aisin+TKT-030&x=14&y=12
Forum: LS400 03-21-13, 06:08 PM
Replies: 19
Views: 2,405
Posted By lexxpro
Had the same issue with my 93. Had to turn the...

Had the same issue with my 93. Had to turn the key about 10 times before it finally fired up. Just replaced mine a couple weeks ago and it starts up better then ever now.
Showing results 1 to 16 of 16

 
Forum Jump
All times are GMT -7. The time now is 05:31 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info