Go Back   Club Lexus Forums > Search Forums
Sign in using an external account
Register Forgot Password?

Showing results 1 to 7 of 7
Search took 0.07 seconds.
Search: Posts Made By: Techmotion
Forum: LS400 06-22-13, 03:07 PM
Replies: 5
Views: 463
Posted By Techmotion
Yes, could be the PB Blaster lubed the bearing on...

Yes, could be the PB Blaster lubed the bearing on the pintle side. Plenty of carbon came out after the PB Blaster soak. I just got finished today. I plan on testing the crap out of this car in...
Forum: LS400 06-22-13, 12:03 PM
Replies: 5
Views: 463
Posted By Techmotion
Low speed stall - hard to restart - my problem solved.

My 93 would stall at low speed, and had a hard time re-starting after the stall. First after having the ECU Capacitors replaced with recommend ones. (thanks LScowboyLS and others from that thread )....
Forum: LS400 12-01-12, 08:45 AM
Replies: 978
Views: 197,891
Posted By Techmotion
Look at posts 146,148,151 for my problems. ...

Look at posts 146,148,151 for my problems.

Update on my 93 LS. I got the caps shipped, and got into replacing them. I could tell after removing the two that had leaks that the circuit board was...
Forum: LS400 11-24-12, 09:29 AM
Replies: 978
Views: 197,891
Posted By Techmotion
I ordered enough caps from digi-key to do 3...

I ordered enough caps from digi-key to do 3 ecu's. The total was $33 (including $20 for 2nd day shipping). Glad to hear this job will make it run like new. I bet many people just give up and junk...
Forum: LS400 11-23-12, 02:13 PM
Replies: 978
Views: 197,891
Posted By Techmotion
I have the ECU removed and there are problems. At...

I have the ECU removed and there are problems. At least 2 caps (C103 + C105) leaked out and have apparent damage. I will order all the recommended caps from Digi-Key. Thanks for the info about low...
Forum: LS400 11-22-12, 08:44 AM
Replies: 978
Views: 197,891
Posted By Techmotion
Just some background as I have not driven my car...

Just some background as I have not driven my car for 6 months due to a drain on the battery after about 2 days of sitting. My 1993 LS400 with Traction has 182k plus miles. I paid $2000 and have had...
Forum: LS400 11-29-11, 05:16 PM
Replies: 6,443
Views: 1,447,013
Posted By Techmotion
1993 ls 400 186k

Greetings from Georgia
I was glad to see this forums after I bought this LS 400 last week for $2200. Last owner had starter and radiator replaced recently, said cost $1200 for both with parts and...
Showing results 1 to 7 of 7

 
Forum Jump
All times are GMT -7. The time now is 11:15 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info