Go Back   Club Lexus Forums > Search Forums
Sign in using an external account
Register Forgot Password?

Showing results 1 to 12 of 12
Search took 0.15 seconds.
Search: Posts Made By: cbo111
Forum: RX - Second Generation 11-18-09, 12:11 PM
Replies: 52
Views: 6,813
Posted By cbo111
Power functions

If Sears or someone other than the dealer replaces the battery, do they have the ability to reset some of those computer/electronic functions like the power windows etc? Last time the battery was...
Forum: RX - Second Generation 11-05-09, 05:18 PM
Replies: 14
Views: 2,979
Posted By cbo111
Will do. I think I may try replacing the DRL...

Will do. I think I may try replacing the DRL relay. Should't cost more than $40 I hope.
Forum: RX - Second Generation 11-04-09, 07:14 AM
Replies: 14
Views: 2,979
Posted By cbo111
Thanks for all your help anyway. Looks like it...

Thanks for all your help anyway. Looks like it may be time for a trip to the dreaded dealership.
Forum: RX - Second Generation 11-03-09, 06:33 PM
Replies: 14
Views: 2,979
Posted By cbo111
The fog lights are on, then turn off when high...

The fog lights are on, then turn off when high beam selected. So....maybe not the switch? I continue to scratch my head:confused:
Forum: RX - Second Generation 11-02-09, 06:30 PM
Replies: 14
Views: 2,979
Posted By cbo111
the plot thickens

I just checked the fuses with the high beam switch on:
DRL is hot, shows 11.5 volts, but left and right high beams are cold.
Still no high beams or DRL's:confused:
Forum: RX - Second Generation 11-01-09, 06:44 PM
Replies: 14
Views: 2,979
Posted By cbo111
I don't think the DRL's are working either. With...

I don't think the DRL's are working either. With the light switch off, I start the engine with the brake off, and no lights. I believe the DRL's are supposed to be on regardless of the switch...
Forum: RX - Second Generation 11-01-09, 03:56 PM
Replies: 14
Views: 2,979
Posted By cbo111
Any more tips?

Well I checked the fuses on my 04 RX, they were clean and looked fine. Still no high beams. The high beam bulbs look ok, just a little smokey haze on one side, but filaments look good. I replace one...
Forum: RX - Second Generation 10-28-09, 06:42 PM
Replies: 14
Views: 2,979
Posted By cbo111
I will check fuse asap. Thanks for the help.

I will check fuse asap. Thanks for the help.
Forum: RX - Second Generation 10-27-09, 07:58 PM
Replies: 14
Views: 2,979
Posted By cbo111
RX330 high beam lights inop

My high beams suddenly don't work. Probably not the bulbs since it happened at the same time. I looked at recent threads that said a fuse might be the problem. Anybody else have this happen?
thanks,...
Forum: RX - Second Generation 10-27-09, 07:55 PM
Replies: 7
Views: 7,555
Posted By cbo111
do it yourself

I just did both sets of pads on my 04 RX330. The vehicle has 69500 miles and this was the first pad change. The rotors were in excellent shape. The pads had over 50% left but I changed them anyway...
Forum: RX - Second Generation 09-07-09, 08:04 AM
Replies: 2
Views: 330
Posted By cbo111
2004 RX Transmission Filter??

Can anyone verify if the 2004 RX 330 FWD has a replaceable filter in the transmission?
Forum: RX - Second Generation 08-14-09, 11:56 AM
Replies: 192
Views: 106,054
Posted By cbo111
brake kits?

Mandyfig, great write-up. Did you buy the brake fit kit and shim kit from Sewell? This is my first pad replacement at 56k miles. I am getting ready to order from Sewell and saw them listed as...
Showing results 1 to 12 of 12

 
Forum Jump
All times are GMT -7. The time now is 01:20 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info