Club Lexus Forums - Search Results

Log In 

Showing results 1 to 25 of 371
Search took 0.55 seconds.
Search: Posts Made By: shikbas
Forum: RX - 2nd Gen (2004-2009) 06-30-16, 03:03 AM
Replies: 3
Views: 240
Posted By shikbas
Sometimes if the battery is going bad can cause...

Sometimes if the battery is going bad can cause these issues
Forum: RX - 2nd Gen (2004-2009) 03-29-16, 09:20 AM
Replies: 9
Views: 476
Posted By shikbas
Thank you all,I did many replacements before,I...

Thank you all,I did many replacements before,I will try the filter in the cover trick,,,,thanks again
Forum: RX - 2nd Gen (2004-2009) 03-29-16, 07:15 AM
Replies: 9
Views: 476
Posted By shikbas
Smile Engine air filter

Hello,I got a new fram engine air filter as recommended by the book,tried to install and the cover will not close properly,do you have any information please,,,,thanks
Forum: RX - 2nd Gen (2004-2009) 03-20-16, 02:23 PM
Replies: 0
Views: 205
Posted By shikbas
Power seat not working

Hi all
I notised that my passanger power seat moves back and front reclines but not moving up or down and cannot hear any motor whining
Thank you for your help
Forum: RX - 2nd Gen (2004-2009) 12-21-15, 09:42 AM
Replies: 15
Views: 2,694
Posted By shikbas
Excellent info what about diesel? is it the...

Excellent info
what about diesel? is it the same ?
Forum: RX - 2nd Gen (2004-2009) 12-10-15, 04:37 AM
Replies: 148
Views: 24,291
Posted By shikbas
Hi guys So my dealer replaced the dash on my...

Hi guys
So my dealer replaced the dash on my rx330,they scratched badly the little screen on the front of the dash under the windshield,,,,do you know a way to fix it like paint thanks
Forum: RX - 2nd Gen (2004-2009) 11-16-15, 05:02 PM
Replies: 4
Views: 768
Posted By shikbas
I tried that and had to replace those bigger...

I tried that and had to replace those bigger tires after onlr a few monthes gas milage was very bad rubbing on full steering
Forum: RX - 2nd Gen (2004-2009) 08-25-15, 06:31 AM
Replies: 4
Views: 437
Posted By shikbas
The opening to check through is the sensor...

The opening to check through is the sensor opening itself
Forum: RX - 2nd Gen (2004-2009) 08-24-15, 09:10 AM
Replies: 4
Views: 437
Posted By shikbas
If you can do thist,pull every wheel out ,use a...

If you can do thist,pull every wheel out ,use a flashlight to check behind each rotor for the opening of the ABS tone ring while rotating the wheel hub,if you see a broken one that is the problem,do...
Forum: RX - 2nd Gen (2004-2009) 08-10-15, 06:52 AM
Replies: 0
Views: 489
Posted By shikbas
Air suspension

Hello
I have a 2004 RX 330 with air suspension,lately I noticed that the car is not going all the way down as use to be before with the climbing mode activated,that is the mode which suppose to...
Forum: RX - 2nd Gen (2004-2009) 06-26-15, 06:12 AM
Replies: 203
Views: 150,930
Posted By shikbas
I just use an old brake pad and a c clamp to push...

I just use an old brake pad and a c clamp to push the piston,,,,no problems
Forum: RX - 2nd Gen (2004-2009) 06-23-15, 02:42 PM
Replies: 203
Views: 150,930
Posted By shikbas
Do not worry If you are there already replace...

Do not worry
If you are there already replace all the rubber bushing put new grease for the pins with the little ring bushings first clean its housing on the caliper push the bushings first with the...
Forum: RX - 2nd Gen (2004-2009) 04-30-15, 07:26 AM
Replies: 1
Views: 523
Posted By shikbas
RX 330 air suspension

Hello
I have 04 rx330 with air suspension,I noticed lately that the car will not come all the way down as before when activating the the seating support button,,,,,,is there any reset that can be...
Forum: RX - 2nd Gen (2004-2009) 04-11-15, 01:29 PM
Replies: 7
Views: 749
Posted By shikbas
Thank you guys After reading all the...

Thank you guys
After reading all the information I started wigh the front wheel took the abs sensor out checked the tone ring and wala it was broken completely got a new cv axle and was installed...
Forum: RX - 2nd Gen (2004-2009) 03-22-15, 05:46 AM
Replies: 7
Views: 749
Posted By shikbas
Thank you all. A friend mentioned the possibility...

Thank you all. A friend mentioned the possibility of deffective ABS sensors. What do you think?
Thanks in advance
Forum: RX - 2nd Gen (2004-2009) 03-21-15, 05:31 PM
Replies: 7
Views: 749
Posted By shikbas
Thank you I just replaced the rotors today and...

Thank you
I just replaced the rotors today and it started to happen at the pad bedding procedure so that it was few hundreds feet
Forum: RX - 2nd Gen (2004-2009) 03-21-15, 01:56 PM
Replies: 7
Views: 749
Posted By shikbas
Brake issue

Hi very helpful guys
I have 04 rx330 with 70 k miles. Lately I started to feel grinding sensation and pulsation on applying the brakes initially it is fine then it will be felt specially when the...
Forum: RX - 2nd Gen (2004-2009) 02-18-14, 12:04 PM
Replies: 2
Views: 643
Posted By shikbas
Inside car heater

Hello
I have 2004 rx 330. The inside heater is not sustained with the temperature. Sometimes it is ver warm sometimes it will be cold. Will be cold on idling then heats up on moving then it may go...
Forum: RX - 2nd Gen (2004-2009) 12-16-13, 07:36 AM
Replies: 3
Views: 579
Posted By shikbas
Yes sir go ahead with the flushing part when...

Yes sir go ahead with the flushing part when possible,I did add a few cc s of a different coolant to my car sometime ago and now I got the overflow hose clogged twice after long drive ,looked at some...
Forum: RX - 2nd Gen (2004-2009) 11-29-13, 06:13 AM
Replies: 5
Views: 40,164
Posted By shikbas
Did you check the new brakes on the rear? It...

Did you check the new brakes on the rear? It happened to me before that the hardware was loose/bad.
Forum: RX - 2nd Gen (2004-2009) 09-25-13, 10:29 AM
Replies: 3
Views: 834
Posted By shikbas
I had bigger tires on mine,advise not to go that...

I had bigger tires on mine,advise not to go that route
Forum: RX - 2nd Gen (2004-2009) 08-02-13, 05:42 AM
Replies: 2
Views: 548
Posted By shikbas
Missing rear wiper part

This cover fell off,do you know where can I find one please


thanks
Forum: RX - 2nd Gen (2004-2009) 06-17-13, 05:38 AM
Replies: 3
Views: 443
Posted By shikbas
Fair enouph,I removed the pipe at the buttom of...

Fair enouph,I removed the pipe at the buttom of the overflow tank and found a plug of some pasty material cleaned it out with a wire ,flushed the tank and cleaned the pipe itself,every thing checked...
Forum: RX - 2nd Gen (2004-2009) 06-16-13, 06:11 PM
Replies: 3
Views: 443
Posted By shikbas
Problem solved

Problem solved
Forum: RX - 2nd Gen (2004-2009) 06-16-13, 08:28 AM
Replies: 3
Views: 443
Posted By shikbas
Radiator not venting to reservoir

Hello after a long trip i was checking the fluids of rx 330 I notised that the white plastic container for the coolant is low on coolant then i did a mouth pressure test at the radiator of courese...
Showing results 1 to 25 of 371

 
Forum Jump

All times are GMT -7. The time now is 12:55 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved