Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 430
Sign in using an external account
Register Forgot Password?


Steering controls for radio and nav stopped working but not phone -- any ideas?

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 04-12-10, 09:34 AM   #1
JohnnyCake
Lexus Test Driver
Trader Score: (0)
 
JohnnyCake's Avatar
 
Join Date: Feb 2007
Location: DC
Posts: 1,055
Default Steering controls for radio and nav stopped working but not phone -- any ideas?

Suddenly, the steering wheel controls for the radio/cd/etc stopped working -- no MODE change nor UP/DOWN volume. Likewise the control on the back of the wheel to summon the NAV voice control does not work. However, the phone control on the back of the steering wheel DOES work.

Does this suggest anything (other than a trip to the dealer)?
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
__________________
2006 Lexus SC430 - Smoky Mica Granite with Black interior. MODS: DISABLED Nav data entry lockout when in motion; DISABLED phone entry lockout when in motion; DISABLED "I agree" screen; DISABLEDSeat belt chime ADDED: Remote Functions via Cell Phone; LuxLink; NavTool Backup Cam; Sirius XM Radio; Vais iPod adapter; Blitz cabin filter.
JohnnyCake is offline   Reply With Quote
Old 04-12-10, 04:57 PM   #2
Gfather
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2009
Location: CA
Posts: 8
Default Audio Controls

Sounds like your "Spiral Cable" is defective. I had the same issues which were resolved once replaced by the dealer. The problem, accordig to the dealer was an open circuit.











2006 Lexus SC430 - Smoky Mica Granite with saddle interior..
Gfather is offline   Reply With Quote
Old 04-12-10, 05:45 PM   #3
JohnnyCake
Lexus Test Driver
Trader Score: (0)
 
JohnnyCake's Avatar
 
Join Date: Feb 2007
Location: DC
Posts: 1,055
Default

If you don't mind me asking, how much did that repair cost?
__________________
2006 Lexus SC430 - Smoky Mica Granite with Black interior. MODS: DISABLED Nav data entry lockout when in motion; DISABLED phone entry lockout when in motion; DISABLED "I agree" screen; DISABLEDSeat belt chime ADDED: Remote Functions via Cell Phone; LuxLink; NavTool Backup Cam; Sirius XM Radio; Vais iPod adapter; Blitz cabin filter.
JohnnyCake is offline   Reply With Quote
Old 05-17-10, 10:02 PM   #4
Leisurelar
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2004
Location: Fort Saskatchewan Canada
Posts: 16
Default

I would be interested to know the outcome as I have the same problem. Maybe it is the color.
I have a 2006 Smoky Granite Mica with Black interior. lol
Leisurelar is offline   Reply With Quote
Old 05-18-10, 06:06 PM   #5
JohnnyCake
Lexus Test Driver
Trader Score: (0)
 
JohnnyCake's Avatar
 
Join Date: Feb 2007
Location: DC
Posts: 1,055
Default

Quote:
Originally Posted by Leisurelar View Post
I would be interested to know the outcome as I have the same problem. Maybe it is the color.
I have a 2006 Smoky Granite Mica with Black interior. lol
If you get yours fixed, PLEASE post the diagnosis.
__________________
2006 Lexus SC430 - Smoky Mica Granite with Black interior. MODS: DISABLED Nav data entry lockout when in motion; DISABLED phone entry lockout when in motion; DISABLED "I agree" screen; DISABLEDSeat belt chime ADDED: Remote Functions via Cell Phone; LuxLink; NavTool Backup Cam; Sirius XM Radio; Vais iPod adapter; Blitz cabin filter.
JohnnyCake is offline   Reply With Quote
Old 05-19-10, 09:39 AM   #6
Leisurelar
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2004
Location: Fort Saskatchewan Canada
Posts: 16
Default

I think it is the spiral cable as I can turn the wheel to different spots and it will work. If or when I get it fixed I will post results, unfortunately it will not be warranty, Jan was my time limit, of course.
Leisurelar is offline   Reply With Quote
Old 05-26-10, 08:08 AM   #7
Habious
Moderator
Trader Score: (0)
 
Habious's Avatar
 
Join Date: Jan 2007
Location: VA
Posts: 2,698
Default

Quote:
Originally Posted by Gfather View Post
Sounds like your "Spiral Cable" is defective. I had the same issues which were resolved once replaced by the dealer. The problem, accordig to the dealer was an open circuit.

Super-big kudos to Gfather who nailed this problem right out of the gate!

Also wanted to make sure this thread got updated so, in the future, when someone comes across the same problem, the solution will be right there with it.

Turns out it WAS the spiral cable all along...and JohnnyCake is no longer crying himself to sleep...or wandering around the Mercedes dealership, looking longingly at the convertibles parked there.
__________________
2003 Lexus SC430 - Black with Ecru interior. VaisTech & NavTool interfaces with Centrafuse CarPC integrated into factory navigation screen (includes hands-free Bluetooth, Voice Command, mp3 support, videos, HD Radio, Sirius Satellite radio, DVD playback, Internet access, and digital gauge cluster (via OBD-II))...LuxLink remote top/start module, and GlobalTop HUD unit.
My CarPC YouTube Video - - - - - - - - - - - - - NY Times Article
Habious is offline   Reply With Quote
Old 05-26-10, 08:18 AM   #8
JohnnyCake
Lexus Test Driver
Trader Score: (0)
 
JohnnyCake's Avatar
 
Join Date: Feb 2007
Location: DC
Posts: 1,055
Default

I definitely agree that updating threads is important. Related thread is at:
Don't let the dealer tell you that LuxLink caused this problem.
__________________
2006 Lexus SC430 - Smoky Mica Granite with Black interior. MODS: DISABLED Nav data entry lockout when in motion; DISABLED phone entry lockout when in motion; DISABLED "I agree" screen; DISABLEDSeat belt chime ADDED: Remote Functions via Cell Phone; LuxLink; NavTool Backup Cam; Sirius XM Radio; Vais iPod adapter; Blitz cabin filter.
JohnnyCake is offline   Reply With Quote
Old 12-27-10, 12:54 PM   #9
nwcn98
Rookie
Trader Score: (0)
 
Join Date: Dec 2010
Location: WA
Posts: 78
Default

I'm late to the game, but my car is an 06 in the same colors...and the same issue
nwcn98 is offline   Reply With Quote
Old 12-27-10, 04:31 PM   #10
scdroptop
Moderator
Trader Score: (1)
 
scdroptop's Avatar
 
Join Date: Jul 2006
Location: Tx
Posts: 2,683
Default

Look further down on the threads...we just talked about this yesterday or day before....I just had mine replaced under warranty at Sewell $480 or so. Sorry to hear...not a big deal...hopefully you have warranty.
__________________
2005 Pebble Beach Edition Named "Ebony" Only 600 Made Black Diamond Pearl Pimento Red Interior Espresso Birdseye Maple Wood Smoked Pebble Beach Headlights Pebble Beach Badges on Fenders, Console and PB Embossed Mats, Pebble Beach Red Engine Cover and Cargo Cover Pull Mods: Injen Short Ram Intake ADR 20" Staggered Wheels w/Yokos Tasteful Drop w/ Megan Street LP Coilovers SL2-UP Vais iPod, DRL LED Upgrade Lexus Aluminum Pedals, 06+ LED Tails, 9.1 Nav, Welcome Screen Bypass Zaino Luxlink 2.0 39k
scdroptop is offline   Reply With Quote
Old 04-21-12, 01:44 PM   #11
Leisurelar
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2004
Location: Fort Saskatchewan Canada
Posts: 16
Default

Took a while but I just replaced my spiral cable sub assembly updated part # 8430651030 for a 2006 SC 430.
Part came frome Sewell price was 207.27 took about 40 min to replace and solved the problem.
Leisurelar is offline   Reply With Quote
Old 04-21-12, 03:52 PM   #12
Harold57
Lexus Test Driver
Trader Score: (0)
 
Join Date: Aug 2006
Location: Texas
Posts: 1,489
Default

Quote:
Originally Posted by Leisurelar View Post
Took a while but I just replaced my spiral cable sub assembly updated part # 8430651030 for a 2006 SC 430.
Part came frome Sewell price was 207.27 took about 40 min to replace and solved the problem.
Did you do it yourself or have it done?
Harold57 is offline   Reply With Quote
Old 04-22-12, 08:46 PM   #13
Leisurelar
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2004
Location: Fort Saskatchewan Canada
Posts: 16
Default

I did it myself quite straight forward. Remove neg bat cable for air bag, I did not do this and had no issues, remove small round plug on right side back of steering wheel, push pin lock in on radio control buttons left side of wheel and lift off cover, remove 2 small phillips screws from radio controls let hang down, remove the #30 torx screws from either side of wheel, screws must come out completely, lift off and unplug air bag, Loosen steering wheel with a 19mm socket do not take nut right off yet, make sure wheel is centered and use your knees under the wheel and hands on top to work the wheel off of the splines, when wheel is loose remove the nut the rest of the way. Unplug remaining wires and remove wheel, take three phillips screws out of the bottom steering column cover and move down out of the way, undo the rest of the plugs, remove xtra plug box from spiral cable,(just snaps in) remove 2 small springs from old cable these are the horn return springs, plug in and reinstall new spiral cable and break off orange indexing tab. Reassemble in reverse.
Leisurelar is offline   Reply With Quote
Old 04-22-12, 08:46 PM
 
 
 
 
Reply

Tags
430, cable, controls, fault, lecus, lexus, navigation, sc, sc430, screen, spiral, steering, stopped, wheel, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 03:49 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info