Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 400/300
Sign in using an external account
Register Forgot Password?

Odometer not working

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 08-26-13, 07:07 AM   #1
crenfro
Driver
Trader Score: (0)
 
crenfro's Avatar
 
Join Date: Oct 2012
Location: Indiana
Posts: 110
Default Odometer not working

I bought my 92 400 with 146k miles on it and have had it for about a year now. I've knowingly put on about 2k miles and just recently the odometer went out. It's completely blank, no numbers or anything.

Is this a bulb problem? I don't know if it is because all the bulbs are working in my cluster besides my needles. Is is possibly a fuse? What else could it be?
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
crenfro is offline   Reply With Quote
Old 08-26-13, 07:37 AM   #2
SC400slide
Lexus Champion
Trader Score: (5)
 
SC400slide's Avatar
 
Join Date: Apr 2012
Location: In Recovery mode
Posts: 2,924
Jonathan Hoppman SC400slide Jonathan Hoppman Jonny Hoppman
Send a message via Skype™ to SC400slide
Default

Does the speedometer still work? If so, it's your VSS.
__________________
1992 Lexus SC400,1995 Lexus SC400, 1996 Ford Explorer, 1971 Oldsmobile Cutlass SOLD, 1992 Ford Explorer SOLD
Lebo Boh tak miloval svet...
Apple Device Intellegentsia
TLN# 49 "Burnt Brownie"
SC400slide is offline   Reply With Quote
Old 08-26-13, 07:54 AM   #3
crenfro
Driver
Trader Score: (0)
 
crenfro's Avatar
 
Join Date: Oct 2012
Location: Indiana
Posts: 110
Default

Quote:
Originally Posted by SC400slide View Post
Does the speedometer still work? If so, it's your VSS.
Yes. Everything in my dash works. And sorry but what is a VSS?
crenfro is offline   Reply With Quote
Old 08-26-13, 08:02 AM   #4
SC400slide
Lexus Champion
Trader Score: (5)
 
SC400slide's Avatar
 
Join Date: Apr 2012
Location: In Recovery mode
Posts: 2,924
Jonathan Hoppman SC400slide Jonathan Hoppman Jonny Hoppman
Send a message via Skype™ to SC400slide
Default

Quote:
Originally Posted by crenfro View Post
Yes. Everything in my dash works. And sorry but what is a VSS?
Vehicle Speed sensor. I'd first poke around the obvious smaller things, like fuses. Though, the SC needles go out so often.
I'm sure that if the VSS was out, the speedo wouldn't work, and niether would the odometer. It would read "0".
__________________
1992 Lexus SC400,1995 Lexus SC400, 1996 Ford Explorer, 1971 Oldsmobile Cutlass SOLD, 1992 Ford Explorer SOLD
Lebo Boh tak miloval svet...
Apple Device Intellegentsia
TLN# 49 "Burnt Brownie"
SC400slide is offline   Reply With Quote
Old 08-26-13, 09:44 AM   #5
1JZPWRD
1JZ Single SC400
Trader Score: (58)
 
1JZPWRD's Avatar
 
Join Date: Jan 2009
Location: Alabama, Roll Tide!
Posts: 8,461
Default

Quote:
Originally Posted by SC400slide View Post
Vehicle Speed sensor. I'd first poke around the obvious smaller things, like fuses. Though, the SC needles go out so often.
I'm sure that if the VSS was out, the speedo wouldn't work, and niether would the odometer. It would read "0".
I agree with that being the problem. If it isn't, I say it's the cluster itself.
__________________
1992 SC400, Sleeper..522RWHP - 93 octane, 1JZ, BW S366, Soarer R154, ACT Stage 4, 800cc, DM LW Flywheel, MINZ FPR, 3" Exhaust, HKS CF Slip on, HKS BOV, Tial 44 WG, BC 264 Cams, AEM gauges, AEM V2, MKIV Auto LSD!
Follow my build thread.....http://www.clublexus.com/forums/buil...and-links.html
Jay's Interior....http://www.clublexus.com/forums/sc-4...y-1jzpwrd.html
1JZPWRD is offline   Reply With Quote
Old 08-26-13, 10:10 AM   #6
crenfro
Driver
Trader Score: (0)
 
crenfro's Avatar
 
Join Date: Oct 2012
Location: Indiana
Posts: 110
Default

Quote:
Originally Posted by SC400slide View Post
Vehicle Speed sensor. I'd first poke around the obvious smaller things, like fuses. Though, the SC needles go out so often.
I'm sure that if the VSS was out, the speedo wouldn't work, and niether would the odometer. It would read "0".
Ok yeah that's weird then because it doesn't read 0 it's just completely black and not lit up at all. I'll check fuses later after school and see if that's a problem. Could it be as simple as a bulb? Does the odo have its own?
crenfro is offline   Reply With Quote
Old 08-26-13, 04:30 PM   #7
O. L. T.
Keeper of the light
Trader Score: (15)
 
O. L. T.'s Avatar
 
Join Date: Feb 2003
Location: 1997
Posts: 33,519
Default

Sorry, you need another ODO assembly. Once the gas and heat grid burns out it's done. I have a spare in the attic.
__________________
Mercedes C Class | 19" Staggered Zenetti's | HID's
OESpectrum Suspension | K&N filters | 2" drop

O. L. T. is offline   Reply With Quote
Old 08-26-13, 05:24 PM   #8
1JZPWRD
1JZ Single SC400
Trader Score: (58)
 
1JZPWRD's Avatar
 
Join Date: Jan 2009
Location: Alabama, Roll Tide!
Posts: 8,461
Default

If thats the case, I just through one away. Pretty easy to replace just be careful with the ribbon.
1JZPWRD is offline   Reply With Quote
Old 08-26-13, 06:17 PM   #9
O. L. T.
Keeper of the light
Trader Score: (15)
 
O. L. T.'s Avatar
 
Join Date: Feb 2003
Location: 1997
Posts: 33,519
Default

ODO doesn't work, but the search button does http://www.clublexus.com/forums/sc-4...tml#post668356


__________________
Mercedes C Class | 19" Staggered Zenetti's | HID's
OESpectrum Suspension | K&N filters | 2" drop

O. L. T. is offline   Reply With Quote
Old 08-26-13, 06:17 PM
 
 
 
 
Reply

Tags
1997, 400, blank, lexus, ls, odometer, sc400, screen, sensor, speed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
odometer/speedometer accuracy bnewcol RX - Second Generation 25 03-22-14 09:41 AM
Odometer display is blank Brando ES300 and ES330 0 09-02-13 03:39 PM
2006 odometer in 2004 dashboard!! would it work? Turboo SC 430 15 02-16-13 11:35 PM
MD WTB: LS400 UCF10 Analog Odometer duballstar LS460 / 430 / 400 / 600h Classifieds 0 01-19-13 09:59 AM
change odometer? imDementeD SC 400/300 23 12-02-12 11:14 AM

All times are GMT -7. The time now is 11:37 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info