Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 400/300
Sign in using an external account
Register Forgot Password?

What did you do to your SC today?

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 05-20-11, 01:30 PM   #811
kikcaffine
Lead Lap
Trader Score: (3)
 
Join Date: Sep 2010
Location: Ga
Posts: 525
Send a message via AIM to kikcaffine
Default

drove it!!
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
kikcaffine is offline   Reply With Quote
Old 05-20-11, 03:39 PM   #812
jadu
OLLO
Trader Score: (39)
 
jadu's Avatar
 
Join Date: Oct 2008
Location: CALI
Posts: 10,122
jadu jadu jadu
Send a message via ICQ to jadu
Default

hopefully have time this weekend to change tranny fluid
__________________


RIP Jaynelle imu
jadu is offline   Reply With Quote
Old 05-20-11, 04:14 PM   #813
Kira X
美少女戦士セーラームーン
Trader Score: (18)
 
Kira X's Avatar
 
Join Date: Oct 2008
Location: 東京都
Posts: 7,514
Dark Cloud XS Death_Anghell
Default

I polished my headlights earlier today.
__________________
93 Lexus SC300
02 Lexus LS430
05 Lexus LS430 UL
95 Toyota Supra

さくら
7

Kira X is offline   Reply With Quote
Old 05-20-11, 04:30 PM   #814
sayayin
Pole Position
Trader Score: (2)
 
sayayin's Avatar
 
Join Date: May 2010
Location: fl
Posts: 286
Default

I was doing yesterday still need to do the passenger side, I use SEM paint.
color coat. gloss black 15233 and portola red 15363.
Attached Images
 
sayayin is offline   Reply With Quote
Old 05-20-11, 04:51 PM   #815
NjLexSc400
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2011
Location: NJ
Posts: 43
Default

blew the power steering pump wondering what else i could replace when i do the job
NjLexSc400 is offline   Reply With Quote
Old 05-20-11, 05:02 PM   #816
Tret
Pole Position
Trader Score: (1)
 
Tret's Avatar
 
Join Date: May 2010
Location: California
Posts: 327
https://www.facebook.com/GregoryAdman Mikkel_Dot_JPEG
Send a message via AIM to Tret
Default

So far, I've washed it and compound polished that dumpy booty with some wax. now to wait for the California sun to go down so this stuff stop insta-drying lol

Click the image to open in full size.
__________________
To be Continued...
Tret is offline   Reply With Quote
Old 05-20-11, 07:09 PM   #817
redforeva
Rookie
Trader Score: (2)
 
redforeva's Avatar
 
Join Date: Jan 2011
Location: California
Posts: 66
Default

gave it a nice wash, added some oil since the 2.5 quarts or less warning light popped up, should do an oil change next week
__________________
redforeva is offline   Reply With Quote
Old 05-20-11, 07:45 PM   #818
poorsupra
Pole Position
Trader Score: (10)
 
Join Date: Oct 2010
Location: So Cal
Posts: 322
Default

DIY clear running lights, pulled my projectors apart and cleaned the moisture out. painted my chrome trim and badges black. more to come tomorrow, ive had my sc400 3 days and im already making it my own!
poorsupra is offline   Reply With Quote
Old 05-20-11, 08:22 PM   #819
Abelo
Driver
Trader Score: (0)
 
Abelo's Avatar
 
Join Date: Mar 2011
Location: Canada, Alberta, Calgary
Posts: 158
Default

put my turbo back on the car, took me a hour to bolt everything down, towed it to the exhaust shop, to find out my v-band flange is the wrong size so i told them to just weld it together cause i had enough of looking for parts. drove it home to find out it wasnt making any boost,

mess around with hoses and clamps for 3 hours trying to solve the problem, go for another test drive. it hits boost!!!! only to have my fun stopped by the sound of my compressor wheel scraping against my compressor housing. nothing was damaged thankfully because ive already rebuilt this turbo twice and im not about to strike out on my third attempt.

so to do list for tommorow, reatach compressor housing (shop did a ****ty *** job) properly bolt down my exhaust manifold, clock the turbo so my oil drain line doesnt catch on fire then should be good to go i hope
Click the image to open in full size.
Attached Images
 
Abelo is offline   Reply With Quote
Old 05-20-11, 10:06 PM   #820
booja
Lead Lap
Trader Score: (1)
 
booja's Avatar
 
Join Date: Jun 2006
Location: texas
Posts: 677
Default

started it for the first time in 2 weeks. cleaned some bird poop off of it... thats about it
booja is offline   Reply With Quote
Old 05-20-11, 10:16 PM   #821
status
Rookie
Trader Score: (0)
 
Join Date: Apr 2011
Location: bc
Posts: 62
Default

got some borla mufflers 0o
status is offline   Reply With Quote
Old 05-21-11, 08:19 AM   #822
JoshRReese
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2011
Posts: 10
Default

Finished Tokico HPs, tanabe springs, and rays.
Click the image to open in full size.
Ignore the dead grass and profusion of crab grass. It has rained once in Houston in the past 2 months. I was hoping the drought would kill the crab grass. No such luck.
JoshRReese is offline   Reply With Quote
Old 05-21-11, 08:35 AM   #823
trancuongv
Lead Lap
Trader Score: (3)
 
trancuongv's Avatar
 
Join Date: Aug 2005
Location: Texas
Posts: 713
Send a message via AIM to trancuongv Send a message via Yahoo to trancuongv
Default

changed my radiator to a mishimoto radiator, modified my gte water neck to finally install my intake pipe on.
trancuongv is offline   Reply With Quote
Old 05-21-11, 11:07 AM   #824
RED95sc
Pole Position
Trader Score: (1)
 
RED95sc's Avatar
 
Join Date: Jan 2010
Location: md
Posts: 385
Default

i installed a new alpine head unit. not as bad as people made me think it would be, then i changed the oil, trans fluid, and a wash her
__________________

Clublexus SC with the least amount of mods..1jz swap, LS400 BBK
98 maxima supercharged....gone
99 SC300 TT wheels and brakes.
http://www.clublexus.com/forums/sc-4...d-threads.html
RED95sc is offline   Reply With Quote
Old 05-21-11, 12:55 PM   #825
Taste
Driver
Trader Score: (0)
 
Join Date: Apr 2011
Location: Las Vegas
Posts: 101
joa_taste
Default

Click the image to open in full size.

took off my ugly worn automatic shiftknob....looks a little better to me

Last edited by Taste; 05-22-11 at 01:10 PM..
Taste is offline   Reply With Quote
Old 05-21-11, 12:55 PM
 
 
 
 
Reply

Tags
31, 40, amp, calipers, cel, code, lexus, madmax98, mount, sc, sc400, sc430, supra, supraforums, tt

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your GS today? subzero32 GS - Second Generation 315 09-07-14 08:14 PM
What did you do to your THIRD Generation RX today? FishCandy RX - Third Generation 253 08-31-14 10:08 PM
Do you need Premium Gas in the 2RX (merged discussion threads) lexuslover RX - Second Generation 554 04-19-14 12:13 PM
What Did You Do To Your Car Today? Jim2jz IS - First Generation 480 11-17-12 06:07 PM
What did you do to your ES300 today? Victor520 ES300 and ES330 3 10-12-12 03:39 AM

All times are GMT -7. The time now is 06:42 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info