Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 400/300
Sign in using an external account
Register Forgot Password?

my sc400 is throwing 8 codes =( help me fix PLEASE!

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-19-10, 10:59 PM   #1
iridebmx
Lexus Test Driver
Trader Score: (6)
 
iridebmx's Avatar
 
Join Date: May 2010
Location: Colorado Springs, CO
Posts: 1,442
Default my sc400 is throwing 8 codes =( help me fix PLEASE!

Well I just checked my diagnostic box because my car is having a starting problem about every 2 weeks or so. And come to find out I am throwing way more codes than just the one I thought it was....


12- RPM signal
24- IAT Sensor Signal
25- A/F Ratio Lean Malfunction
26- A/F Ratio Rich Malfunction
52- KS Signal
55- KS Signal
71- EGR System Malfunction
78- Fuel Pump Control

I just bought this car about 2-3months ago and I don't know much about them what all do I need to get ALLLL those fixed??

Thanks in Advance to anyone knowledgeable about this.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
iridebmx is offline   Reply With Quote
Old 07-19-10, 11:22 PM   #2
iridebmx
Lexus Test Driver
Trader Score: (6)
 
iridebmx's Avatar
 
Join Date: May 2010
Location: Colorado Springs, CO
Posts: 1,442
Default

This is what I have come up

-Clean my mafs - but with what?
-buy two new distributors
-maybe new knock sensors to fix the Air Fuel readings BUT first go and buy some spark plugs and seafoam my car before i spend $300 on Knock sensors
-new egr position sensor


I dont know what to do about the fuel pump code though?

also correct me if i am wrong please

Last edited by iridebmx; 07-19-10 at 11:27 PM..
iridebmx is offline   Reply With Quote
Old 07-19-10, 11:25 PM   #3
Carfreak70
Lexus Champion
Trader Score: (15)
 
Carfreak70's Avatar
 
Join Date: Dec 2007
Location: Tennessee
Posts: 2,117
Carfreak70852 Inline 6 2JZGTE
Send a message via AIM to Carfreak70
Default

Sounds like your ECU went haywire to me...
__________________
Car List
1st 95' SC400, 2nd 86' Toyta Supra, 3rd 92' SC300 5 Speed, 4th 89' Toyota Supra Turbo, 5th 97' SC300 (#1 of 120),
6th 95' GS300 2JZGTE Single Turbo, 7th SC300 2JZGTE Single Turbo 6 speed, 8th 92' Lexus SC300 5 speed, 9th 92' SC300 Autotragic, 10th 93' Lexus SC400, 11th 92' Lexus SC400, 12th 88' Toyota Supra Turbo (running), 13th 1992 SC300 1jzgte, 14th Suzuki Sidekick 1.8 sport (DD POS), 15th 01' IS300, 16th 99' SC300 17th 1994 GS300 18th 1991 Mazda Miata 19th 1993 GS300
Carfreak70 is offline   Reply With Quote
Old 07-19-10, 11:29 PM   #4
iridebmx
Lexus Test Driver
Trader Score: (6)
 
iridebmx's Avatar
 
Join Date: May 2010
Location: Colorado Springs, CO
Posts: 1,442
Default

So all that may not be wrong and its a computer problem?

for some reason that sounds hard to believe but i have no idea... i shouldve stayed with my s13 that i know up and down left and right


RIGHT NOW my car is doing these things:

-rpm and mph gauges dont always start working until i drive for like 10-15mins than they come on randomly and stay until i turn the car off and back on. sometimes they come on and stay on from the get go or 1 at a time.... TALKING ABOUT ACTUALLY READINGS NOT LIGHTS

-lately i have to left my car get fuel by leaving my car in the on position without starting it so fuel pumps or it wont start up right away (i bypassed the fuel pump ecu) COULD MY BYPASSING THE ECU THROW MOST OF THESE FUEL CODES??? I didnt splice the wire and plug the plug back in a just pinned the two wires through the plug.

-it is laggy from around 0-25mph, BUT sometimes just flies right up there....

hmm thats about all the problems i am having...

Last edited by iridebmx; 07-19-10 at 11:37 PM..
iridebmx is offline   Reply With Quote
Old 07-19-10, 11:32 PM   #5
Carfreak70
Lexus Champion
Trader Score: (15)
 
Carfreak70's Avatar
 
Join Date: Dec 2007
Location: Tennessee
Posts: 2,117
Carfreak70852 Inline 6 2JZGTE
Send a message via AIM to Carfreak70
Default

I mean the fact that your car just all of the sudden throws 8 codes leads me to believe its the ECU.
__________________
Car List
1st 95' SC400, 2nd 86' Toyta Supra, 3rd 92' SC300 5 Speed, 4th 89' Toyota Supra Turbo, 5th 97' SC300 (#1 of 120),
6th 95' GS300 2JZGTE Single Turbo, 7th SC300 2JZGTE Single Turbo 6 speed, 8th 92' Lexus SC300 5 speed, 9th 92' SC300 Autotragic, 10th 93' Lexus SC400, 11th 92' Lexus SC400, 12th 88' Toyota Supra Turbo (running), 13th 1992 SC300 1jzgte, 14th Suzuki Sidekick 1.8 sport (DD POS), 15th 01' IS300, 16th 99' SC300 17th 1994 GS300 18th 1991 Mazda Miata 19th 1993 GS300
Carfreak70 is offline   Reply With Quote
Old 07-20-10, 05:05 AM   #6
iridebmx
Lexus Test Driver
Trader Score: (6)
 
iridebmx's Avatar
 
Join Date: May 2010
Location: Colorado Springs, CO
Posts: 1,442
Default

its not all of a sudden... its had a cel on for about a month now
iridebmx is offline   Reply With Quote
Old 07-20-10, 08:01 PM   #7
iridebmx
Lexus Test Driver
Trader Score: (6)
 
iridebmx's Avatar
 
Join Date: May 2010
Location: Colorado Springs, CO
Posts: 1,442
Default

anyone else? anyone have knowledge of their cars messing up?
iridebmx is offline   Reply With Quote
Old 07-20-10, 08:01 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Misfiring P0300, P0171, P0174 clintbw ES300 and ES330 12 04-01-14 08:38 AM
99 es300 codes? Sublime69 ES300 and ES330 3 02-11-13 01:36 PM
Engine Diagnostic tools and pc tools (includes all trouble codes) Australian RX - First Generation 13 09-19-11 02:19 AM
Lexus Specific CEL Codes Clear2Cloz GS - Second Generation 1 06-15-11 12:15 AM
Numerous CEL codes - need advice JAB RX - First Generation 6 10-15-09 12:43 AM


Tags
1992, 400, 52, code, egr, fix, iat, ks, lexus, pump, sc, sc400, senso, sensor, signal, start, stay, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 05:09 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info