sc400 (97) GTE 6spd (speedometer not working) - Club Lexus Forums

Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC- 1st Gen (1992-2000)
Log In 

sc400 (97) GTE 6spd (speedometer not working)

Thread Tools Search this Thread
Old 07-20-14, 01:02 PM   #1
Driver School Candidate
Trader Score: (0)
AlaskaUSA's Avatar
Join Date: Mar 2014
Location: Nv
Posts: 33
Default sc400 (97) GTE 6spd (speedometer not working)

the 97 sc400 has a 6spd GTE swap and it starts runs etc ok... the TACH works but the speedometer doesn't work and doesn't read speed at all.

any idea where I can start looking, change or fix?

AlaskaUSA is offline   Reply With Quote
Old 07-20-14, 01:26 PM   #2
Lexus Fanatic
Trader Score: (15)
97-SC300's Avatar
Join Date: Jun 2006
Location: WI/IL
Posts: 7,394

Is the speed sensor connected?

Under Construction.........
97-SC300 is offline   Reply With Quote
Old 07-21-14, 11:10 AM   #3
Lexus Champion
Trader Score: (14)
CatManD3W's Avatar
Join Date: May 2013
Location: SteelCity
Posts: 1,630

I have a 92 SC300 that I swapped over to GTE.....I have tried everything to get my speedo to work.....i.e new speed sensor......checked wiring over a dozen times per wiring diagrams.....I am thinking that the actual gauge itself is shot....
1992 Lexus SC300 Original 5spd #586 Sandstone Beige Metallic (4K9) |1 of 1601|
2JZGTE/Tripod Built R154 w/S366 Undergoing Upgrades...

1999 Toyota Tacoma X-Cab |5VZFE|5spd|4wd|Shrockworks Front Bumper|2.5" Bilstein Suspension| LCE Engineering Pro Clutch Kit|Magnaflow exhaust|33X10.5X15 BFG A/T|OEM 15X7's
CatManD3W is offline   Reply With Quote
Old 07-21-14, 05:32 PM   #4
Lexus Test Driver
Trader Score: (4)
Vrank's Avatar
Join Date: Feb 2011
Location: TX
Posts: 960

^ some days I have to give my dash a good smack for the speedo and/or tach to work in my daily beater 400.
Vrank is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
1993 LS 400, Speedometer sometimes works and sometimes doesn't (sits at 0) andyschiu LS - 1st and 2nd Gen (1990-2000) 8 05-04-15 06:55 PM
speedometer messed up how to fix or solve problem soccergk SC- 1st Gen (1992-2000) 5 02-12-15 11:28 PM
gte 6spd swap (speedometer not working) AlaskaUSA SC- 1st Gen (1992-2000) 3 08-31-14 11:34 PM
sc300/400 gte swap (Fan shroud) AlaskaUSA SC- 1st Gen (1992-2000) 13 06-13-14 08:48 PM
6spd (2, 4th gears) not going in gear AlaskaUSA SC- 1st Gen (1992-2000) 4 05-14-14 08:05 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 05:07 PM.

Copyright © 2000-2015 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS