sc400 (97) GTE 6spd (speedometer not working) - Club Lexus Forums


sc400 (97) GTE 6spd (speedometer not working)

Reply
 
 
 
Thread Tools Search this Thread
Old 07-20-14, 01:02 PM   #1
AlaskaUSA
Driver School Candidate
Thread Starter
 
AlaskaUSA's Avatar
 
Join Date: Mar 2014
Location: Nv
Posts: 33
Default sc400 (97) GTE 6spd (speedometer not working)

the 97 sc400 has a 6spd GTE swap and it starts runs etc ok... the TACH works but the speedometer doesn't work and doesn't read speed at all.

any idea where I can start looking, change or fix?

thanks
AlaskaUSA is offline   Reply With Quote
Old 07-20-14, 01:26 PM   #2
97-SC300
Lexus Fanatic
iTrader: (16)
 
97-SC300's Avatar
 
Join Date: Jun 2006
Location: Illinois
Posts: 8,013
Default

Is the speed sensor connected?
97-SC300 is offline   Reply With Quote
Old 07-21-14, 11:10 AM   #3
CatManD3W
Lexus Champion
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 2,072
Default

I have a 92 SC300 that I swapped over to GTE.....I have tried everything to get my speedo to work.....i.e new speed sensor......checked wiring over a dozen times per wiring diagrams.....I am thinking that the actual gauge itself is shot....
CatManD3W is offline   Reply With Quote
Old 07-21-14, 05:32 PM   #4
Vrank
Lexus Test Driver
iTrader: (4)
 
Vrank's Avatar
 
Join Date: Feb 2011
Location: TX
Posts: 968
Default

^ some days I have to give my dash a good smack for the speedo and/or tach to work in my daily beater 400.
Vrank is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1993 LS 400, Speedometer sometimes works and sometimes doesn't (sits at 0) andyschiu LS - 1st and 2nd Gen (1990-2000) 8 05-04-15 06:55 PM
gte 6spd swap (speedometer not working) AlaskaUSA SC- 1st Gen (1992-2000) 3 08-31-14 11:34 PM
sc300/400 gte swap (Fan shroud) AlaskaUSA SC- 1st Gen (1992-2000) 13 06-13-14 08:48 PM
GTE 6spd a (sc400 or get a sc300)? suprat04r Performance & Maintenance 15 06-11-12 08:17 AM
speedometer and odometer stopped working RX7 RAGE Performance & Maintenance 3 11-22-10 10:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 02:45 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved