A/C smell - Club Lexus Forums

Log In 

A/C smell

Reply
 
 
 
Thread Tools Search this Thread
Old 05-22-13, 11:19 PM   #1
94Blexus
Driver School Candidate
Thread Starter
 
94Blexus's Avatar
 
Join Date: Apr 2011
Location: Illinois
Posts: 36
Default A/C smell

I have a 94 SC400...So, now that summer is here in chicago i turned on my A/C and a recurring smell is back, It is only when my system is cooling down, jut before it gets cold. It is getting worse every year.
I can't find a drain tube that might be clogged, my intake screens don't have any holes in them. What am i missing?
Thanks for any help!!!
94Blexus is offline   Reply With Quote
Old 05-23-13, 07:27 AM   #2
estomax
Lead Lap
iTrader: (2)
 
Join Date: Jan 2013
Location: WA
Posts: 490
Default

Thats mildew, and its caused by water staying in the system. most likely what you are doing is using your AC and then shutting off the car with the AC still on. This leaves the ice inside the evaporator that then melts and mildew starts feeding on it every time the car is shut off. when you turn it on you freeze it all back up and the smell goes away. What i find helps is turning off AC a mile or so before destination so the ice melts and you are still blasting air through the condenser and evaporate the water. Since the mildew is already there though, you need to get some anti mildew spray and spray it in there and hopefully it will get rid of it. The drain tube comes out right by the front subframe on the passenger side. i can't remember if in front or behind it. So check there if you can see water dripping out after having AC on for a while and then turning it off.

I haven't taken that part of my car apart yet, so i'm not sure how easy it is to access from under the dash but spraying the mildew cleaner right into the condenser area will provide you with the best results. I have previously just sprayed it into the vents with so-so results.

Last edited by estomax; 05-30-13 at 07:24 AM.
estomax is offline   Reply With Quote
Old 05-23-13, 03:20 PM   #3
94Blexus
Driver School Candidate
Thread Starter
 
94Blexus's Avatar
 
Join Date: Apr 2011
Location: Illinois
Posts: 36
Default

Thanks man! I did get spray, worked so far.
I haven't looked for the cabin filter, gonna do that today.
94Blexus is offline   Reply With Quote
Old 05-23-13, 06:36 PM   #4
1JZPWRD
1JZ Single SC400
iTrader: (59)
 
1JZPWRD's Avatar
 
Join Date: Jan 2009
Location: Alabama, Roll Tide!
Posts: 8,500
Default

Now that is something I have never done.. I will have to give it a try. Thanks for posting this detailed description of why possibly we have a smell.
1JZPWRD is offline   Reply With Quote
Old 05-28-13, 10:53 AM   #5
412eSC
Driver School Candidate
 
Join Date: Feb 2012
Location: California
Posts: 5
Default

hello ive had this same problem but i was wondering is there a way i can drain it from the drain tube?
412eSC is offline   Reply With Quote
Old 05-30-13, 07:42 AM   #6
estomax
Lead Lap
iTrader: (2)
 
Join Date: Jan 2013
Location: WA
Posts: 490
Default

The drain tube is designed to drain the water from the system without you having to do it. If your drain tube is clogged you need a coat hanger or something semi-stiff to shove up it and hopefully unclog it. either way you need to either get under your dash or under your car, no lazy way out to properly fix this. It's a preventative maintenance thing to keep from happening
estomax is offline   Reply With Quote
Old 05-30-13, 09:29 AM   #7
Tabaka
Lexus Champion
iTrader: (8)
 
Join Date: Mar 2010
Location: Dale City, VA
Posts: 3,808
Default

$5.00 fix

Tabaka is offline   Reply With Quote
Old 05-30-13, 12:31 PM   #8
ShiftyD2k
Lead Lap
iTrader: (18)
 
ShiftyD2k's Avatar
 
Join Date: May 2008
Location: SoCal
Posts: 756
Default

same me i hate smell when i turn off a/c.... it could cabin filter got dirt..?
ShiftyD2k is offline   Reply With Quote
Old 06-27-13, 08:50 PM   #9
hun1800
Driver School Candidate
 
Join Date: Jul 2011
Location: fla
Posts: 5
Default odor

Quote:
Originally Posted by 94Blexus View Post
I have a 94 SC400...So, now that summer is here in chicago i turned on my A/C and a recurring smell is back, It is only when my system is cooling down, jut before it gets cold. It is getting worse every year.
I can't find a drain tube that might be clogged, my intake screens don't have any holes in them. What am i missing?
Thanks for any help!!!
go to toyota and get a kit that forces foam thru your system and a spray that sprays in your vent, the cost is $20 you can do it your self. also when have you changed the cabin filter? the cabin filter will be a little tricky . get the exact model for your car so it will fit.
hun1800 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
A/C lights blinks 340massive LS - 1st and 2nd Gen (1990-2000) 10 10-27-15 06:43 PM
A/c problem Diazg07 LS - 1st and 2nd Gen (1990-2000) 1 06-24-12 08:24 PM
Musty Smell when A/C is on blanquitom ES - 1st to 4th Gen (1990-2006) 8 05-23-11 05:12 PM
diy question: how to put a/c gas thesung41 ES - 1st to 4th Gen (1990-2006) 2 08-13-09 08:33 PM
Burning smell - HELP! EnzoRX RX - 1st Gen (1999-2003) 4 10-19-03 09:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 10:36 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved