Aftermarket Climate Control - Page 11 - Club Lexus Forums

Log In 

Aftermarket Climate Control

Reply
 
 
 
Thread Tools Search this Thread
Old 07-08-14, 10:17 PM   #151
oldManTan
Lexus Champion
 
Join Date: Jan 2014
Location: illinois
Posts: 1,843
Default

i'm gonna wait until this is like 200 bucks lol.
oldManTan is offline   Reply With Quote
Old 07-09-14, 02:46 AM   #152
KahnBB6
Moderator
iTrader: (5)
 
Join Date: Jun 2010
Location: California
Posts: 3,193
Default

Quote:
Originally Posted by oldManTan View Post
i'm gonna wait until this is like 200 bucks lol.
That's not going to happen. The price is already adjusted :P But hey, maybe they'll adjust it some more. Just not to $200.

I've also been planning to buy one of these and I am very interested to know if they stand behind their product or not. Not assuming anything, just waiting to hear what people's impressions are.
KahnBB6 is offline   Reply With Quote
Old 07-09-14, 03:14 AM   #153
CBlack0
Driver School Candidate
 
Join Date: Jun 2014
Location: Florida
Posts: 9
Default

yeah, looks crazy awesome!
CBlack0 is offline   Reply With Quote
Old 07-10-14, 09:06 AM   #154
Durrby
Lexus Test Driver
iTrader: (3)
 
Join Date: Mar 2009
Location: Florida
Posts: 908
Default

Quote:
Originally Posted by KahnBB6 View Post
You should ask them for one, or at least to inspect and repair the one they sent you. It's a new product and there may be a couple of glitchy ones in their first batch. They should stand behind it if you can send it in.

If for some reason they won't honor an inspection/repair/replacement.... then that's another story.
Quote:
Originally Posted by eknine9 View Post
Also if they don't want to do that I'd like to hear about it since I intend on dropping part of my paycheck on it in 2-3 days.
Have a whole new issue now. Drove 45 minutes yesterday to get an alignment from a recommended place. On the way there the unit just shut off. I turned the car off and on a few times and the unit didn't boot up. After a few hours I tried it again and it began to boot but froze on the lexus boot screen like it's been doing. Also I've noticed that after setting the time and date on the unit it eventually reverts back to the default Jan 1st 12:00am. I mean it's only 4 wires that were spliced so I doubt it's operator error, it works fine when it works. Had to leave my car overnight so they could raise it and realign it so I haven't been able to further look into it. After I can I will be contacting the developers of the unit for sure. This is starting to become a joke of a unit. Sorry I wasted my money at this point
Durrby is offline   Reply With Quote
Old 07-10-14, 12:06 PM   #155
oldManTan
Lexus Champion
 
Join Date: Jan 2014
Location: illinois
Posts: 1,843
Default

Quote:
Originally Posted by Durrby View Post
Have a whole new issue now. Drove 45 minutes yesterday to get an alignment from a recommended place. On the way there the unit just shut off. I turned the car off and on a few times and the unit didn't boot up. After a few hours I tried it again and it began to boot but froze on the lexus boot screen like it's been doing. Also I've noticed that after setting the time and date on the unit it eventually reverts back to the default Jan 1st 12:00am. I mean it's only 4 wires that were spliced so I doubt it's operator error, it works fine when it works. Had to leave my car overnight so they could raise it and realign it so I haven't been able to further look into it. After I can I will be contacting the developers of the unit for sure. This is starting to become a joke of a unit. Sorry I wasted my money at this point
sucks that the unit is taking a dump on you. but overnight alignment??? got my alignment at pepboys in 1 hour, and 3 month warranty so i gotta get my suspension mods in and go in for another alignment lol
oldManTan is offline   Reply With Quote
Old 07-10-14, 12:33 PM   #156
Durrby
Lexus Test Driver
iTrader: (3)
 
Join Date: Mar 2009
Location: Florida
Posts: 908
Default

I didn't want to make a long post longer but there's more to it. I had them mount tires on a new set of wheels. They were stretched and the rears didn't want to hold. So they swapped new rears to the front and reused my old rear tires. By the time they started to align it it was almost 7pm and they closed at 8. The new setup is more aggressive and trying to work with the current height (tucking tires all around) they were at -7 camber in the rear and it still wasn't clearing. They called it a night and they are working on it today by raising it and trying again. Also added Megan rear toe arms, camber arms and tracton rods so it's more than a simple alignment.
Durrby is offline   Reply With Quote
Old 07-10-14, 12:54 PM   #157
scENFORCER
Lexus Champion
 
Join Date: Oct 2006
Location: Vancouver, BC
Posts: 3,113
Default

^ been following on IG, the new wheels look great!
scENFORCER is offline   Reply With Quote
Old 07-10-14, 04:37 PM   #158
KahnBB6
Moderator
iTrader: (5)
 
Join Date: Jun 2010
Location: California
Posts: 3,193
Default

Durrby, based on what you've described I'd call Popformance and obtain an RMA number for them to inspect it and repair or replace for you. None of that sounds good. These are a brand new aftermarket design and it's possible a couple of these may have issues. I'm giving the designer/technician the benefit of the doubt that he accounted for vehicle vibration, increased vibration from stiffer suspensions or rough terrain, built in enough cooling for the electronics and used high quality parts for the internals.

And you have the firmware updated to the latest revision, correct?

They should inspect it and see what the issue is.
KahnBB6 is offline   Reply With Quote
Old 07-11-14, 09:09 AM   #159
eknine9
Lexus Test Driver
iTrader: (8)
 
eknine9's Avatar
 
Join Date: Mar 2012
Location: TX
Posts: 1,062
Default

Seems new units aren't even available right now... guess I'll buy something else lol.
eknine9 is offline   Reply With Quote
Old 07-11-14, 03:44 PM   #160
KahnBB6
Moderator
iTrader: (5)
 
Join Date: Jun 2010
Location: California
Posts: 3,193
Default

^^ I just saw that. Probably the designer/owner has seen a couple of issues crop up in the first batch and is correcting them for the next run. Or else it's just that much of a low volume product that it can only be available in batches.

Still want to hear any feedback from current owners who had to send theirs back for repair or replacement.
KahnBB6 is offline   Reply With Quote
Old 07-11-14, 07:29 PM   #161
Duck05
Lexus Test Driver
 
Duck05's Avatar
 
Join Date: Sep 2011
Location: CA
Posts: 889
Default

My unit failed after just one week. I held back reporting that on here since these are new units and Patrick has put a lot of design, effort, testing, into the controller and it is always difficult getting a new product off the ground. Especially one so specialized for our cars.

While not the "swiftest" at turn around, he was really responsive as to communicating what was going on with my unit. The unit experienced a "cold solder" connection on the main chip which was quite involved to swap out. He even went ahead and made a few other hardware changes and loaded the latest firmware.

I just got it re-installed today and on the 90 minute drive home so far so good. This is a step up from the stock climate controller and kind of a "luxury" item; those that take advantage of the gauge display options (the install/hook up process, accuracy, visual quality, etc) will be the real benefactors of this product. The climate control portion is an upgrade but certainly not essential (but real cool looking.....).

Not sure what others have to say about his "customer service" but I can not complain and am happy with the response and results. It will now be up to the unit to perform and be reliable. However, if it does fail again I am confident that he will make it good.....
Attached Thumbnails
Aftermarket Climate Control-sc300-212.jpg  
Duck05 is offline   Reply With Quote
Old 07-12-14, 02:14 AM   #162
KahnBB6
Moderator
iTrader: (5)
 
Join Date: Jun 2010
Location: California
Posts: 3,193
Default

Duck05, thank you for that update and review. I'm glad to hear Patrick (the designer) is responding to initial build issues as one would expect. I figured it had something to do with the type of solder used (lead-free solder?) which I know can be tricky. Hope he's solved it by now and is implementing the fix in future builds.

I have also been looking seriously at this unit to serve virtual gauges for oil pressure, boost pressure, A/F ratio and fuel pressure. I think his boost controller option may not be the best option for me as I've heard that the HKS EVC-4/5/6 are the only boost controllers that work well with GTE sequential turbos. Obviously most people aren't running those.

Thanks and do keep us updated especially if you take advantage of some of the optional firmware.
KahnBB6 is offline   Reply With Quote
Old 07-12-14, 12:33 PM   #163
jimbow
Rookie
 
Join Date: May 2008
Location: Maryland
Posts: 56
Default

I like it. But I always loved the way the mkiv supra climate controls look. I may try to adapt them in my car in the next few years.
jimbow is offline   Reply With Quote
Old 08-10-14, 01:51 PM   #164
Duck05
Lexus Test Driver
 
Duck05's Avatar
 
Join Date: Sep 2011
Location: CA
Posts: 889
Default

Been about a month (after the repair) and the unit is performing as expected...... Sent a quick note to Patrick.

Hard to tell how many members invested in this upgrade. Would like to see more pics and get status along with anyone leveraging the capabilities beyond the climate functions.
Duck05 is offline   Reply With Quote
Old 08-10-14, 03:06 PM   #165
eknine9
Lexus Test Driver
iTrader: (8)
 
eknine9's Avatar
 
Join Date: Mar 2012
Location: TX
Posts: 1,062
Default

Quote:
Originally Posted by Duck05 View Post
Been about a month (after the repair) and the unit is performing as expected...... Sent a quick note to Patrick.

Hard to tell how many members invested in this upgrade. Would like to see more pics and get status along with anyone leveraging the capabilities beyond the climate functions.
Good to hear. I still want to buy one, but lol still says they are unavailable so I'll just sit on the money, it's about time for me to get a new front lip anyways.
eknine9 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Climate control resets to foot setting wbzautocus LS - 1st and 2nd Gen (1990-2000) 3 03-05-16 07:05 PM
CA WTB: Climate controls Turch 2Gen GS430 / 400/ 300 Classifieds (98-05) 2 02-06-15 07:17 PM
VA WTB: Climate control Rollaboy SC430 Classifieds 2 01-17-15 10:20 AM
Where is the fuse for climate control? Ineedspeed SC- 1st Gen (1992-2000) 3 06-30-14 11:36 AM
Looking for wiring diagram.. (climate control pinouts) Davidddd SC- 1st Gen (1992-2000) 3 08-25-13 07:18 PM


Tags
aftermarket, aswc1, climate, control, controls, gs300, installed, lcd, lexus, replacing, sc300, sc430, screen, stereo, touch, touchsceeen, vehicle

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 11:23 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved