What did you do to your SC today? - Page 424 - Club Lexus Forums

Log In 

What did you do to your SC today?

Reply
 
 
 
Thread Tools Search this Thread
Old 08-18-16, 07:16 AM   #6346
nnnickkk
Lexus Test Driver
iTrader: (1)
 
nnnickkk's Avatar
 
Join Date: Mar 2004
Location: California
Posts: 856
Default

Dropped the SC400 off at the Magnaflow r&d center yesterday for them to develop a SC cat back. Hopefully getting the car back Friday night so will make a thread and update everyone.
nnnickkk is offline   Reply With Quote
Old 08-18-16, 09:06 AM   #6347
macna
Driver School Candidate
 
Join Date: Oct 2012
Location: TN
Posts: 11
Default

Started a W58 swap in my SC400


macna is offline   Reply With Quote
Old 08-18-16, 08:49 PM   #6348
ross3857
Driver
iTrader: (3)
 
Join Date: Jul 2012
Location: CA
Posts: 184
Default

Quote:
Originally Posted by Blkexcoupe View Post
Those sizes have a lot of potential to be the perfect size on a SC if you were to consider relipping them. Did the originally come off of a NSX? Based on the lip sizes and offset it seems like your fronts would clear a supra tt caliper without a spacer too.
It was made for a GS400. Those wheels clear my ISF also, ample amount of space. I am only running the LS brakes up front and not a problem.
ross3857 is offline   Reply With Quote
Old 08-20-16, 01:02 AM   #6349
JoshuaI6
Driver School Candidate
 
Join Date: Apr 2016
Location: Kansas
Posts: 2
Default Headlight restoration

Used the 3M headlight restoration kit to clean up my headlights and fogs.
JoshuaI6 is offline   Reply With Quote
Old 08-20-16, 02:01 PM   #6350
CoOl21
Driver School Candidate
 
Join Date: Feb 2016
Location: BC
Posts: 18
Default

Shout out to the guys over at JZZ30.com

CoOl21 is offline   Reply With Quote
Old 08-21-16, 03:49 PM   #6351
Sylexus
Driver
iTrader: (1)
 
Join Date: Nov 2012
Location: Texas
Posts: 129
Default

Cleaned just my interior today since the weather in central Texas has been so crappy for the past week. As soon as it clears up and continues with the regularly scheduled program I'll wash and add another coat of wax.

Soon: Full APT AC style polyurethane kit, 5Zigen Fireball replica mufflers, window tint (has NONE, I'm dying in Texas) black interior dye and still deciding on wheels/suspension set up.

Last edited by Sylexus; 08-21-16 at 04:07 PM.
Sylexus is offline   Reply With Quote
Old 08-21-16, 09:26 PM   #6352
ar3
Driver School Candidate
 
Join Date: May 2016
Location: California
Posts: 32
Default

Quote:
Originally Posted by Sylexus View Post
Cleaned just my interior today since the weather in central Texas has been so crappy for the past week. As soon as it clears up and continues with the regularly scheduled program I'll wash and add another coat of wax.

Soon: Full APT AC style polyurethane kit, 5Zigen Fireball replica mufflers, window tint (has NONE, I'm dying in Texas) black interior dye and still deciding on wheels/suspension set up.
Tell me about it dude, my SC all black leather interior + no tint = oven on wheels
ar3 is offline   Reply With Quote
Old 08-21-16, 10:58 PM   #6353
Sylexus
Driver
iTrader: (1)
 
Join Date: Nov 2012
Location: Texas
Posts: 129
Default

Quote:
Originally Posted by ar3 View Post
Tell me about it dude, my SC all black leather interior + no tint = oven on wheels
It also doesn't help that my AC isn't working. I charged it up with my old work's machine (used to be an auto technician) and it worked amazing for that evening. Went out the next day and it was back to blowing out hot. Now when I turn just my fan on it acts erratically. Goes from full blast to low, and back and forth.

No idea whats up with it. All I can say is that if my windows didn't roll down, I'd be parking her for a bit. lol.
Sylexus is offline   Reply With Quote
Old 08-21-16, 11:17 PM   #6354
ar3
Driver School Candidate
 
Join Date: May 2016
Location: California
Posts: 32
Default

Quote:
Originally Posted by Sylexus View Post
It also doesn't help that my AC isn't working. I charged it up with my old work's machine (used to be an auto technician) and it worked amazing for that evening. Went out the next day and it was back to blowing out hot. Now when I turn just my fan on it acts erratically. Goes from full blast to low, and back and forth.

No idea whats up with it. All I can say is that if my windows didn't roll down, I'd be parking her for a bit. lol.
That's weird, my climate control was acting funky too but it fixed itself today. Before my heater would blow cold air opposite of yours. But as I was installing a double din, I connected everything back; climate, hazard, etc. then I turned on the heater to see if the problem went away and it did. I originally thought it was my heater control valve, not that I need heat at this time of the year, but I'm OCD like that and needed to fix it.
ar3 is offline   Reply With Quote
Old 08-22-16, 03:45 PM   #6355
ross3857
Driver
iTrader: (3)
 
Join Date: Jul 2012
Location: CA
Posts: 184
Default

Quote:
Originally Posted by CoOl21 View Post
Shout out to the guys over at JZZ30.com

nice, that is on my to buy list next month.
ross3857 is offline   Reply With Quote
Old 08-23-16, 08:21 PM   #6356
BubbaGump
Driver School Candidate
 
Join Date: Aug 2016
Location: NY
Posts: 8
Default

Between last night and tonight I managed to get one engine mount out and a new one back in...waiting to be tightened tomorrow night. Other side mount is loose and ready to come off. Holy crap, this is turning out to be the most difficult thing I've ever had to do on any of my cars. I am used to Subaru and the more I work on my SC the more I appreciate my Legacy,
BubbaGump is offline   Reply With Quote
Old Yesterday, 02:38 AM   #6357
ar3
Driver School Candidate
 
Join Date: May 2016
Location: California
Posts: 32
Default

Quote:
Originally Posted by BubbaGump View Post
Between last night and tonight I managed to get one engine mount out and a new one back in...waiting to be tightened tomorrow night. Other side mount is loose and ready to come off. Holy crap, this is turning out to be the most difficult thing I've ever had to do on any of my cars. I am used to Subaru and the more I work on my SC the more I appreciate my Legacy,
Nice! I had a Legacy (NA 06') that I sold then got the SC300. You got that right about the EJ engines being easier to work on not sure about reliability tho
ar3 is offline   Reply With Quote
Old Today, 08:45 PM   #6358
Ramblerman
Pole Position
 
Ramblerman's Avatar
 
Join Date: Jan 2014
Location: N.W.,Pa.
Posts: 320
Default

Waiting to get it back from the shop, as I have been to busy to change the timing belt and such, so I have allowed some one else to touch my baby!
Ramblerman is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
what did you do today to your gs 94vipd GS - 1st Gen (1993-1997) 35 04-18-16 07:04 AM
What did you do with your RC today equalme RC - 1st Gen (2015-present) 1 05-12-15 02:28 PM
Do you need Premium Gas in the 2RX (merged discussion threads) lexuslover RX - 2nd Gen (2004-2009) 581 12-01-14 02:31 PM
Getting new exhaust installed today? chris6878 IS F (2008-2014) 11 05-23-11 12:18 PM
what's goin on? seangworld CL of Hawaii 4 12-04-08 01:20 AM


Tags
31, 40, amp, calipers, cel, code, lexus, madmax98, mount, sc, sc400, sc430, supra, supraforums, tt

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 11:56 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved