Go Back   Club Lexus Forums > Lexus Model Forums > RX Models > RX - Second Generation
Sign in using an external account
Register Forgot Password?

clicking sound after trying to remove rear rotor with parking brake on.

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-22-14, 04:16 PM   #1
mitch1927
Driver School Candidate
Trader Score: (0)
 
mitch1927's Avatar
 
Join Date: Jul 2014
Location: Kentucky
Posts: 1
Question clicking sound after trying to remove rear rotor with parking brake on.

2007 RX350 AWD

Hello all and thank you for the wealth of information that I have consumed from this forum.

Now, before you call me a moron...I'm already aware of that status. I've replaced front brakes and rotors many times but only rear brakes twice, but still should have had better sense on this one. Here's what happened...

As expected it was hard to get the rear rotors off, so I used the counter screw holes. However, because I had the parking brake on, it "unstuck, but was still held on by something. It wasn't until I kept turning the screws until they stripped and the rotor was still hanging on the wheel hub (though at an angle) that I realized that the parking brake is probably holding on to it. Sure enough, I disengaged the brake and the rotor came off with ease.

In the process of trying to get the rotor off with the ebrake on, I bent the spring pin holding the ebrake in place (not the straight one, but the one with the u-shape in it. I was able to bend the pin back into place and got it put back together so that the spring cap doesn't stick out any more than it's twin on the other side of the wheel (it does not come close to rubbing against the wheel hub.

I replaced the brakes and rotors which went well from there. However, there is a loud clicking/bumping sound with each wheel rotation coming from that same wheel (left rear). I took the wheel and rotor off and the ebrake spring is still in place and not at risk of hitting anything upon rotation. The parking brake pad is firmly in place against the surface behind it as it should be and nothing is floating loose or seems out of place. It could have nothing to do with the ebrake, in fact I could have damaged something else in my effort to "force" the rotor off with the ebrake engaged.

Any thoughts on what this could be? I suspect something to do with the ebrake, but not sure about that.

One more thing, there is some play when turning the wheel hub, not by grabbing the 3 and 9 positions and rocking it (that is tight as it should be), but if I can turn the hub clockwise or counter clockwise just a fraction of a turn (5 degrees maybe) without it turning the whole axle, etc. This may be normal, but just checking.

thanks in advance.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!

Last edited by mitch1927; 07-22-14 at 04:23 PM.. Reason: forgot something
mitch1927 is offline   Reply With Quote
Old 07-22-14, 04:16 PM
 
 
 
 
Reply

Tags
clicking, ebrake, parking brake, rotor, rx350

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 GX parking brake noise. Randy B GX - Second Generation 1 08-20-14 09:08 AM
Front Brake Pads Touching the Rotors Jack1995 IS - Third Generation 1 04-06-14 11:53 PM
E-brake Not working as well... Nsteezyy Suspension and Brakes 3 01-10-14 06:52 AM
BBK issues (detailed explanation) Adam350is Suspension and Brakes 10 08-08-13 01:20 PM
Emergency Brake Noises hungryeddy ES300 and ES330 1 01-28-13 12:45 PM

All times are GMT -7. The time now is 11:52 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info