Go Back   Club Lexus Forums > Lexus Model Forums > RX Models > RX - Second Generation
Sign in using an external account
Register Forgot Password?

A/C problem for 2004 RX330

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-25-11, 07:51 PM   #16
quantfutur
Rookie
Trader Score: (0)
 
Join Date: Feb 2011
Location: MA
Posts: 99
Default

Quote:
Originally Posted by mschluns View Post
ai had similar problems with my 04 rx, my problem was related to a radiator leak...The car didnot overheat but the radiator level was low enuf to screw up the cooling/heating controls...there is a recall on these radiators, Lexus replaced mine in 2010...
There is a recall on the radiators? I am having problems with my heater (hot/cold on 80+ to HIGH heat)... and had low coolant. Why were the radiators recalled? Because they are leaking or because they mess up the cooling/heating controls somehow? I know this post is to a dated thread.....
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
quantfutur is offline   Reply With Quote
Old 10-25-11, 09:39 PM   #17
RX330inFL
Lexus Champion
Trader Score: (0)
 
Join Date: May 2006
Location: FL
Posts: 4,000
Default

Quote:
Originally Posted by quantfutur View Post
There is a recall on the radiators? I am having problems with my heater (hot/cold on 80+ to HIGH heat)... and had low coolant. Why were the radiators recalled? Because they are leaking or because they mess up the cooling/heating controls somehow? I know this post is to a dated thread.....
The recall was due to leaking at the bottom. They extended the warranty on the radiator past its original expiration. Cannot remember the length of the extension . You may find information on that if you search the forums.
RX330inFL is offline   Reply With Quote
Old 08-03-14, 06:41 PM   #18
farry
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2014
Location: ks
Posts: 1
Default The A/C in off when the car stops

HI guys, I have RX330 2004, the a/c is not working and I can't hear the compressor is clicking when the car is not moving , however when the car is moving the a/c is fine
farry is offline   Reply With Quote
Old 08-18-14, 11:49 AM   #19
mpatton
Rookie
Trader Score: (0)
 
Join Date: Oct 2013
Location: al
Posts: 79
Default

Quote:
Originally Posted by mschluns View Post
ai had similar problems with my 04 rx, my problem was related to a radiator leak...The car didnot overheat but the radiator level was low enuf to screw up the cooling/heating controls...there is a recall on these radiators, Lexus replaced mine in 2010...
Do you have any of the info on the recall? I bought an '04 this year and since I've had it, you can always smell a slight trace of coolant burning off. Dealer said they can't find a leak and proposed maybe it was spillover, but 11 months later, it's clearly not spill over being burnt off.

Thanks!
mpatton is offline   Reply With Quote
Old 08-18-14, 12:51 PM   #20
Rainbird
Lexus Test Driver
Trader Score: (0)
 
Join Date: Apr 2006
Location: California
Posts: 1,359
Default

I don't think there was a recall on the radiator but there was a TSB (see below). Lexus would replace the radiator if it was found defective. These TSB's usually have a time limit, so most likely a 2004 is not covered.
Attached Images
 
__________________
2007 RX350 - Savannah Metallic
Thundercloud Grille
Rainbird is offline   Reply With Quote
Old 08-18-14, 03:51 PM   #21
mpatton
Rookie
Trader Score: (0)
 
Join Date: Oct 2013
Location: al
Posts: 79
Default

Yeah, I'd be shocked if anything 10 yrs later is covered unless it's going to turn the car into a ball of fire and even then I think it's a stretch.

Any advice on finding a leak? I figured if the dealer can't find it, but we can all smell it, it's clearly leaking.

The AC made an awful groan this afternoon that I've never heard before and the green a/c button on the console blinked and I switched it off and it came back on and blew cold air just fine. I added some coolant because it was low...hoping that's the issue and not a compressor, etc.

Thanks
mpatton is offline   Reply With Quote
Old 08-18-14, 03:51 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Air conditioner not working, no cold air, no vents. No A/C! Alex818 SC 430 12 07-13-13 02:05 AM
2004 RX 330, Loud Clicking in Engine, Related to Climate Control System(?) jspeciner RX - Second Generation 13 06-12-13 11:36 PM
Air Condition Problem bombermani IS - Second Generation 4 05-26-13 02:22 PM
Really Weird Climate Control Problem MattStarr SC 400/300 19 08-09-11 01:05 PM
IS300 a/c temperature isses mooingchic IS - First Generation 3 12-25-10 12:50 PM


Tags
04, 2008, 350, ac, air, blowing, conditioner, harrier, hot, lexus, location, problem, relais, relay, rx, rx330, toyota

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 10:18 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info